-   Debian (
-   -   difficulty installing java (

walterbyrd 01-11-2006 08:42 PM

difficulty installing java
Downloaded both jre-1_5_0_06-linux-i586.bin and jre-1_5_0_06-linux-i586-rpm.bin from sun.

I have alien, I thouhgt I might be able to use that with the rpm package.

Logged in as root, I tried:

# /bin/sh jre-1_5_0_06-linux-i586.bin

Read through the long agreement, and finally got:

Do you agree to the above license terms? [yes or no]
jre-1_5_0_06-linux-i586.bin: line 262: ./install.sfx.8289: Permission denied
jre-1_5_0_06-linux-i586.bin: line 529: cd: jre1.5.0_06: No such file or directory

The rpm package was the same.

Brian1 01-11-2006 09:19 PM

Look over this post and see if it helps.


walterbyrd 01-12-2006 08:32 AM

Here is where I have my problem.

6. Type ' ./jdk-1_5_0_05-nb-4_1-linux-ml.bin ' hit enter ( This extracts the file and installs in /opt directory.)

I always get errors at this point, I don't know why. I did the chmod 777 thing, it didn't help.

lestoil 01-12-2006 11:34 PM

have you looked at

microsoft/linux 01-12-2006 11:40 PM

what I did to get java installed correctly was download the *.bin file, and 'apt-get install java-package'. then you can

$ fakeroot make-jpkg <whatever the long name is>.bin
This makes a .deb file, and you can just

dpkg -i <whatever the name is>.deb
to install it. It worked really well.

damienduff 01-14-2006 03:47 AM

u must be using debian or debiab-based distro, maybe u can try the blackdown java instead.

All times are GMT -5. The time now is 06:54 PM.