LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-11-2018, 11:45 AM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,613

Rep: Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716
Question Devuan 2.0 ASCII fresh installation failure


After the release of Devuan 2.0 ASCII I decided to jump in and get it. I have an aging notebook with an i5, 8GB of RAM and a 1.0TiB drive, so it is perfect. However I just cannot get Devuan 2.0 to install at all. I thought perhaps maybe it is the media I downloaded, (full DVD), so I decided to just try out with the netinstall image, and I am still not able to install I just get an error at the install process itself.

I figured maybe something is up with my notebook, so I switched to a VM on my Slackware machine but I am getting the same thing. I can reproduce the exact same issue in a VM when I was trying to install on my notebook(I have not tried the live environments yet).

I also thought maybe I was doing something wrong partitioning which could be the cause, but same error on an actual system as well as VM, guide LVM crypt, or just standard partitioning I still get an error when the install starts. I wonder can anyone reproduce my results, and has anyone had any success doing a fresh install of Devuan 2.0?

I also thought maybe it was the isos at fault, so tried a random mirror on Devuan's site - same thing; and same issue with both netinstall and full DVD iso.


I haven't tried just upgrading from 1.0 -> 2.0 though. Any ideas?
Attached Thumbnails
Click image for larger version

Name:	VirtualBox_Devuan_11_06_2018_10_34_57.png
Views:	38
Size:	29.1 KB
ID:	27864   Click image for larger version

Name:	VirtualBox_Devuan_11_06_2018_10_35_00.png
Views:	28
Size:	15.4 KB
ID:	27865   Click image for larger version

Name:	VirtualBox_Devuan_11_06_2018_10_35_04.png
Views:	26
Size:	12.3 KB
ID:	27866   Click image for larger version

Name:	VirtualBox_Devuan_11_06_2018_10_35_05.png
Views:	27
Size:	21.5 KB
ID:	27867   Click image for larger version

Name:	VirtualBox_Devuan_11_06_2018_10_35_14.png
Views:	23
Size:	35.0 KB
ID:	27868  

 
Old 06-12-2018, 09:45 AM   #2
trumpforprez
Member
 
Registered: Nov 2016
Location: UK
Distribution: Debian Jessie
Posts: 132

Rep: Reputation: Disabled
Quote:
Originally Posted by Jeebizz View Post
After the release of Devuan 2.0 ASCII I decided to jump in and get it. I have an aging notebook with an i5, 8GB of RAM and a 1.0TiB drive, so it is perfect. However I just cannot get Devuan 2.0 to install at all. I thought perhaps maybe it is the media I downloaded, (full DVD), so I decided to just try out with the netinstall image, and I am still not able to install I just get an error at the install process itself.
It looks like you are installing quite a number of desktop environments.
You could try just installing the Devuan default DE and XFCE.

Have you ensured there is no data on the target partition?
You might need to use Gparted and ensure the target partition is completely clean of any data.
 
Old 06-12-2018, 10:21 AM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,613

Original Poster
Rep: Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716
Quote:
Originally Posted by trumpforprez View Post
It looks like you are installing quite a number of desktop environments.
You could try just installing the Devuan default DE and XFCE.
Odd, the only thing I don't want is KDE, and I made sure to de-select it. Plus I wouldn't have thought that would cause any issues.

Quote:
Originally Posted by trumpforprez View Post
Have you ensured there is no data on the target partition?
You might need to use Gparted and ensure the target partition is completely clean of any data.
Both with or without gparted gives me the same error. Partitioning came way before the actual install process of course and also as I stated I even tried just using the guided setup and not the manual partitioning setup, no luck. I know I am thick but I know I am not doing anything out of the ordinary to cause this issue.
 
Old 06-12-2018, 10:41 AM   #4
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 2,613

Original Poster
Rep: Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716Reputation: 716
Choose less environments for the installation to go through without error

Quote:
Originally Posted by trumpforprez View Post
It looks like you are installing quite a number of desktop environments.
You could try just installing the Devuan default DE and XFCE.
Ok, that was it not the partitioning but choosing less environments let the installation go through to GRUB without any error. I chose only MATE and now it is going through. Not a problem since if I want the other environments I can always use synaptics to get them; it is just a bug with the installer then, because I should have been able theoretically to choose all the environments right then and there.

Your first theory was correct.

Click image for larger version

Name:	VirtualBox_Devuan_12_06_2018_09_33_38.png
Views:	16
Size:	28.6 KB
ID:	27873Click image for larger version

Name:	VirtualBox_Devuan_12_06_2018_09_35_53.png
Views:	11
Size:	17.0 KB
ID:	27874Click image for larger version

Name:	VirtualBox_Devuan_12_06_2018_09_38_22.png
Views:	9
Size:	12.3 KB
ID:	27875Click image for larger version

Name:	VirtualBox_Devuan_12_06_2018_09_38_35.png
Views:	10
Size:	27.7 KB
ID:	27876

Last edited by Jeebizz; 06-12-2018 at 10:55 AM.
 
Old 06-13-2018, 11:14 AM   #5
trumpforprez
Member
 
Registered: Nov 2016
Location: UK
Distribution: Debian Jessie
Posts: 132

Rep: Reputation: Disabled
Quote:
Originally Posted by Jeebizz View Post
Your first theory was correct.
Glad I could help you with my posts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fresh Devuan install won't look to web for pkgs, refers me to install media Wade Patton Linux - Software 1 02-04-2018 12:35 PM
Devuan & Devuan based distro thread fatmac Linux - General 8 07-30-2017 03:55 AM
Failure in installing remaining packages after fresh installation on vmware,virtualbo rupeshforu *BSD 1 02-17-2013 03:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration