LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-09-2005, 08:15 AM   #1
orca
LQ Newbie
 
Registered: Mar 2003
Location: Rio de Janeiro, Brazil
Distribution: Debian
Posts: 20

Rep: Reputation: 0
Deskjet 870Cse not printing


Hi all

I have a dual boot desktop Athlon 3000+, 1GB RAM, running a Windows XP Pro and a
Debian 31-r0a-amd64.

Despite being able to print under Windows XP, I am having problems with
printing, under Linux, on my local parallel port HP DeskJet 870Cse. I send test
pages, via either the CUPS web interface or KDE Control Center, or pages from
other applications, such as a text editor or a browser, but nothing is spilt
from the printer.

I have checked that I have all cups and foomatic relevant files; I have checked
the cups web interface and the KDE COntrol Center information relating to the
printer and they seem to be fine, except for the fact that, for the device, they
both list parallel:/dev/unkown-parallel0, and in KDE CC, there is an extra
information stating that the URI is
ipp://mauricio:631/printers/DeskJet870Cse-319-11.

Also, right after booting, I checked the dmsg messages and the lines concerning
parallel ports read:

parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,EPP]
parport0: irq 7 detected
parport0: Printer, HEWLETT-PACKARD DESKJET 870C
lp0: using parport (polling)

I checked as well the log files under /var/log/cups and everything seemed fine,
except that, in error_log the remote printers of my LAN were listed but there
was no mention of the local DeskJet printer...

I am really perplexed and any help is greatly appreciated!
 
Old 11-09-2005, 12:30 PM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
The device should be /dev/lp0
 
Old 11-10-2005, 05:33 AM   #3
orca
LQ Newbie
 
Registered: Mar 2003
Location: Rio de Janeiro, Brazil
Distribution: Debian
Posts: 20

Original Poster
Rep: Reputation: 0
Hi all,

I solved my printing problem: I made a search in Google for "/dev/unknown-parallel" and ended up in a topic here in LinuxQuestions where there was a link

http://www.hanklambert.com/Tutorial%...s/printer.html

whose directions, followed literally, allowed me to print. In particular, the device changed to /dev/lp0, as it should be of course.

Thanks all and good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HP deskjet printing on Gentoo Brakki Linux - General 0 02-12-2004 11:38 PM
HP 930 deskjet printing problems Harp00 Linux - Newbie 1 11-30-2003 01:16 AM
Color printing with HP DeskJet kamstrup Linux - Hardware 1 09-26-2003 11:00 AM
Samba Printing to XP HP DeskJet nbin Linux - Software 0 07-15-2003 09:28 PM
printing with HP deskjet 1220C noir-gel Linux - Hardware 1 02-19-2003 03:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration