-   Debian (
-   -   Debian unstable - unfixable broken packages after update. (

Imek 07-14-2005 03:20 PM

Debian unstable - unfixable broken packages after update.

For reasons I can't quite remember, I wanted to use X.Org when I started up with Debian. To accomplish this, I did a web search and found a package repository with xorg on it, installed it and everything worked fine. A while later, I upgraded to Debian unstable. Everything continued to work fine for a while, until just recently when I did an update. As near as I can tell, there is now an official xorg package that it wanted to install, but it conflicts with the xorg-common package I already had installed and so it fails. Now I have what looks like a half-installed X server and a package manager that refuses to do anything because there are broken packages. I can't simply remove the old xorg-common package then replace it with the new one either, as it will also remove every single package I have installed that depends on X.

I'm still fairly inexperienced with using apt (I'm primarly using Synaptic as a front-end), so I may be interpreting this all wrong. Is there any way around this problem that I'm missing? Any ideas would be appreciated.

Oh, and here is the output I get when trying to install the new package:


Preconfiguring packages ...
(Reading database ... 154749 files and directories currently installed.)
Unpacking x11-common (from .../x11-common_6.8.2.dfsg.1-2_all.deb) ...
dpkg: error processing /var/cache/apt/archives/x11-common_6.8.2.dfsg.1-2_all.deb (--unpack):
 trying to overwrite `/etc/X11/Xsession', which is also in package xorg-common
dpkg-deb: subprocess paste killed by signal (Broken pipe)


makuyl 07-14-2005 03:49 PM

Hmm, you could try: dpkg -i --force-all /var/cache/apt/archives/x11-common_6.8.2.dfsg.1-2_all.deb

EDIT: just checked, I don't have xorg-common, only x11-common so the forcing should work

Imek 07-14-2005 04:01 PM

Thanks, doing that then removing the old xorg package seems to have worked.

joffa 07-20-2005 06:42 AM

Excellent advice - I also had this problem and this fixed it. Thanks a heap.

ssfrstlstnm 07-20-2005 12:23 PM

I would suggest using aptitude instead of synaptic, especially for upgrades. Aptitude is much better at showing you dependency and conflict issues before you install anything so that you can get things fixed before they break your system.

All times are GMT -5. The time now is 04:09 PM.