LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-10-2011, 01:14 PM   #1
BigVig
Member
 
Registered: Feb 2006
Location: Chi-town
Distribution: Debian Sid Amd64
Posts: 108

Rep: Reputation: 15
Debian Unstable AMD64 nvidia xserver disaster w nvidia 7600 GT


I was running Debian Unstable AMD64, when the nvidia/xserver thing messed up my xserver.
I have uninstalled Xserver-xorg and re-installed xserver-xorg/testing. I have purged it and reinstalled. I have uninstalled the nvidia 280 driver and reinstalled it.
I have enabled "IgnoreABI" in xorg.conf and ignored it.
And I cannot get a working xserver. I am posting this using lynx. Many have suggested using the nouveau driver. I am using an nvidia 7600 GT and have no idea how to get the nouveau driver to work.
When gdm attempts to start the server, the error message reads that it cannot load the 'nvidia' driver because it does not exist. This is surprising because I have run m-a a-i nvidia dozens of times since this all began. And that usually works to re-install and solve the problem. Any suggestions, help, google searches, assistance that any of you could provide would be most appreciated.
Thank you.

Last edited by BigVig; 09-10-2011 at 01:18 PM.
 
Old 09-10-2011, 01:35 PM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,667

Rep: Reputation: 112Reputation: 112
Right, first get yourself a working X environment: open the xorg.conf file, find the section [Device] then change the "nvidia" reference to "vesa". Save the file and try starting X again with
Code:
startx
This should give you a GUI. Now you're in a position to restart installing the nVidia drivers again. Use the official drivers and installer this time....

PS: there's a reason why UNstable is called UNstable... If you can't fix it, stay out...
 
Old 09-10-2011, 02:59 PM   #3
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD
Posts: 1,102

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally Posted by Dutch Master View Post
there's a reason why UNstable is called UNstable... If you can't fix it, stay out...
+1

Two possible "solutions":

1) Install the nvidia driver from experimental, use the IgnoreABI option in your xorg.conf (if you decide to install the .run installer from nvidia - you'll still need to use that option as well).

2) Purge the nvidia driver and use nouveau - it should work fine with a 7600GT. To get 3D acceleration with nouveau, have a look at the debian wiki.
 
Old 09-11-2011, 06:38 PM   #4
BigVig
Member
 
Registered: Feb 2006
Location: Chi-town
Distribution: Debian Sid Amd64
Posts: 108

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Dutch Master View Post
Right, first get yourself a working X environment: open the xorg.conf file, find the section [Device] then change the "nvidia" reference to "vesa". Save the file and try starting X again with
Code:
startx
This should give you a GUI. Now you're in a position to restart installing the nVidia drivers again. Use the official drivers and installer this time....

PS: there's a reason why UNstable is called UNstable... If you can't fix it, stay out...
Thank you very much for your suggestion. I do appreciate the reply. Having queried on the issue, I posted here to appeal to the combined wisdom of the readership. As you might expect, your suggestion did not work. The error message read, "vesa: Ignoring device with a kernel bound driver."

So again, thank you very much for your reply. I will attempt to continue working on this problem as time permits. If you have any additional suggestions, I would be very happy to try them.
 
Old 09-11-2011, 06:40 PM   #5
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 646

Rep: Reputation: 93
Try booting it up without the xorg.conf once just to see if it's actually seeing the driver or not.

If that works, generate a new xorg.conf via the Nvidia Xserver Settings program, then restart X.

I have a 9600Gt in my second pc, an NVS160M in my laptop, and a 460GTX (768 MB) in my main machine, and doing it this way has never failed to work for me. Although your mileage may vary.

Last edited by Timothy Miller; 09-11-2011 at 06:43 PM.
 
1 members found this post helpful.
Old 09-11-2011, 07:54 PM   #6
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,667

Rep: Reputation: 112Reputation: 112
Sorry to hear the vesa option failed. Is the vesa driver actually installed? If not, do so and reboot. Alternatively, try if you can install (and use) the older nv driver (adjust the xorg.conf file accordingly). If all that fails, you need to get back to square 1: a more-or-less stable system. To do this, disable the unstable sources in your sources.list (and making sure you have the testing repo's properly named there). Up/downgrade your system, make sure to back up important data first! It's going to be a royal PITA and rather ugly too, so you do have your work cut out for you... You'll save a lot of trouble by booting into the testing kernel, not the unstable version (you did keep that testing kernel, did you? ) as the latter will almost surely rely on packages that needed to be purged.

Given the hassle and potential problems you may want to consider re-installing, it's probably a lot quicker too...

Best of luck!
 
Old 09-11-2011, 09:07 PM   #7
evo2
Senior Member
 
Registered: Jan 2009
Location: Japan
Distribution: Debian
Posts: 4,821

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
I'd like to second the suggestions to try using the free drivers to get X back up (you may even find you prefer the free driver). One thing that can cause the free drivers to fail is if there are any of the nvidia packages still lurking on your system.

Run the following to check:
Code:
dpkg -l '*nvidia*'
If this shows any of these packages are installed, remove them. You should also check that you really have the nouveau driver installed (xserver-xorg-video-nouveau), and that you do not have an xorg.conf.

If the above doesn't work please post your /var/log/Xorg.0.log

HTH,

Evo2.
 
Old 09-12-2011, 02:51 AM   #8
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD
Posts: 1,102

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally Posted by BigVig View Post
The error message read, "vesa: Ignoring device with a kernel bound driver."
You won't be able to load any kind of xorg video driver while the kernel mode setting driver (nouveau) is in use.

Follow evo2's suggestion, purge all of the nvidia proprietary driver packages and just use nouveau. The nouveau driver and mesa in Sid is a lot better than the older stuff in stable. It's worth giving it a go anyway.
 
Old 09-20-2011, 01:08 PM   #9
davcefai
Member
 
Registered: Dec 2004
Location: Malta
Distribution: Debian Sid
Posts: 739

Rep: Reputation: 31
How I fixed mine

I had the same problem on my system, running 32 bit unstable on AMD.

If you're still stuck, this may help.

The full thread is here:

http://www.linuxquestions.org/questi...g-xorg-901520/

The "meat" of the solution was:

It seems that the xorg versions for testing and unstable are the same. What worked was removing xorg AND xserver-xorg-core then disabling the unstable repo (I use apt-proxy on another machine) and installing xorg AND xserver-xorg-core.

Install xorg only did not bring in the other packages. Xserver-xorg-core brought in 37 others. xserver-common and xserver-xorg-devs have remained at the unstable versions. I have not tried tinkering with them yet.
 
Old 09-20-2011, 05:11 PM   #10
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD
Posts: 1,102

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
You can downgrade to the xserver-xorg-core, xserver-xorg-video-*, xserver-xorg-input-* and xserver-common in testing, but the nvidia driver from experimental and the "IgnoreABI" option in your xorg.conf should also work and be easier to maintain.

For fglrx (Catalyst) there still seems to be no other option except to downgrade xorg.
 
Old 09-21-2011, 02:25 AM   #11
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,658

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
10 days from post #1 and its 'pretty old'? *blinks* Seems current to me.....
 
Old 09-21-2011, 02:43 AM   #12
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD
Posts: 1,102

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Quote:
Originally Posted by cascade9 View Post
10 days from post #1 and its 'pretty old'? *blinks* Seems current to me.....
It's a spammer/bot - already reported.

Last edited by cynwulf; 09-21-2011 at 03:32 AM.
 
1 members found this post helpful.
  


Reply

Tags
debian, nvidia, unstable, xserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Help. Nvidia Driver Issue on Debian amd64 feeblebrain Linux - Newbie 4 03-22-2011 10:20 PM
KDE 4 on Fedora 9 x86_64 unstable on nVidia Gforce Go 7600 dallyack Linux - Desktop 0 08-23-2008 11:16 AM
Nvidia 7600 GT Thatonedude87 Linux - Hardware 4 05-07-2008 09:36 AM
nvidia driver woes after dist-upgrade (GeForce F5200, Debian Unstable) Errsta_Fonzarelli Debian 7 06-02-2007 12:22 PM
How to nvidia drivers on AMD64 Debian using apt-get? Aman9090 Debian 5 12-15-2005 04:19 AM


All times are GMT -5. The time now is 04:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration