-   Debian (
-   -   debian testing install cd rescue mode not accepting luks passphrase (

Molly 02-10-2009 12:28 AM

debian testing install cd rescue mode not accepting luks passphrase
I'm trying to access my root luks encrypted partition from the same debian cd I initially installed the system with using rescue mode in order to resize lvm, filesystem, crypt, and partition. The system is currently running .. so I'm not locked out, but this would be a rather ugly situation if I actually depended on the rescue mode to get access to my files

install/rescue cd info:
Debian Testing AMD64 12-15-2008
debian 2.6.26-1-amd64 #1 SMP Thu Oct 9 14:16:53

i boot the cd into rescue mode .. it gets to the point where it detects the hard drives, asks me for passphrase.. I enter passphrase repeatedly and still it refuses to accept. The same thing happens for all 3 luks encrypted volumes sda3, sdb1, sdc1. I have also tried dropping to shell and just using

cryptsetup luksOpen /dev/sda3 cryptroot
which also refuses to accept the passphrase. I have tried this both from local console and over serial console with same results. I also typed the passphrase onto console in plaintext just to verify the alphanumerics were all correct.

actual running system:

Enter passphrase to unlock the disk /dev/sda3 (sda3_crypt):
key slot 0 unlocked.
Command successful.


line:~# cat /etc/debian_version
line:~# uname -a
Linux line 2.6.26-1-amd64 #1 SMP Sat Jan 10 17:57:00 UTC 2009 x86_64 GNU/Linux
line:~# cryptsetup --version
cryptsetup 1.0.6
line:~# dmsetup --version
Library version:  1.02.27 (2008-06-25)
Driver version:    4.13.0


line:~# cat /etc/crypttab
sda1_crypt /dev/sda1 /dev/urandom cipher=aes-cbc-essiv:sha256,size=256,swap
sda3_crypt /dev/sda3 none luks
freeside /dev/sdc1 /root/test luks
mirror  /dev/sdb1  /root/test  luks


line:~# cryptsetup luksDump /dev/sda3
LUKS header information for /dev/sda3

Version:        1
Cipher name:    aes
Cipher mode:    cbc-essiv:sha256
Hash spec:      sha1
Payload offset: 2056
MK bits:        256
MK digest:      ***
MK salt:        ***
MK iterations:  10
UUID:          ***

Key Slot 0: ENABLED
        Iterations:            291959
        Salt:                  ***
        Key material offset:    8
        AF stripes:            4000
Key Slot 1: DISABLED
Key Slot 2: DISABLED
Key Slot 3: DISABLED
Key Slot 4: DISABLED
Key Slot 5: DISABLED
Key Slot 6: DISABLED
Key Slot 7: DISABLED

Would really appreciate any ideas here, thanks

nx5000 02-10-2009 01:11 PM

Did you check the bug reports?

Molly 02-11-2009 12:11 AM

bug reports
I searched for luks or cryptsetup in debian bugs list archive but the closest thing I could find in the bug reports was someone who actually had forgotten their passwd .. which wasn't a debian bug.

I will wait for the next round of lenny iso's to hit the servers and download a new image to see if the issue is resolved..

nx5000 02-11-2009 06:18 AM

Ok, was just a try.. I thought about this one

Molly 02-13-2009 01:50 PM

I downloaded a debian amd64 testing iso build from 2-12-2009 and this fixes the problem! not sure yet what causes this incompatibility in the previous install iso but at least it is fixed

All times are GMT -5. The time now is 02:09 AM.