LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-19-2018, 06:28 PM   #1
Yure Talis
LQ Newbie
 
Registered: Dec 2018
Posts: 2

Rep: Reputation: Disabled
Exclamation Debian Strech - audio suddenly not working


Hi,

That's the 4th time I installed Debian Stretch on my notebook and the same problem happens all over again. Some time after the installation, the audio stops playing for no apparent reason.

Some information that might help solving the problem:
http://www.alsa-project.org/db/?f=f2...e0ddfb909d042e

I checked
Code:
pavucontrol
and the sound is not muted. Also, all Output Devices appear to me as unplugged.

One more thing: when I connect a headphone to the notebook, nothing occurs.

Look forward to your responses, guys.
Thank you,
Yure
 
Old 12-21-2018, 08:13 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 14,629
Blog Entries: 24

Rep: Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055Reputation: 4055
How long is "some time"? Hours, days, weeks?

If it's hours, try booting to a Live CD of something outside the Debian family (Magiea, OpenSuse) and testing with the Live CD or, if the machine is dual boot, does the problem occur on the other side of the computer?
 
Old 12-21-2018, 08:31 PM   #3
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, Arch, KDE Neon, & ROSA
Posts: 2,954

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
2 questions.

1. Are you running the 4.9 kernel or the backports 4.18 kernel?
2. Do you have firmware-intel-sound installed?

If you're running the 4.9 kernel, I'd install the backports kernel. The neweness of that hardware will work MUCH better with the 4.18 than the older 4.9. The firmware-intel-sound may or may not have anything to do with it. Probably not if it works AT ALL, but can't hurt if it's not installed to install it.
 
1 members found this post helpful.
Old 12-22-2018, 03:14 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,046
Blog Entries: 7

Rep: Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780
possible that a backported kernel might fix everything on this rather new (1 year or so) hardware.

even before that, you should go through the pulseaudio mixer app and fiddle with ALL settings.
 
1 members found this post helpful.
Old 01-07-2019, 10:26 AM   #5
Yure Talis
LQ Newbie
 
Registered: Dec 2018
Posts: 2

Original Poster
Rep: Reputation: Disabled
frankbell, by some time, I mean some days.

I had Manjaro 18.0 installed on my notebook for at least a month and I didn't have any trouble regarding audio. I also had Ubuntu 16.04.5 LTS installed and again, no problem.

About four days ago I noticed that, as opposed to what was happening before, when I plug my headphone in, the audio is back and works just fine (even when I disconnect it). So, I checked
Code:
$ pavucontrol
again and in the Configuration section, changed the Profile from Digital Stereo (HDMI) Output to Analog Stereo Output and now the audio is working as it should be.

Timothy Miller and ondoho, I'm running the 4.9 kernel and if the problem returns, I'll install the backported kernel and eventually post the results here.

Thank you, guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Debian Strech - Unable to add Backports repository RazvanZ Linux - Software 3 09-16-2018 06:55 PM
Change Default home Directory Debian 9 Strech chenco Debian 3 09-26-2017 03:16 AM
LXer: Amp Up Your Multimedia Experience On Debian 9 Strech Linux LXer Syndicated Linux News 0 06-18-2017 03:36 PM
gcc to compile without warnings on Debian Testing Strech? Xeratul Debian 4 06-25-2016 11:28 AM
dual monitors - how can I strech desktop xanas3712 Linux - Newbie 3 04-30-2004 09:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration