LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-09-2008, 11:38 AM   #1
Holonet
LQ Newbie
 
Registered: Nov 2008
Posts: 5

Rep: Reputation: 0
Debian stable - no command prompt


I've been using Ubuntu for about a year, and I'm sick of the bleeding edge philosophy and stuff breaking as fast as it's fixed, so I've been wanting to try Debian, with one massive roadblock...

I've just installed Debian stable (64 bit), I have a Nvidia 9800 GT card, and I downloaded the latest driver. In Ubuntu, I had no problem installing any nvidia driver, by pressing CTRL+ALT+F1, then running /etc/init.d/gdm stop, etc... When trying the same approach in Debian, pressing CTRL+ALT+F1 just makes the screen go blank and the monitor goes into standby mode. The exact same thing happens if I try /etc/init.d/gdm stop from the prompt in gnome. Also, if I press CTRL+ALT+BACKSPACE, it doesn't work right either...same blank standby screen, and it doesn't even go back to the login screen. It does go back to the login screen, however, if I'm already at the login screen...how useful is that? So essentially, this thing WILL NOT let me have a command prompt outside of gnome and/or X server...and I need it.

This is noteably a very basic function, and majorly disappointing to not work from an OS that is heralded as so "stable." I have also tried this a couple months ago with the exact same results, clean installation both times.
 
Old 11-09-2008, 12:03 PM   #2
Count Zero
Member
 
Registered: Feb 2008
Distribution: Debian wheezy
Posts: 130

Rep: Reputation: 15
Whatever it is, it's certainly not due the standard behavior. I'm running Lenny, ran Etch before that. CTRL+ALT+(F1-F6) gives me a command prompt (no X), CTRL+ALT+F7 returns me to my X-session and CTRL+ALT+BACKSPACE restarts the X-session, returning to the login manager.

Sorry for not having a solution to your problem but this basic function is certainly default on a Debian system.

/CZ
 
Old 11-09-2008, 12:16 PM   #3
Holonet
LQ Newbie
 
Registered: Nov 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Count Zero View Post
Sorry for not having a solution to your problem but this basic function is certainly default on a Debian system.

/CZ
That's alright, I appreciate the reply anyhoo...and I realize that--which is precisely why I find it so irritating lol. It's like getting a fancy toilet with no flusher. The only thing I could possibly think of is that I didn't actually ditch the /home directory when I did these "clean" installs, but that really should not matter. The OS partition was freshly formatted.

I'm currently upgrading this to Lenny to see if it carries any magic with it...

Last edited by Holonet; 11-09-2008 at 12:17 PM.
 
Old 11-09-2008, 12:34 PM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
# telinit 1
...and enter root password. You may have to enter both the user name, root, and the password.
 
Old 11-09-2008, 01:16 PM   #5
Holonet
LQ Newbie
 
Registered: Nov 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for that, but it turned out upgrading to Lenny solved the problem...of course, there is the issue that I should not have had to do that...but moving on, I have my nvidia driver.
 
Old 11-09-2008, 03:31 PM   #6
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Quote:
of course, there is the issue that I should not have had to do that...
Of course you shouldn't, and if you hadn't screwed something up, you would not have had to.
 
Old 11-09-2008, 03:57 PM   #7
Holonet
LQ Newbie
 
Registered: Nov 2008
Posts: 5

Original Poster
Rep: Reputation: 0
And what exactly is it that I screwed up? As I said, this was with a clean install. I tried after once more after deleting hidden files and such in the home directory, installing again. Same problem. I did not mess with anything; tried it first thing after the clean install booted up. I don't understand how it could be my fault...and I'm no closer to it either with your lucid explanation...

Last edited by Holonet; 11-09-2008 at 03:59 PM.
 
Old 11-09-2008, 04:03 PM   #8
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
I don't know what you did, but Debian Stable has been installed millions of times, and the installer hasn't been changed in two years, and I've never heard any suggestion of anyone else having such a problem, ... ergo, you screwed up.

How? Not a clue. There are way too many possibilities.
 
Old 11-09-2008, 04:07 PM   #9
Holonet
LQ Newbie
 
Registered: Nov 2008
Posts: 5

Original Poster
Rep: Reputation: 0
It's certainly possible, but "I've never heard of...etc..." is not a reason. I have a reasonably modern video card that has only last month been supported by its own company's driver (Nvidia 9800 GT)...it might not like that, for example. Just because it's unlikely does not mean it's impossible.

Again, I'd invite any suggestions as to any of these "possibilities" I could have done during the installation procedure by going with all the default options. And yeah, it's true I don't know, but neither do you, and your presumptuous tone does not help anything.
 
Old 11-09-2008, 04:59 PM   #10
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Quote:
...your presumptuous tone does not help anything.
Debian users grow thick skins. It's part of the mystique.
 
Old 11-11-2008, 07:00 PM   #11
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,190

Rep: Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037Reputation: 1037
Could it be that you had text mode using the framebuffer? Don't ask me how to check that, but since you are not a complete noob you might have seen that expression somehow, somewhere. It's the only thing I can think of. Text mode (assuming no frambuf, no vga=nnn boot parameter) is pretty basic, the only thing which can not display 80x25 is my coffee maker. (And Windows Vista )

Did you see all messages scroll by while booting, until the screen went black for switching to graphic mode?

jlinkels
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
tar.gz of a gnome-panel more stable for debian stable :lol frenchn00b Debian 4 05-07-2008 10:32 AM
LXer: For me, Debian Testing is more stable than Stable LXer Syndicated Linux News 0 04-22-2008 05:20 AM
startx command in FC7 reverts me back to the command prompt sriram87 Linux - Newbie 5 01-03-2008 11:18 PM
Is Debian 3.1r4 "stable" really stable or it just called that? General Debian 22 01-29-2007 05:18 PM
Key stroke/command to shut down x and go into the command prompt screen? Fear58 Linux - General 1 07-14-2004 07:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration