LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-14-2012, 11:01 AM   #1
qkzoo
LQ Newbie
 
Registered: Jan 2012
Distribution: Lubuntu & Debian Squeeze
Posts: 6

Rep: Reputation: Disabled
Debian Squeeze - Cannot connect to network


I installed Debian Squeeze to a partition on my HP Mini 110 netbook. On the other partition, I have Lubuntu installed, and it works fine. On The debian install, I was finally able to get wicd installed, it sees my network, but won't connect. Initially, it said that I was entering the wrong passphrase. Scratching my head, because I verified I entered the wrong one over and over again, I finally made the network open. Now that it's open, it still won't connect. I could use some assistance,

thanks!
 
Old 01-14-2012, 02:02 PM   #2
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,178
Blog Entries: 23

Rep: Reputation: 278Reputation: 278Reputation: 278
Okay, what does ifconfig say?

tried to ping your box? try this:
Quote:
ping 127.0.0.1
if that works, try to ping the default gateway

Let's see where we end up, it is in the install of Debian, I'm sure...

The usual way I initiate networking is (in the console)

Quote:
ifconfig eth0 [IP address] netmask [netmask, susally 255.255.255.0) broadcast [broadcast IP] up
route add default gw [IP of the default agateway]
vi /etc/resolv.conf - enter the nameservers as "nameserver [IP from the provider]
Good luck

Thor
 
Old 01-14-2012, 02:46 PM   #3
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 455Reputation: 455Reputation: 455Reputation: 455Reputation: 455
Start here: WiFi - Debian Wiki : http://wiki.debian.org/WiFi
 
Old 01-14-2012, 08:46 PM   #4
qkzoo
LQ Newbie
 
Registered: Jan 2012
Distribution: Lubuntu & Debian Squeeze
Posts: 6

Original Poster
Rep: Reputation: Disabled
ifconfig results:

root@andrew-netbook:/home/andrew# ifconfig
eth0 Link encap:Ethernet HWaddr 00:21:cc:47:89:e1
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:26 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:96 errors:0 dropped:0 overruns:0 frame:0
TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8058 (7.8 KiB) TX bytes:8058 (7.8 KiB)

root@andrew-netbook:/home/andrew#

I'll post the output of the pings as soon as I get them, I forgot my router's ip,
 
Old 01-14-2012, 09:26 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,322

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
Also, please post the contents of your /etc/network/interfaces file.

Please surround them in "code" tags, which become available when you click the "Go Advanced" button at the bottom of the "Quick Reply" window.

Your router's ip address is likely 192.168.1.1 or 192.168.2.1 or something like that. If you have another computer in your network, find out its IP address and replace the last numeral with "1." The odds are that will connect to your router.
 
Old 01-15-2012, 07:48 AM   #6
qkzoo
LQ Newbie
 
Registered: Jan 2012
Distribution: Lubuntu & Debian Squeeze
Posts: 6

Original Poster
Rep: Reputation: Disabled
Ok, here is my /etc/network/interfaces file:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet static
	address 192.168.2.3
	netmask 255.255.255.0
	network 192.168.2.0
	broadcast 192.168.2.255
	gateway 192.168.2.1
	# wireless-* options are implemented by the wireless-tools package
	wireless-mode managed
	wireless-essid Diamond
	wireless-key1 s:12345
	# dns-* options are implemented by the resolvconf package, if installed
	dns-nameservers 192.168.2.1
	dns-search diamond
 
Old 01-16-2012, 07:31 PM   #7
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,322

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
Unless 192.168.2.1 is running a DNS server program such as BIND, I think you need to point to a valid DNS server.

If 192.168.2.1 is a router, as I suspect is likely, it will pass the nameserver to DHCP clients, but not to static IP clients.

Again, if my guess is correct (and I am guessing), you need to enter a valid DNS server address for the dns-nameservers value or remove that line.

Here's my /etc/network/interfaces for comparison:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address [ip-address]
netmask 255.255.255.0
gateway 192.168.1.1

auto eth0
And the output of my ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr 00:11:11:a9:7d:8d  
          inet addr:[ip-address]  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::211:11ff:fea9:7d8d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:72124088 errors:0 dropped:0 overruns:0 frame:0
          TX packets:37311844 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3769889785 (3.5 GiB)  TX bytes:3966764456 (3.6 GiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:392540 errors:0 dropped:0 overruns:0 frame:0
          TX packets:392540 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:16496768 (15.7 MiB)  TX bytes:16496768 (15.7 MiB)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After installing KDE 4.4.5 on Debian Squeeze wireless will not connect RayGo75 Debian 6 10-06-2011 07:52 AM
Debian Squeeze, no Network Manager Jetso Linux - Newbie 11 08-01-2011 06:26 PM
No Network Manger Display in Debian Squeeze adamwoop Linux - Newbie 8 08-01-2011 08:26 AM
Various segmentation faults Debian Squeeze Virtualbox running on Debian Squeeze host fordwrench Debian 1 07-21-2011 03:55 AM
Debian Squeeze - Connman Does not see network Interfaces Jeff91 Linux - Software 0 06-24-2011 08:57 AM


All times are GMT -5. The time now is 12:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration