-   Debian (
-   -   Debian Sarge NetInst DHCP Trouble (

PatrickNew 11-09-2006 11:18 PM

Debian Sarge NetInst DHCP Trouble
Hello, I got tired of dealing with Suse on my desktop, felt that this would be a good time to try out debian. So, I tried to use a netinstall since I didn't feel like downloading all those discs.

So, I got the base system installed from the netinst cd and I got through the setup up to the point where I set up apt, and that never works. If I choose to go through ftp, every repo refuses to connect, and if I go through http, I get a gzip error that stdin isn't in gzip format, and another error that certain files aren't available.

I happen to know that the DCHP on my school's network is particularly slow, and that my dchpc kept timing out on a slackware install. So, I suspect that my slow dchp is preventing me from getting an internet connection. How do I give it more time before timing out? Thanks.

PatrickNew 11-10-2006 12:07 PM

Well, it appears that the dchp isn't the problem. I have indeed been assigned an IP address, however with each repo, the screen sits at "connecting to <repo name>" for a long time, until I finally get an error screen saying that apt reports "Failed to fetch" "connection timed out" and "some index files failed to download"

Daws 11-10-2006 12:13 PM

Proxy server?

PatrickNew 11-10-2006 12:19 PM

I'm on a campus network, so I'm not sure of their internals, but if there is one fedora and suse autodetected it. I'll call and ask.

Daws 11-10-2006 12:28 PM

Well etch beta 3 doesn't want to detect my proxy so the old sarge installer probably won't either. I had to set debconf priority (press ESC during installation and its near the end of the menu) to low and enter it manually. Hope you get it working.

PatrickNew 11-10-2006 01:16 PM

Thanks for the help, but after calling I discovered that this is caused by the ideosyncracies of this particular network. Solved.

PatrickNew 11-10-2006 01:38 PM

EDIT: Spoke too soon, there must be some other problem. I can resolve DNS's with ping, but I can't connect to the mirrors.

All times are GMT -5. The time now is 09:57 PM.