-   Debian (
-   -   Debian Sarge alsa lib update broke gstreamer (

HalfDiminished 05-04-2005 08:35 PM

Debian Sarge alsa lib update broke gstreamer
Recently, I updated some alsa-libs and I noticed that now sever programs involving gstreamer do not work. The gstreamer test/config program gstreamer-properties loads, but when I set my sound sink to alsasink, it crashes and give sthe following error message:

gstreamer-properties: relocation error: /usr/lib/gstreamer-0.8/ undefined symbol: gst_audio_set_channel_positions

Also, when I use rhythmbox to play an mp3, it gives this error:

rhythmbox: relocation error: /usr/lib/gstreamer-0.8/ undefined symbol: gst_audio_set_channel_positions

Same error. Anybody have any ideas? Sound still works for other apps, like xmms and frozen bubble. All my modules are loaded and volumes are unmuted and turned up.


HalfDiminished 05-10-2005 02:25 PM


Still totally stuck. Tried reinstalling gstreamer-alsa and alsa-base. No dice.

HalfDiminished 05-18-2005 09:32 AM

Well, frustrated and somewhat discouraged, I decided to upgrade any and all packages that have anything to do with either gstreamer or alsa - based on a search from within Synaptic. And...poof! Gstreamer functionality has returned. The problem has been 'solved' - however, if updating a package is going to break functionality unless other packages are also updated, they should be included as dependencies to the original package. This isn't the first time this has happened with alsa-related packages for me. I think I'll file a bug report.
Sound systems in Linux work pretty well for playing mp3s out of a built in soundcard. But having multiple soundcards configured for studio recording is really not very practical at this point.
There's a thread on the LQ feedback forum suggesting that a forum be created specifically for audio. I've posted there along with a few others. If you have been getting frustrated with audio recording/hardware issues, go there to help us bug the moderators to create a new forum.

All times are GMT -5. The time now is 09:37 PM.