LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Sarge 3.1 and ATi drivers (https://www.linuxquestions.org/questions/debian-26/debian-sarge-3-1-and-ati-drivers-343881/)

intuxicator 07-16-2005 10:14 PM

Debian Sarge 3.1 and ATi drivers
 
I have a debian Sarge 3.1. system and ATi 9200SE video card. Surfing the web i have found a good tutorial which explains how to install the godforsaken ATi drivers and have done everything which was actually written in that tutorial(http://xoomer.virgilio.it/flavio.sta...installer.html), but when i came to the part where i had to compile the driver i got the following output

Quote:

cube:/usr/src/modules/fglrx# sh make.sh
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /usr/src/linux-2.6.12.3 SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Entering directory `/usr/src/linux-2.6.12.3'
CC [M] /usr/src/modules/fglrx/agp3.o
CC [M] /usr/src/modules/fglrx/nvidia-agp.o
CC [M] /usr/src/modules/fglrx/agpgart_be.o
/usr/src/modules/fglrx/agpgart_be.c: In function `agp_find_supported_device':
/usr/src/modules/fglrx/agpgart_be.c:7136: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7156: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7161: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7187: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7207: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7227: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c:7232: error: structure has no member named `slot_name'
/usr/src/modules/fglrx/agpgart_be.c: In function `__fgl_agp_init':
/usr/src/modules/fglrx/agpgart_be.c:7613: warning: `pm_register' is deprecated (declared at include/linux/pm.h:106)
/usr/src/modules/fglrx/agpgart_be.c: In function `__fgl_agp_cleanup':
/usr/src/modules/fglrx/agpgart_be.c:7623: warning: `pm_unregister_all' is deprecated (declared at include/linux/pm.h:116)
make[2]: *** [/usr/src/modules/fglrx/agpgart_be.o] Greška 1
make[1]: *** [_module_/usr/src/modules/fglrx] Greška 2
make[1]: Leaving directory `/usr/src/linux-2.6.12.3'
make: *** [kmod_build] Greška 2
build failed with return value 2
and when i ran dmesg the last few lines where like that

Quote:

[drm] Initialized radeon 1.16.0 20050311 on minor 0: ATI Technologies Inc RV280 [Radeon 9200 SE]
[drm:radeon_cp_init] *ERROR* radeon_cp_init called without lock held
[drm:drm_unlock] *ERROR* Process 5129 using kernel context 0
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
anyone any ideas what this is ? how should i fix this problem and finnaly bring my ATi to life ?

thanx in advance

xukosky 07-20-2005 06:36 AM

I know the tutorial but it never worked for me, just forget it.

Installing the drivers in sarge was as easy as converting the .rpm in .deb with alien and then following the general instructions (something about makes in the kernel's module directory) but with the latest drivers ati has released a new installer that is distribution-independent (no need for alien) and does the compiling work for you just clicking on it (no makes), go to ati's website and download it.

But don't forget to run fglrxconfig before installing, it continues being necessary, read the instructions.

intuxicator 07-20-2005 11:55 AM

yep but when i again try to compile the module after running fglrxconfig i get the same error

twinkers 07-20-2005 12:58 PM

Quote:

Originally posted by xukosky
I know the tutorial but it never worked for me, just forget it.
Hmm, that's a bit harsh to state a tutorial is worhtless just because it isn't working for you. I've been using this tutorial for ages and it works just fine...........


You mention: cube:/usr/src/modules/fglrx# sh make.sh

I'm not sure why you would wanna try it that way. I always use the make-kpkg one (You can now build the kernel module in several ways. Choose one, preferably the make-kpkg command.)

The command for that would be:

Code:

cd kernel-source-2.x.y
fakeroot make-kpkg --append-to-version "-flavour" --added-modules fglrx modules_image

-flavour being whatever your kernel is named after 2.x.y

Whenever I build a new ATI module for a new kernel I always forget this step (just before compiling the module):

Quote:

if you are using a custom kernel, you'll have to build the kernel module yourself; change directory to /usr/src and unpack the module sources:

cd /usr/src
bzcat fglrx.tar.bz2 | tar x
Make sure you do that aswell.

It might not help you out, but the make-kpkg way has never failed me.

ToastedToad 07-20-2005 01:49 PM

If 32bit, then the installer from ATI works great for me. It's what we've all been waiting for, but I still see lots of people trying it the hard way?????

Have you tried the installer?

intuxicator 07-20-2005 07:57 PM

ok thanx a lot guys i'll try the make-kpkg version, well my point is i am using a custom kernel so the biggest problem for me was compiling the kernel module. I have found on some website that the module in source (*.c) format has some errors in the syntax and needs to be repaired so i did that but after i compiled it without errors it would not put the module into the kernel with the modprobe fglrx command. The system would say that i do not have permission to that allthough i was root. Anyway i got some ideas why it is that way so i'm going to repair it ....

thanx again for your help

motub 07-21-2005 07:37 AM

For a 9200, you don't have to use the fglrx drivers at all-- you can use the kernel drivers (radeon) and MESA. The fglrx drivers are only required for the 9500 and above, which must use the fglrx drivers to get hardware acceleration due to the "advanced" chip on the upper level cards.

So if the fglrx drivers are too tough to install, you do have the option to just scrap 'em.


All times are GMT -5. The time now is 11:34 PM.