LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Debian post-install Error 21. (https://www.linuxquestions.org/questions/debian-26/debian-post-install-error-21-a-717743/)

Dillix 04-08-2009 11:57 AM

Debian post-install Error 21.
 
Ok, so I am installing Debian5-lenny on an Intel DualCore1.8gHz
Clean install, No windows Disks nor any other OS partitions, Clean Debian install with a full 250GB SATA HDD to its disposal.

The full install process of the base system is working like a charm, Debian installer finds all hardware etc. while installing, along with network card.

I'm choosing "Entire Disk Guided" on the partition field in GUI Installer,
everything looks to be working just fine for the complete installation, I get to the last bit, where the installer asks me whether to install Grub on the MBR of the first disk or not, as installer did not find any other OS installed.

Quite true, there is no other OS here. So i click "Yes", it installs itself, pushes out my DVDrom. and starts rebooting.

Now, for the first 5'ish attempts or so, upon finishing installing I got the "Missing operating system" error where "DMI update" should be printed,
and now, for the last few tries I am getting the Error 21, stage 1.5 grub loader.

This was all done on a SATA Disk, could that be the problem? I mean, is SATA disks just as supported as the IDE(hd0)etc. HDDs ?
This hard drive has been used for both windows XP and Vista until recently, so it should be just fine, unless there can be some windows fragments still on it bugging it for the linux installer.

And, any suggestions on how to go forward with this problem, and solving it?

-Note that i have no installed system on the computer, so getting menu.lst printouts can be a no-go.

Saptech 04-08-2009 12:32 PM

Try reinstalling and when you get to the partition screen, choose Manual partition, that should let you choose it. (/dev/sda1) for (/)root.

Dillix 04-08-2009 12:59 PM

Quote:

Guided Partitioning
Help on partitioning

SCSI5 (0,0,0)(sda) - 250.1 GB ATA SAMSUNG HD252KJ
> #1 Primary 247.3GB B f ext3 /
> #5 Logical 2.7GB F swap swap


undo changes to partitions
finish partitioning and write changes to disk
This is how my disk table looks like during installation, the setup installation sets itself, quite the linux newbie, but it looks about right according to other images i've seen.
apart from it missing a /boot partition?

This is also how I've tried my previous installs, apart from one where i tried to resize the primary partition, and created a /boot, ext2 at 1GB and set that to "boot flags"
didn't change anything from what i saw after the install finished.

Any suggestions upon this? tried to set the boot to both logical, and primary partition in 2 separate installs, with no change in outcome.

farslayer 04-08-2009 02:45 PM

When attempting to boot Linux it's not seeing your drive..

21 : Selected disk does not exist
This error is returned if the device part of a device- or full file name refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system.


I would get the supergrub boot disk, and use it to boot the installed system, then grab the bootinfoscript and run it, post the output here..


this whole issue could be caused by a setting in the BIOS for the Disk Controller.. is that SATA controller a RAID controller by any chance ? is there an option to change the mode for the controller in BIOS ? [RAID/ATA/LEGACY]


All times are GMT -5. The time now is 08:47 PM.