LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-16-2007, 03:17 PM   #1
DRagonRage
LQ Newbie
 
Registered: Sep 2005
Distribution: Debian
Posts: 28

Rep: Reputation: 15
debian permission error


im trying to run apache but thats what t gives:
Code:
 
[root@dserv ~]# whoami
root
[root@dserv ~]# apache2ctl start
Syntax error on line 1 of /etc/apache2/mods-enabled/actions.load:
Cannot load /usr/lib/apache2/modules/mod_actions.so into server: /usr/lib/apache2/modules/mod_actions.so: cannot open shared object file: Permission denied
[root@dserv ~]# apt-get remove apache2-*  --purge
Reading Package Lists... Done
Building Dependency Tree... Done
Note, selecting libapache2-mod-scgi for regex 'apache2-*'
Note, selecting libapache2-mod-auth-sys-group for regex 'apache2-*'
Note, selecting apache2-utils for regex 'apache2-*'
Note, selecting libapache2-mod-python2.2 for regex 'apache2-*'
Note, selecting libapache2-mod-python2.3 for regex 'apache2-*'
Note, selecting libapache2-mod-rpaf for regex 'apache2-*'
Note, selecting libapache2-mod-proxy-html for regex 'apache2-*'
Note, selecting libapache2-svn for regex 'apache2-*'
Note, selecting libapache2-mod-python for regex 'apache2-*'
Note, selecting libapache2-mod-ruby for regex 'apache2-*'
Note, selecting libapache2-mod-musicindex for regex 'apache2-*'
Note, selecting apache2-modules for regex 'apache2-*'
Note, selecting apache2-common for regex 'apache2-*'
Note, selecting apache2-mpm-perchild for regex 'apache2-*'
Note, selecting libapache2-redirtoservname for regex 'apache2-*'
Note, selecting libapache2-mod-macro for regex 'apache2-*'
Note, selecting apache2-mpm-prefork for regex 'apache2-*'
Note, selecting libapache2-mod-perl2-dev for regex 'apache2-*'
Note, selecting libapache2-mod-auth-pgsql for regex 'apache2-*'
Note, selecting libapache2-mod-fcgid for regex 'apache2-*'
Note, selecting apache2 for regex 'apache2-*'
Note, selecting libapache2-mod-auth-kerb for regex 'apache2-*'
Note, selecting libapache2-mod-layout for regex 'apache2-*'
Note, selecting libapache2-mod-auth-plain for regex 'apache2-*'
Note, selecting apache2-threaded-dev for regex 'apache2-*'
Note, selecting libapache2-mod-suphp for regex 'apache2-*'
Note, selecting libapache2-mod-encoding for regex 'apache2-*'
Note, selecting libapache2-mod-python-doc for regex 'apache2-*'
Note, selecting libapache2-dav-svn for regex 'apache2-*'
Note, selecting libapache2-mod-auth-mysql for regex 'apache2-*'
Note, selecting libapache2-mod-xmlrpc2 for regex 'apache2-*'
Note, selecting libapache2-mod-fastcgi for regex 'apache2-*'
Note, selecting apache2-mpm-threadpool for regex 'apache2-*'
Note, selecting libapache2-mod-perl2 for regex 'apache2-*'
Note, selecting libapache2-mod-auth-pam for regex 'apache2-*'
Note, selecting libapache2-mod-chroot for regex 'apache2-*'
Note, selecting apache2-dev for regex 'apache2-*'
Note, selecting apache2-threaded-dev instead of apache2-dev
Note, selecting apache2-doc for regex 'apache2-*'
Note, selecting apache2-mpm-worker for regex 'apache2-*'
Note, selecting libapache2-mod-php4 for regex 'apache2-*'
Note, selecting libapache2-mod-php5 for regex 'apache2-*'
Note, selecting libapache2-mod-security for regex 'apache2-*'
Note, selecting libapache2-mod-ldap-userdir for regex 'apache2-*'
Note, selecting libapache2-mod-jk2 for regex 'apache2-*'
Note, selecting apache2-prefork-dev for regex 'apache2-*'
Note, selecting libapache2-request-perl for regex 'apache2-*'
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  apache-common: Depends: apache2-utils but it is not going to be installed
  php4: Depends: libapache-mod-php4 (>= 4:4.3.10-19) but it is not going to be installed or
                 libapache2-mod-php4 (>= 4:4.3.10-19) but it is not going to be installed
        Depends: php4-common (>= 4:4.3.10-19) but 4:4.3.10-16 is to be installed
  phpgroupware: Depends: apache but it is not going to be installed or
                         httpd
  phpmyadmin: Depends: apache but it is not going to be installed or
                       apache-perl but it is not going to be installed or
                       apache-ssl but it is not going to be installed or
                       apache2 or
                       httpd
  squirrelmail: Depends: apache2 or
                         httpd
  webmin-apache: Depends: apache but it is not going to be installed or
                          apache-perl but it is not going to be installed or
                          apache2 or
                          apache-ssl but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
[root@dserv ~]# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
  apache2-common libapache-mod-php4 libapache2-mod-php4 php4-cli php4-common
  php4-gd php4-imap php4-mysql
Suggested packages:
  apache2-doc php4-pear
The following NEW packages will be installed:
  libapache-mod-php4
The following packages will be upgraded:
  apache2-common libapache2-mod-php4 php4-cli php4-common php4-gd php4-imap
  php4-mysql
7 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
65 not fully installed or removed.
Need to get 0B/5907kB of archives.
After unpacking 3232kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 33150 files and directories currently installed.)
Preparing to replace apache2-common 2.0.54-5 (using .../apache2-common_2.0.54-5sarge1_i386.deb) ...
Unpacking replacement apache2-common ...
dpkg: error processing /var/cache/apt/archives/apache2-common_2.0.54-5sarge1_i386.deb (--unpack):
 unable to stat `./usr/lib/apache2' (which I was about to install): Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace libapache2-mod-php4 4:4.3.10-16 (using .../libapache2-mod-php4_4%3a4.3.10-19_i386.deb) ...
Unpacking replacement libapache2-mod-php4 ...
dpkg: error processing /var/cache/apt/archives/libapache2-mod-php4_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/apache2' (which I was about to install): Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace php4-cli 4:4.3.10-16 (using .../php4-cli_4%3a4.3.10-19_i386.deb) ...
Unpacking replacement php4-cli ...
dpkg: error processing /var/cache/apt/archives/php4-cli_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/php4' (which I was about to install): Permission denied
Preparing to replace php4-mysql 4:4.3.10-16 (using .../php4-mysql_4%3a4.3.10-19_i386.deb) ...
Unpacking replacement php4-mysql ...
dpkg: error processing /var/cache/apt/archives/php4-mysql_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/php4' (which I was about to install): Permission denied
Preparing to replace php4-imap 4:4.3.10-16 (using .../php4-imap_4%3a4.3.10-19_i386.deb) ...
Unpacking replacement php4-imap ...
dpkg: error processing /var/cache/apt/archives/php4-imap_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/php4' (which I was about to install): Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace php4-gd 4:4.3.10-16 (using .../php4-gd_4%3a4.3.10-19_i386.deb) ...
Unpacking replacement php4-gd ...
dpkg: error processing /var/cache/apt/archives/php4-gd_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/php4' (which I was about to install): Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace php4-common 4:4.3.10-16 (using .../php4-common_4%3a4.3.10-19_i386.deb) ...
Unpacking replacement php4-common ...
dpkg: error processing /var/cache/apt/archives/php4-common_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/php4' (which I was about to install): Permission denied
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Unpacking libapache-mod-php4 (from .../libapache-mod-php4_4%3a4.3.10-19_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libapache-mod-php4_4%3a4.3.10-19_i386.deb (--unpack):
 unable to stat `./usr/lib/php4' (which I was about to install): Permission denied
Errors were encountered while processing:
 /var/cache/apt/archives/apache2-common_2.0.54-5sarge1_i386.deb
 /var/cache/apt/archives/libapache2-mod-php4_4%3a4.3.10-19_i386.deb
 /var/cache/apt/archives/php4-cli_4%3a4.3.10-19_i386.deb
 /var/cache/apt/archives/php4-mysql_4%3a4.3.10-19_i386.deb
 /var/cache/apt/archives/php4-imap_4%3a4.3.10-19_i386.deb
 /var/cache/apt/archives/php4-gd_4%3a4.3.10-19_i386.deb
 /var/cache/apt/archives/php4-common_4%3a4.3.10-19_i386.deb
 /var/cache/apt/archives/libapache-mod-php4_4%3a4.3.10-19_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
[root@dserv ~]# chown root:root -R /usr/lib
chown: cannot access `/usr/lib/php4': Permission denied
chown: cannot access `/usr/lib/pppd': Permission denied
chown: cannot access `/usr/lib/libpci.so': Permission denied
chown: cannot access `/usr/lib/libpci.so.2': Permission denied
chown: cannot access `/usr/lib/libgdbm.so.3.0.0': Permission denied
chown: cannot access `/usr/lib/libpcap.so.0.7.2': Permission denied
chown: cannot access `/usr/lib/tasksel': Permission denied
chown: cannot access `/usr/lib/libtextwrap.so.1.0.0': Permission denied
chown: cannot access `/usr/lib/libtextwrap.so.1': Permission denied
chown: cannot access `/usr/lib/libgdbm_compat.so.3': Permission denied
chown: cannot access `/usr/lib/libpcap.so.0.7': Permission denied
chown: cannot access `/usr/lib/man-db': Permission denied
chown: cannot access `/usr/lib/libgdbm.so.3': Permission denied
chown: cannot access `/usr/lib/apache2': Permission denied
chown: cannot access `/usr/lib/libgdbm_compat.so.3.0.0': Permission denied
is there any way to fix that?
Code:
[root@dserv ~]# uname --a
Linux dserv 2.6.8-2-386 #1 Tue Aug 16 12:46:35 UTC 2005 i686 GNU/Linux
 
Old 03-18-2007, 06:46 AM   #2
Garda
Member
 
Registered: May 2005
Distribution: Debian
Posts: 83
Blog Entries: 2

Rep: Reputation: 15
yep, that's weird
if i had to guess, i would guess that it's because that part of the filesystem is read-only

cat /etc/fstab | less

see if the filesystem in question is mounted read only, there should be a ro somewhere if it is, under the options section, change that to rw

it's probably something else though if you have everything on just one partiton

might, also be that you're out of space

df -h

will tell you how much space you have left
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
permission denied on home dir debian sarge2 bennethos Linux - General 2 02-01-2007 07:47 AM
Cannot run scripts (Permission denied). Debian etch. mva.led Debian 7 10-05-2006 02:38 PM
my sql permission error gravesb Linux - Software 5 08-09-2006 08:51 AM
Permission error Burian Fedora 3 01-11-2005 08:10 PM
permission denied error endezeichen Linux - General 5 12-20-2003 06:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration