-   Debian (
-   -   debian-patch-debianlogo w/2.6.5 kernel-patch-lpp (

Outabux 05-08-2004 03:31 AM

debian-patch-debianlogo w/2.6.5 kernel-patch-lpp
performed an
apt-get install debian-patch-debianlogo
unzipped debian-logo-2.6.2 and placed in /usr/src/linux
performed patch -p1 < /usr/src/linux/debian-logo-2.6.2
all seems well, no errors...
no listing in choices as I can see in kernel config
installed new kernel with patch in place
after reboot, nothing...

what'd I do wrong
any suggestions

While I'm here any help with kernel-patch-lpp. Since I was unable to decipher my problems with debian-logo I did not proceed to try to install this patch; however, I was and am still able to patch the kernel with an ACPI ddst/initrd patch with the same patch command...

any suggestions as I'm trying to create a eye candy but functional system on an Inspiron 8200 w/loads of tweaks and removable modules (hdd, zip, floppy, ...), C/DockII, and others
do like my bootmessages, but wondering what if...

Thanx! in advance! Visit my earlier thread to help me out with a firestarter that all of a sudden goes bonkers after an upgrade...go figure

Outabux 05-10-2004 07:47 AM

kernel config does exist in device drivers\graphics drivers\framebuffers\Logo Configuration

already checked...
removed the other checks and recompiled, nvidia installer, ...

now no penguin or swirl

rechecked all again, penguin...

kernel is not 2.6.2 which is patch i apply; however, 2.6.5 showed no errors

trying to get this to the top of the list
i know some understand

:newbie: :Pengy: :Pengy: :confused:

Outabux 05-10-2004 07:49 AM

oh yeah the lpp has been superceeded by elpp and can be downloaded and applied from its maintainer, not in debian tree yet

says its a little gittery

i will worry about it later

dano.1 05-11-2004 02:04 PM

Did you also select the logo in make menuconfig? It's somewhere down in the menu.



Outabux 05-11-2004 03:39 PM

yup, reread earlier post...tried with it checked by itself and with others...same dice

keepem comin

dano.1 05-13-2004 02:17 PM

yeah, have a similair thing here.

I've tried apt-get install kernel-patch-debianlog and all went well.

To my knowledge the patch isn't installed at this moment but after the patch command it should be. After this something should be expected in make menuconf or xconfig.

The patching failed: ' patch -p1 < /usr/src/kernel-patches/all/apply/debianlogo ' gives ' patch: **** Only garbage was found in the patch input.' Bummer.

No more reason looking any furter i guess till this is solved.

My guess is that under the section Graphic support, logo configuration, bootup logo some debian logo must appear.

All eyecandy anyway and i'll look anyfurther in the topics as we speak (haven't done that yet, oeps) i'll let you know if someting pops up interresting.



Outabux 05-13-2004 04:42 PM

nope, the patch appends perfectly and appears in config...check above for location
may try 2.6.4 or 2.6.6 on a new SID Build

on lighter side was able to apt-get install boot-icons, a very clever graphical status monitor of the init process. Modifies the init-scripts to post icons along side Tux in boot/init process using framebuffer device that signals completion of motherboard (ram, chipset, cpu, blah, blah, blah), disk & filesystem checks, network connection, ...

awesome, no need for lppp or elppp for i can see nice graphics in 1280X960 while still seeying the boot messages scroll down. Nice!

Hope someone will continue to help however with the debian-logo patch for 2.6.2 inside 2.6.5 (done manually) so my icons will be debian then switch to Glowing Tux then the rest of the icons across the top of the screen during boot.

zuralin 05-13-2004 05:18 PM

Are you using make-kpkg to build your kernel? If not try it, if so, use

make-kpkg clean; make-kpkg --added-patches="debianlogo" kernel_image

note: it might not be called debianlogo, look around in your /usr/src/patches for the correct name (might not be called patches, havent done this in a while)..

when this is ran, make oldconfig gets ran so say yes to the debian logo questions.

For more help on make-kpkg check

Outabux 05-13-2004 10:29 PM

of course, but i install the patches manually and separately using the debian tools of kernel-package including make-kpkg kernel-image
and dpkg -i kernel-image-2.6.X-Custom10.00-i386.deb or something like that

when configuring i do see the option for the replacement with the debian logo and have unchecked the others and tried

will be trying with another installation as soon as I download, burn, and check the sarge netinst.iso so that my linux.old will be 2.6.3

dano.1 05-19-2004 09:49 AM

Got it working.

Basically i've done the exact thing you did earlier, yet i have the swirl debian logo when booting.

Anyway this is how i've done it.

First i 've downloaded the zip file (not the .deb file) kernel-patch-debianlogo_1.0-9.tar.gz and extracted it in the /usr/src/ directory. In here you can find the diff file debian-logo-2.6.2 (closest to my kernel version 2.6.6) which i've patched into the kernel. From /usr/src/linux (or whatever symlink you use) patch command ' patch -p1 <../kernel-patch-debianlogo-1.0/debian-logo-2.6.2' to apply the diffs to the config. In make menuconfig=>device drivers=>graphic support=>logo configuration=> select Debian GNU/Linux Open Use logo (new).

After make-kpkg clean | make-kpkg --append-to-version -blabla kernel-image you can dpkg -i blabla.deb and boot with this new kernel now suporting the Debian logo.

For some reason the original kernel-patch-debianlogo.deb didn't work for me, but this solved my case.

Hope this helped.


Outabux 05-19-2004 11:24 PM

like i said ill be doin it for 2.6.5 with debianlogo-2.6.2 patch as im not certain if debian at present has 2.6.6 kernel w/ their patches installed

think it will all be fixed when i start anew

well, thanx, i know it works

Outabux 05-20-2004 02:21 PM

works, but use boot-icons patch, would like to move them over as they get stamped over the debian banner...

wondering if i could modify init scripts to movem over as im using a high res console (video=794 mostly, sometime 793)

lemme know, will look into that later
wondering why i cant get alsa going
used to be a simple apt-get alsa
that was it, got more to do...

All times are GMT -5. The time now is 01:32 PM.