-   Debian (
-   -   debian lenny or testing (for KDE 4.3)? (

pusrob 08-09-2009 04:53 PM

debian lenny or testing (for KDE 4.3)?
I was wondering which debian would be the best for using KDE 4.3?

I'm currently using Lenny with KDE 3 and I'm happy with it, but I just don't want to wait until KDE 4.3 gets ported to stable, because it will take ages, and I really want to try out KDE 4 (I was waiting since it was announced that KDE4 will be developed). I know there is an unofficial site, where recent KDE packages are compiled within a reasonable time, but when I tried to install (actually I wasn't trying so hard, I was waiting for 4.3) KDE 4.2.4, there were some unavailable packages in the repos, which were needed.

I checked the testing repo, where those packages are already available (since testing has KDE 4.2.4 natively), and I was wondering if it is worth to upgrade my lenny to testing? I would also like the idea to have much more recent software than we have in Lenny.

I also would like to ask some debian testing users, what kind of experience do you have with testing? How much bugs do you encounter, how much errors you get, do you think if it can be used for everyday use, is it worth to upgrade to testing in your opinion, etc...
In short: what pros and contras do you have about the upgrade?


the trooper 08-09-2009 05:31 PM


what kind of experience do you have with testing
I find it pretty stable.
I'm confident enough with Testing that i use it on both my machines at home everyday.


How much bugs do you encounter
There is the occasional bug,but generally not bad enough to break the system.
I'd recommend installing apt-listbugs to check for any critical bugs in packages you are about to install or update.
I'd also suggest doing regular updates using aptitude safe-upgrade.


is it worth to upgrade to testing in your opinion
I'd say it is,but that's just my opinion as i run Testing myself ;).
Here's a link to a great to guide to installing Debian/Testing:

Hope this helps,post back if you need anymore help or advice.

mushroomboy 08-10-2009 04:20 AM

Testing is usually stable, it gets pretty buggy when you start mixing lenny/squeeze/sid about. I just dist-upgrade to squeeze off the bat and install what I can off that, if a package doesn't work I see what sid offers and if it works.

For example the best wine is for sid, but the working nspluginwrapper is for lenny (here goes the mixing) but for ia32-libs all the working ones I've found are in sid (as of today, I've been trying to get everything working). Though /emul/ia32-linux is depreciated in squeeze/sid... It's all a muck sometimes but you get the hang of it once you figure things out.

Like today for compiling wine (32 bit) I had to install ia32-libs (sid) and then muck around with /usr/lib32 and copy needed libraries from extracting i386 debs just so it would compile and run. Though since /emul/ia32-linux has been dropped in squeeze I had to copy the /emul/ia32-linux/usr/lib stuff over to /usr/lib32 so nvidia compat 32 libs would work.

Really sometimes it all depends on the day you decide to Some days it all works fine, some days they release something new.

the trooper 08-10-2009 09:26 AM


Though since /emul/ia32-linux has been dropped in squeeze I had to copy the /emul/ia32-linux/usr/lib stuff over to /usr/lib32 so nvidia compat 32 libs would work.
Can you post the details of what you did?.
I have run in to this problem installing the nvidia driver.

mushroomboy 08-11-2009 06:34 AM


Originally Posted by the trooper (Post 3637808)
Can you post the details of what you did?.
I have run in to this problem installing the nvidia driver.

K basically I just installed the system from scratch recently (freaking mixing stable/testing/unstable sometimes gets funky).

First step I did was install base system, you don't have to, just make sure you have the latest ia32-libs. Right now I'm using the 20090808 version from unstable, installed all the ia32* stuff from testing/unstable and installed the wine package from lamaresh so I had 1.1.26. (optional: do an apt-get build-dep for wine after you have the right repo's and you can build wine with the CC="gcc-4.3 -m32" ./configure and then do the usual make stuff)

Ok, now go to your /emul/ia32-linux/usr directory, you should have a lib? copy everything from that to /usr/lib32 and remove the folder and make a sys link:
cd /emul/ia32-linux/usr
ln -s /usr/lib32 lib

Now install the Nvidia drivers.

If you already installed/compiled and installed the 32bit compat just copying and making the sys link should restore all functionality.

the trooper 08-11-2009 09:39 AM

Thank you so much mushroomboy!.
Your suggestion worked.
I think it's worth mentioning that i also used the ia32-libs from Sid(run a Testing/Sid mixed system anyway).
For the nvidia driver i'm using the current beta driver:
Cp'd the lib directory as suggested,then moved it to my /home.
Next,made the link and installed the driver.No more error messages about not being able to find!.
Cedega and Q4 now run perfectly,as before the 'upgrade'.
I've been scratching my head and Googling this for a couple of days now,so it's great to have a conclusion to the problem.

mushroomboy 08-11-2009 09:09 PM

No problem, I guess they just made the decision to drop /emul/ia32-linux and not many people know much about it. =( I was reading through email logs and that's how I found out it was depreciated. They want to put ia32-apt-get in and have /lib32 /lib64. I think that would be great, just make a sys link for /lib to /lib64, this would make upgrading to a new format in the future possible. But yeah, if you get the dev files or you want to build something for it you can just put the files you need /usr/lib32. I was sticking in i386 dev files in their so I could build wine. Just grabbed the testing deb's from debian, opened them up and dropped the files in either /lib32 or /usr/lib32. You can now compile any program for 64bit as 32bit. =)

All times are GMT -5. The time now is 03:44 PM.