LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-18-2014, 12:20 AM   #1
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,665

Rep: Reputation: 98
DEbian jessie: AMD catalyst (fglrx) installed but slow.


Hya,

System
Debian jessie 64bit. (as of 15/Apr/2014)
fglrx version. 1:14.3~beta1.0-1

Situation.
glxinfo says that direct rendering is Yes, however it is very slow.

dmesg says
Code:
 <3>[fglrx:KAS_Mutex_Release] *ERROR* Mutex released without holding it.

bugs.debian.org says (bug=741397) that
Code:
Bug#739054: fixed in fglrx-driver 1:14.3~beta1.0-1

We believe that the bug you reported is fixed in the latest version of
fglrx-driver, which is due to be installed in the Debian FTP archive.
I guess I still have this error.

This happened after dist-upgrade. Kernel modules were rebuilt.

Question
Does anybody else have same problem?

cheers
 
Old 04-18-2014, 01:51 AM   #2
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,628

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Don't have this problem. Quit using the fglrx driver some time ago as the FOSS driver works very well. In fact better than the fglrx on my hardware.
 
Old 04-18-2014, 04:50 AM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,575
Blog Entries: 3

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
you may have installed the driver but I do not think you are using it. open a terminal and type lsmod | grep fglrx and see if the module is loaded.
if not try modprobe fglrx . if you compiled it your self did you run the aticonfig --initial for a single monitor.

did you try fglrxinfo
Quote:
$ glxinfo | grep "direct rendering"

If it says "direct rendering: yes" then you're good to go! If the $ glxinfo command is not found install the mesa-demos package.
remember you can test it also
Quote:
You can also use:

fgl_glxgears

as the fglrx alternative test to glxgears.
as for this
Quote:
Situation.
glxinfo says that direct rendering is Yes, however it is very slow.
the nouveau driver will give you the same output.

Last edited by Drakeo; 04-18-2014 at 04:53 AM.
 
Old 04-18-2014, 05:05 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by widget View Post
Don't have this problem. Quit using the fglrx driver some time ago as the FOSS driver works very well. In fact better than the fglrx on my hardware.
+1 -- Same experience as described by Widget. I'm using the radeon driver that comes with the kernel and it works fine. What graphics card do you have? Also this link may be of interest.
jdk
 
Old 04-18-2014, 06:20 AM   #5
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,665

Original Poster
Rep: Reputation: 98
Hya,

Thanks.

My penguin looks like this HCL.

Yes, glxinfo says direct rendering is yes.

+++++
I guess I solved this problem.

I found another problem with update-initramfs, which lead me to this thread.

I removed libc-x32 (also dev package), and rebuilt kernel modules again,

aticonfig --initial (I have not done this step until today)

My penguin is in good shape now.
++++++

I am not sure which step worked.

By the way, Debian does not recommend to turn X86_x32 on for security reason. On the other hand, package manager installs libc-x32. I guess it might be somewhat preposterous.
 
Old 04-20-2014, 10:10 PM   #6
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,665

Original Poster
Rep: Reputation: 98
Hya

Self reply.

I tried kernel option, X86_x32 on, libc-x32 installed. -> things look good, so far.

Anyway, thanks for everybody.

cheers
 
  


Reply

Tags
ati, catalyst, dri, error


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] jessie: ATI radeon (fglrx driver) not working kaz2100 Debian 19 01-16-2014 06:58 PM
No direct rendering (DRI) with Catalyst / fglrx on 14.1 dokkalf Slackware 18 11-30-2013 12:50 AM
LXer: The AMD Catalyst 13.6 proprietary video driver will support the latest AMD APUs and I really LXer Syndicated Linux News 0 07-10-2013 02:20 PM
Installing both catalyst and fglrx at the same time? rassah Linux - Desktop 3 02-22-2009 09:23 AM
Fglrx - I can't set refresh rate in catalyst cc sloteel Linux - Hardware 1 01-30-2008 08:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration