LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Debian Buster on Raspbian: SSH error (https://www.linuxquestions.org/questions/debian-26/debian-buster-on-raspbian-ssh-error-4175674058/)

business_kid 04-27-2020 04:38 AM

Debian Buster on Raspbian: SSH error
 
I have a RazPi 4 running Debian Buster and I had to set a password for user 'pi'which I read online was 'raspberry,' It actually wasn't so I set it to raspberry.

Now I get errors on startup with ssh complaining and telling me to change the password for user pi in Raspberry Pi Configuration. I did. No change.

Does anyone know the original password for pi, or how to shut Openssh up? I may need openssh one day.

Turbocapitalist 04-27-2020 05:06 AM

Which method did you use? If you use raspi-config to set the password for 'pi', the shell should calm down about it and stop nagging when you log in.

business_kid 04-27-2020 11:22 AM

Quote:

Originally Posted by Turbocapitalist (Post 6116331)
Which method did you use? If you use raspi-config to set the password for 'pi', the shell should calm down about it and stop nagging when you log in.

I did. It didn't. Do you know what the default passwd for user pi is? I can set that, and see if it shuts up.

EDIT: Wait a sec. It's not the shell that's throwing the error, it's openssh.

Keith Hedger 04-27-2020 11:42 AM

the default for the pi user IS raspberry

Turbocapitalist 04-27-2020 01:47 PM

Quote:

Originally Posted by business_kid (Post 6116448)
I did. It didn't. Do you know what the default passwd for user pi is? I can set that, and see if it shuts up.

EDIT: Wait a sec. It's not the shell that's throwing the error, it's openssh.

What is the exact error and where, specifically, are you seeing it? Please paste it here.

If you have changed the default password for the user 'pi' using the raspi-config utility, then you will not get nagged about it when operating headlessly. The raspi-config program won't affect the nag you get in the GUI, however. You can eliminate that by removing /etc/xdg/autostart/piwiz.desktop completely or rename it to anything other than .desktop.

Keith Hedger 04-27-2020 02:38 PM

remove/edit /etc/profile.d/sshpwd.sh

Turbocapitalist 04-28-2020 12:29 AM

Quote:

Originally Posted by Keith Hedger (Post 6116514)
remove/edit /etc/profile.d/sshpwd.sh

That's only triggered if the file /run/sshwarn exists. Which systemd service creates that file?

business_kid 04-28-2020 03:47 AM

Not on the RazPi now. Is there any problem with me just setting the ssh passwd myself? To my mind, the biggest disadvantage of Raspbian is Systemd. It's like Selinux and NetworkManager, pourous. And the answer to a bug is rarely a fix, but another script :(.

It reminds me of this fortune cookie
Quote:

Bug:
An elusive creature living in a program that makes it incorrect.
The activity of "debugging," or removing bugs from a program, ends
when people get tired of doing it, not when the bugs are removed.


Turbocapitalist 04-28-2020 04:24 AM

It looks like it is run from PAM via the package libpam-chksshpwd.

Code:

$ dpkg -S  /etc/profile.d/sshpwd.sh
libpam-chksshpwd:armhf: /etc/profile.d/sshpwd.sh

$ dpkg -L libpam-chksshpwd
/.
/etc
/etc/profile.d
/etc/profile.d/sshpwd.sh
/lib
/lib/arm-linux-gnueabihf
/lib/arm-linux-gnueabihf/security
/lib/arm-linux-gnueabihf/security/pam_chksshpwd.so
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libpam-chksshpwd
/usr/share/doc/libpam-chksshpwd/NEWS.Debian.gz
/usr/share/doc/libpam-chksshpwd/changelog.Debian.gz
/usr/share/doc/libpam-chksshpwd/changelog.gz
/usr/share/doc/libpam-chksshpwd/copyright
/usr/share/man
/usr/share/man/man8
/usr/share/man/man8/pam_chksshpwd.8.gz
/usr/share/pam-configs
/usr/share/pam-configs/chksshpwd


Keith Hedger 04-28-2020 04:53 AM

Quote:

Originally Posted by business_kid (Post 6116744)
... To my mind, the biggest disadvantage of Raspbian is Systemd. It's like Selinux and NetworkManager, pourous. And the answer to a bug is rarely a fix, but another script :(. ...

Put Linux from scratch on it, works well and without all the systemd overhead and guff.

Quote:

That's only triggered if the file /run/sshwarn exists. Which systemd service creates that file?
The OP just asked for a way to rid themselves of the nag, removing/editing '/etc/profile.d/sshpwd.sh' is a quick simple fix and gets rid of the nag without worrying about systemd getting the hump.

business_kid 04-28-2020 12:35 PM

Removing that file sounds good. I'll do that & report back. My work rate here has slowed considerably due to ill health. I'm just coming up for air after pc trouble before starting into the Pi.

LFS is something I'm not doing on a RazPi. They're not particularly encouraging of Arm on LFS, last time I looked. I did LFS in the past & last year. I'm not trying it on Arm. I went looking for a 64bit OS, but the offerings are few. My own favourite, slackware, has a slackware 32bit build as a WIP. Debian(Raspbian) looks good because they have the critical mass to keep updates, etc. coming until a 64bit distro comes along.

business_kid 04-28-2020 03:04 PM

Solved. Thanks guys.

In the RazPi X config I disabled SSH as user pi. That solved it.
To be sure, I deleted /etc/profile.d/sshckpwd.sh or whatever it was, and the sky didn't fall in.

There's other things that niggle but this box is a tv addon, primarily because the tv interface is such a major pita. This, in it's present state is to be used, not experimented upon.

The only nasty thing I did was to give root a password, which I am wont to do. It saves sudo running out of permission, which happens. Reboot won't reboot, but I absolutely don't care, and refuse to lift a finger investigating.

Turbocapitalist 04-28-2020 09:15 PM

Removing the script can be done by removing the whole package named in #9 above. Otherwise, with the package still there, you have a chance that the script might come back with some future update.

business_kid 04-29-2020 03:25 AM

Quote:

Originally Posted by Turbocapitalist (Post 6117062)
Removing the script can be done by removing the whole package named in #9 above. Otherwise, with the package still there, you have a chance that the script might come back with some future update.

Yes, but the not starting ssh also supressed the error. I'm good, I think.


All times are GMT -5. The time now is 06:20 PM.