LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-26-2019, 08:58 AM   #1
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Rep: Reputation: Disabled
Debian Buster hibernation ( on several laptops )


Hello All,

I've been using Debian Buster lately on several laptops with very good results.
Thanks to the people who make this possible!

A rather small problem is that I cannot get hibernation to work on
HP Probook 6475b with AMD A6-4400M cpu
Lenovo ThinkPad E485 with AMD Ryzen 5 2500U cpu

This does work with Debian Stretch on several laptops with Intel cpu's,
for instance Dell Latitude E6500.
I'm not sure about Debian Buster on laptops with Intel cpu's.

Could this be this is a typical problem of AMD laptops?
How could I get this to work in Buster?

Greetings, J.
 
Old 05-26-2019, 12:58 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
What happens if from a terminal you run
Code:
sudo echo disk > /sys/power/state
 
Old 05-27-2019, 11:40 PM   #3
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hello,

thanks for helping me out.
This commands gives me no output, it sends both laptops in what I assume is hibernation.
On the Lenovo that means the screen goes black, the power buton light flashes but it does not power off.
On the HP this means the laptop powers off but has black screen after booting back up.

Greetings, J.
 
Old 05-28-2019, 12:04 AM   #4
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,146

Rep: Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496
Hi,
Quote:
Originally Posted by jvermeulen View Post
H
A rather small problem is that I cannot get hibernation to work on
HP Probook 6475b with AMD A6-4400M cpu
Lenovo ThinkPad E485 with AMD Ryzen 5 2500U cpu
I think some more information may help.

What command are you running when attempting to put them into hibernate? What happens? Have you checked log files for hints?

I recently upgraded a machine to Buster. I've not tried hibernate but suspend works without issue.

Eg.
Code:
systemctl suspend
Evo2.
 
Old 05-28-2019, 08:02 AM   #5
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hello,

on the Lenovo, the command
systemctl suspend

or going to
System-Shutdown-Pauze or Sleep

results in the screen going black and the power button light blinking.

It looks like the laptop is not completely shutting down.

/var/log/syslog:
May 28 14:54:53 22 systemd[1]: Stopped User Runtime Directory /run/user/117.
May 28 14:54:53 22 systemd[1]: Removed slice User Slice of UID 117.
May 28 14:54:57 22 systemd[1]: systemd-hostnamed.service: Succeeded.
May 28 14:54:57 22 systemd[1]: systemd-fsckd.service: Succeeded.

Greetings, J.
 
Old 05-28-2019, 07:38 PM   #6
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,146

Rep: Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496Reputation: 1496
Hi,

that's a bit strange. You don't see anything related to suspending the system in syslog? Eg
Code:
May 29 09:34:40 kudu systemd[1]: Starting TLP suspend/resume...
May 29 09:34:41 kudu systemd[1]: Started TLP suspend/resume.
May 29 09:34:41 kudu systemd[1]: Reached target Sleep.
May 29 09:34:41 kudu systemd[1]: Starting Suspend...
May 29 09:34:41 kudu systemd-sleep[2230]: Suspending system...

Evo2.
 
Old 05-30-2019, 11:59 AM   #7
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hello,

on the Lenovo, when running this command:
#/usr/sbin/hibernate

this appears in /var/log/hibernate.log:

Starting suspend at do mei 30 10:54:59 CEST 2019
hibernate: [01] Executing CheckLastResume ...
hibernate: [01] Executing CheckRunlevel ...
hibernate: [01] Executing LockFileGet ...
hibernate: [01] Executing NewKernelFileCheck ...
hibernate: [10] Executing EnsureUSuspendCapable ...
hibernate: [11] Executing XHacksSuspendHook1 ...
hibernate: [59] Executing RemountXFSBootRO ...
hibernate: [89] Executing SaveKernelModprobe ...
hibernate: [91] Executing ModulesUnloadBlacklist ...
hibernate: [95] Executing XHacksSuspendHook2 ...
hibernate: [98] Executing CheckRunlevel ...
hibernate: [99] Executing DoUSuspend ...
hibernate: Running /usr/sbin/s2disk ...

Maybe this is helpful.

Greetings, J.
 
Old 05-31-2019, 05:18 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 16,897
Blog Entries: 10

Rep: Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026
just want to make sure people use the right terms here.

when i refer to hibernation, that means:
- system state is saved
- ram is dumped to a file (swap partition ususally)
- the system goes OFF, but can start much faster

when i refer to suspend, that means:
- system goes into a sort of deep screensaver state (hard drives are powered down, hardware goes into powersaving modes, network goes off) - this is usually where i see the blinking light.

now the terms themselves are not so important, just be clear what you talk about.

imo, suspend is much more hardware dependent than hibernate.
i seem to remember that hibernation was disabled by default on many (debian-based?) linux systems, but do not remember why. I once had it working on an archlinux netbook.

maybe start here:
https://wiki.debian.org/Hibernation
https://wiki.debian.org/Suspend
 
Old 06-03-2019, 03:22 AM   #9
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hello,

it is hibernation I am talking about.

It is not disabled on Debian, because I have been using it for months on an Intel-based Dell laptop with Debian Stretch.
I have just tested it on an Intel based Dell laptop with Debian Buster and it also works.

This article goes back to Debian Jessie. I never worked with that but I never had to make changes to the swap partition on any
Linux system to get this to work.

Greetings, J.
 
Old 06-03-2019, 12:48 PM   #10
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Let's try a basic check, Just so we're all sure of things. Have you
  1. the booting option resume=<your swap partition> , e.g. resume=/dev/sda2
  2. The standard debian kernel?
  3. acpid running?
  4. Nothing preventing hibernate?
  5. What does 'sudo systemd-hibernate do?
 
Old 06-05-2019, 12:18 PM   #11
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hallo,

thanks for helping me out.

1. I now have boot option resume=/dev/mapper/jvermeulen--vg-swap_1
2. yes, the standard Debian kernel
3. I now have acpid installed and enabled.
4. I wouldn't know what would prevent hibernating.
5. systemd-hibernate: command not found.

greetings, J.
 
Old 06-06-2019, 06:29 AM   #12
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Quote:
Originally Posted by jvermeulen View Post
Hallo,

thanks for helping me out.
1. I now have boot option resume=/dev/mapper/jvermeulen--vg-swap_1

4. I wouldn't know what would prevent hibernating.

5. systemd-hibernate: command not found.
greetings, J.
1. The trouble is that no services are running when you're trying to resume. If you can find the swap partition with 'fdisk -l' or 'gdisk -l' use that instead.
4. There's usually power management stuff in your X window manager, ranging in quality and complexity. Go figure.
5. It's probably there. Try sudo in front of it. You could run 'sudo updatedb' then 'locate systemd-hibernate' and finally 'sudo systemd-hibernate'
 
Old 06-18-2019, 05:29 AM   #13
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hello,

I have tried to add the resume= option with uuid, that didn't help.

I have tried a similar machine with Centos7 that has an older kernel.Then the machine does power down en comes back up - and the nothing works until you reboot-.
On Centos7 with newer ( elrepo) kernel I get same behavior as in Debian; the machine does not power down.

Greetings, J.
 
Old 06-19-2019, 05:00 AM   #14
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, RPi OS, Mint & Android
Posts: 12,541

Rep: Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560Reputation: 1560
Good. Try 4 & 5 below.
 
Old 07-02-2019, 05:21 AM   #15
jvermeulen
Member
 
Registered: Nov 2014
Posts: 91

Original Poster
Rep: Reputation: Disabled
Hello,

sorry for not replying sooner.

4: I would'n know what to do to stop x window from preventing hibernation
5: root@22:~# locate systemd-hibernate
/lib/systemd/systemd-hibernate-resume
/lib/systemd/system/systemd-hibernate-resume@.service
/lib/systemd/system/systemd-hibernate.service
/lib/systemd/system-generators/systemd-hibernate-resume-generator
/usr/share/man/man8/systemd-hibernate-resume-generator.8.gz
/usr/share/man/man8/systemd-hibernate-resume.8.gz
/usr/share/man/man8/systemd-hibernate-resume@.service.8.gz
/usr/share/man/man8/systemd-hibernate.service.8.gz

From that output I don't see how to run the command.

Greetings, J.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Remastering Debian Stretch/Buster using Linux-live-debian-050419 into a Live CD/DVD/USB/HDD linus72 Debian 1 10-14-2019 01:25 PM
LXer: Debian 11 "Bullseye" and Debian 12 "Bookworm" Are Coming After Debian 10 "Buster" LXer Syndicated Linux News 0 04-18-2018 12:26 PM
[SOLVED] Debian installer weekly build iso testing buster corrupt libdevmapper AwesomeMachine Debian 2 03-02-2018 06:54 PM
LXer: Debian GNU/Linux 10 "Buster" Installer Enters Alpha with Linux 4.12 Support LXer Syndicated Linux News 0 09-05-2017 10:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration