LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-14-2006, 08:49 AM   #1
Vigacmoe
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Rep: Reputation: 0
Debian & Windows dual boot, system time issue


I have a debian & windows dual boot system, everything seems to be fine except the system date in both os. Each time I logout from one os and boot into another, the system date jump several hour forward.
For example, if the system date is 12:00 when I logout from Windows, it will become, say, 22:00 after I boot into Debian.
My timezone setting is the same in windows and debian, is there a way to synchronize the system date in both os?
Thanks!
 
Old 03-14-2006, 09:04 AM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
Depending on your hardware, there could be some different reasons for this, but a first step would probably be to install 'ntpdate'
 
Old 03-14-2006, 09:21 AM   #3
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
The hw clock is assumed to be in UTC since it cannot store the offset. Windows has not concept of this, it sets the hw clock to local time. To work around this issue, make sure that the hw clock is set to local time and change UTC=yes to UTC=no in /etc/default/rcS
 
Old 03-14-2006, 01:22 PM   #4
lestoil
Member
 
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
That same time problem started for me when I upgraded Sarge to Etch with 2.6.12 kernel. It was very frustrating because no offered solution worked. Neither Kanotix nor Mepis nor Sarge ever had problem. Then after several weeks my upgrading kernel to 2.6.14 and system to Etch/Sid resolved time errors. Cheers.
 
Old 03-14-2006, 11:59 PM   #5
Vigacmoe
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the replies.

Quote:
Originally Posted by dracae
make sure that the hw clock is set to local time and change UTC=yes to UTC=no in /etc/default/rcS
The hwclock is set to local time, and the value of UTC in /etc/default/rcS is "no". But still, the problem remain.

Quote:
Originally Posted by lestoil
Then after several weeks my upgrading kernel to 2.6.14 and system to Etch/Sid resolved time errors. Cheers.
My system is Sid, and my kernel is 2.6.15.

Quote:
Originally Posted by rickh
Depending on your hardware, there could be some different reasons for this, but a first step would probably be to install 'ntpdate'
You mean get time from internet servers? But I don't have a constant internet connection available.
 
Old 03-15-2006, 12:08 AM   #6
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 59
It helps if we know a little bit about your system. Is it a 64-bit ... smp ... those hardware configurations are known to have time related idiosyncracies.
 
Old 03-15-2006, 10:37 PM   #7
Vigacmoe
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
No, rickh, it's an old pc, not a 64-bit system.
cpu: p4 2.66 northwood
mainboard: msi 6533e
 
Old 03-15-2006, 11:01 PM   #8
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
It would help to know where the clock skew is coming from
boot bios -> set time
boot windows -> check time
boot bios -> check time
boot debian -> check time
boot bios -> check time
 
Old 08-31-2006, 12:14 AM   #9
ypsiliur
LQ Newbie
 
Registered: Aug 2006
Posts: 1

Rep: Reputation: 0
Maybe it is bugs.debian.org/cgi-bin/bugreport.cgi?bug=346342

(sorry for the incomplete url but i am not allowed to add links to other sites )

see also man 5 rcS

when it is that problem you just should copy your zoneinfo file under /usr/share/zoneinfo to /etc/localtime

Greetz Stefan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yet another windows/Linux dual boot issue wEvil Linux - Newbie 10 02-08-2006 06:13 PM
Im setting up a dual boot system for first time completenumpty Linux - Software 3 04-19-2005 08:45 AM
Suse 9.1 & Windows XP dual boot issue gqstud79 Suse/Novell 7 02-16-2005 03:04 AM
Need Help Loading Windows XP & SuSe Linux version 8.2---to Make a Dual Boot System Howerton Linux - Newbie 7 09-23-2004 02:49 PM
mbr issue on dual boot rhl7.1 dominant system m3rajk Linux - Software 8 12-04-2003 06:17 PM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration