LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Debian 9 doesn't see wifi networks (https://www.linuxquestions.org/questions/debian-26/debian-9-doesnt-see-wifi-networks-4175612252/)

kel_en 08-19-2017 08:56 AM

Debian 9 doesn't see wifi networks
 
Upgraded Lenovo T420 laptops from Debian 8.8 to 9.1. Managed wireless connection works perfectly. It is configured with fixed IP and WEP security. There are 3 available wifi networks but the system doesn't see them after the upgrade. I have a mobile Verizon hotspot which I would like to use away from my home network. I can use my Nexus 7 but there are times I'd like to have a lapatop. Any suggestions?

jim_p 08-19-2017 09:54 AM

What is your wifi card?

kel_en 08-19-2017 10:31 AM

Intel N 6205. I installed the requested firmware iwlwifi-something at the time of upgrade. Thanks for the reply.

dejank 08-19-2017 12:00 PM

Perhaps it is network manager problem. What do you get from this:

Code:

iwlist wlan0 scan
Replace wlan0 with your wireless interface name, if it is different.

kel_en 08-19-2017 12:28 PM

I get 4 cells. The first cell is my managed network connection. The second cell is the wifi channel from my router. The other cells are from neighbors. I can post the complete output if I can figure out how to upload the file. Thanks.

dejank 08-19-2017 12:34 PM

So, important part is that network manager does not see those right?

kel_en 08-19-2017 12:48 PM

Yes, the network manager does not see any of these, assuming it is the network manager that I am invoking when I click on the wireless icon and then try to select a network.

dejank 08-19-2017 01:07 PM

It is, if you have default install, like Gnome, or KDE. Ok, now, you have 2 options. One is to learn how to configure network from command line, using tools like ip, iw, wpa_supplicant and/or ifconfig, iwlist, iwconfig. Other option is to install wicd, disable/remove network-manager and enable wicd. In most cases, wicd is better tool to manage wireless connections than network manager is. Also, bug rep that network manager, if you can.

kel_en 08-19-2017 01:27 PM

Thank you. I will look into wicd. For years I have managed my networks via the command line. It is only the last week that I have the need to connect to a wireless hot spot with a laptop. Not sure if it was possible with Debian 8.X because I never invoked the network manager until this week, a month after upgrading to 9.1. Again, thanks.

dejank 08-19-2017 01:35 PM

Pleasure, have fun :)

kel_en 08-19-2017 06:10 PM

Solved by disabling NetworkManager and installing wicd.

Nolwennig 06-09-2019 05:52 AM

Quote:

Originally Posted by kel_en (Post 5750046)
Solved by disabling NetworkManager and installing wicd.

Works for me too :)


All times are GMT -5. The time now is 01:11 AM.