LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-29-2013, 10:40 AM   #76
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled

The output of the disable command is
Quote:
update-rc.d: using dependency based boot sequencing
insserv: warning: current start runlevel(s) (empty) of script `network-manager' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `network-manager' overrides LSB defaults (0 1 6).
What does the following means?
Quote:
ifup: interface eth0 already configured
What does ping supposed to output ?
What modification shall I do to the router through its IP?
There is no internet connection, however??

Last edited by lin66uxx; 05-29-2013 at 10:44 AM.
 
Old 05-29-2013, 10:50 AM   #77
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
We can't help you id you won't provide the output you see.
No Internet connection in a browser does not necessary mean that you aren't connected to the net, that is why cynwulf asked for testing it with those commands. For example, if you can't ping google.com, but can ping its IP you are connected to the net, but there are problems with name resolving.
 
1 members found this post helpful.
Old 05-29-2013, 11:10 AM   #78
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,417

Rep: Reputation: Disabled
Yep a dead loss, after 6 pages I finally wash my hands of this one - good luck...
 
Old 05-29-2013, 11:21 AM   #79
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled
ping x.x.x.138 gives :
Quote:
PING x.x.x.138 (x.x.x.138) 56(84) bytes of data.
64 bytes from x.x.x.138: icmp_req=1 ttl=64 time=0.444 ms
64 bytes from x.x.x.138: icmp_req=2 ttl=64 time=0.438 ms
.
.
.
after C^c
--- x.x.x.138 ping statistics ---
84 packets transmitted, 84 received, 0% packet loss, time 82996ms
rtt min/avg/max/mdev = 0.372/0.461/0.526/0.027 ms
ping www.google.com gives :
Quote:
ping www.google.com
ping: unknown host www.google.com

ping 173.194.41.64 gives :
Quote:
PING 173.194.41.64 (173.194.41.64) 56(84) bytes of data.
From x.x.x.138 icmp_seq=1 Destination Net Unreachable
.
.
.
^C
--- 173.194.41.64 ping statistics ---
11 packets transmitted, 0 received, +11 errors, 100% packet loss, time 10000ms
cat /etc/resolv.conf :
Quote:
nameserver x.x.x.138
nameserver x.x.x.138

Thanks

Last edited by lin66uxx; 05-29-2013 at 11:23 AM.
 
Old 05-29-2013, 11:33 AM   #80
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled
I think I have to set the username and password received from the ISP under the router IP, but to do so I have to change the bridge mode, which you said not to mess with.
 
Old 05-29-2013, 11:38 AM   #81
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Usually routers are configured in NAS mode, I would give that a try, then of course you have to put your credentials into the router. So far the output of the commands shows that your network is up and running, but your router is not connected to the Internet.
 
Old 05-29-2013, 11:50 AM   #82
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled
Quote:
Connection Type

Select the type of network protocol for IP over Ethernet as WAN interface
there are few options:
1. PPP over ATM (PPPoA)
2.PPP over Ethernet (PPPoE)
3. MAC Encapsulation Routing (MER)
4.IP over ATM (IPoA)
5.Bridging

the selected one is bridging, but under this option there are no fields to feed the ISP username and password.
Under PPPoE and PPPoA there are ! so where shall I feed these info ?

What is NAS mode ?

Under windows 7 it works perfectly.

Last edited by lin66uxx; 05-29-2013 at 11:53 AM.
 
Old 05-29-2013, 11:56 AM   #83
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Sorry, was a typo, I meant NAT mode. I would go for 1. or 2., depending on your type of connection, but I think usually it is 2.
 
Old 05-29-2013, 12:05 PM   #84
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled
I have some more questions:
Under WAN(in case this is where I have to search) there are two options, shall I modify them both?
what is PPPoE service name? it asks for it along with the username and password? is it the name of the ISP?
Also I don't find NAT option .
Thanks

Last edited by lin66uxx; 05-29-2013 at 12:07 PM.
 
Old 05-29-2013, 12:49 PM   #85
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled
OK, I modified both of them, set the username and password, I choosed PPPoE, and guess what? I have internet now, and yes, there is an NAT option.
I just hope It will not disconnect!!!
I'll repost later regarding the other issuse I have such as installing more languages ... .
Thanks,

Last edited by lin66uxx; 05-29-2013 at 12:59 PM.
 
Old 05-29-2013, 01:25 PM   #86
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Nice that it works now. Since your other question is unrelated to this thread I would recommend to open a new thread with that question.
 
Old 06-06-2013, 06:05 AM   #87
lin66uxx
Member
 
Registered: Oct 2012
Distribution: debian10, slackware14.2
Posts: 167

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
I just found something that can help others.
if the output of rfkill list gives something like this:
Quote:
0: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
Then your wireless hardware is blocked, using rfkill unblock 1, did not help, I have also windows 7 on my laptop, so I enabled the wireless under windows 7 and then rebooted in debian 7, and the wireless blocked was removed.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to dual boot opensuse 11.3 and windows xp (opensuse 11.3 is installed first) varunb Linux - Newbie 13 11-10-2011 03:10 AM
Triple-booting Windows 7, Debian (6) and OpenSUSE (Newest: haven't installed yet) Omnilogist Linux - General 3 08-09-2011 04:31 PM
OpenSuSE 10.3 failing to uninstall openSuSE installer from the windows boot Lucens Linux - Newbie 5 10-11-2008 08:08 AM
Restarting Windows machine stops Linux machine mounting/connecting jamespetts Linux - Networking 3 05-29-2008 03:12 AM
Printing from Debian machine to Win machine, What I did wrong. sarajevo Debian 8 04-30-2008 11:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration