LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-10-2019, 05:44 AM   #1
ilesterg
Member
 
Registered: Jul 2012
Location: München
Distribution: Debian, CentOS/RHEL
Posts: 587

Rep: Reputation: 72
Unhappy Debian 10 xfce cannot wake after screen blank


I am on Debian 10 and I noticed one issue.

When the screen goes blank after minutes of inactivity (both locking the screen AND then monitor turns off only), I cannot wake the screen using key presses and mouse actions. The only thing that works is when I Ctrl+F<something>, then back to Ctrl+F7.


What can I check? I haven't used Debian desktop in a while so I forgot where to start. I am using Debian 10, lightdm, and xfce (both installed during Debian installation).
 
Old 08-10-2019, 08:12 AM   #2
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Distribution: Debian, Arch, Kubuntu
Posts: 349

Rep: Reputation: 125Reputation: 125
Wow. Not sure that I can help, but I've also got Debian 10, lightdm, and xfce4 here, and this sounds like the same problem I was having, about a week ago. And I think it started happening after I added xfce4-power-manager. I don't think that I really got to the bottom of what was causing the problem, but I uninstalled xfce4-power-manager. And I also "deactivated" light-locker (didn't want to remove it yet).

Maybe run xset q and see what the output looks like down where it says "Screen Saver:" and "DPMS (Energy Star):". If you have those sections showing up in the output of that command.

When I ran xset s off, that changed the value for "timeout" in the "Screen Saver" section to 0, and after that, when the screen went off I was able to bring it back up normally, by moving the mouse. Until the next session, that is. So I created a script that contained the xset s off command and added that to Autostart, problem solved.

But I stumbled around with this issue for some time, and I think I should have been able to come up with a cleaner solution. And I'm not sure that I really found out what exactly was causing the problem. I hope you post a reply here if you find a better way to fix this. Good luck!

Last edited by m.a.l.'s pa; 08-10-2019 at 08:14 AM.
 
Old 08-10-2019, 08:19 AM   #3
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Distribution: Debian, Arch, Kubuntu
Posts: 349

Rep: Reputation: 125Reputation: 125
FYI, here's what I used in the script that I added to Autostart:

Code:
#!/bin/sh

(sleep 15s && xset s off) &
 
Old 08-10-2019, 05:56 PM   #4
djk44883
Member
 
Registered: Aug 2008
Location: Ohio
Distribution: debian
Posts: 118

Rep: Reputation: 28
Quote:
Originally Posted by m.a.l.'s pa View Post
FYI, here's what I used in the script that I added to Autostart:

Code:
#!/bin/sh

(sleep 15s && xset s off) &
I have very similar to keep my monitor from turning off on my media PC aka TV.

Code:
#!/bin/bash
xset dpms 0 0 0
xset s off
Why do you have it "&" ? it's not a service or daemon.

Quote:
xset - user preference utility for X
it just sets preferences for X and, poof it's done. There's only one X session (usually). Is there an advantage?

I kind of get the delay, but xdg-autostart doesn't happen until X is complete - after the user has logged in
Autostart Of Applications During Startup
 
Old 08-10-2019, 08:27 PM   #5
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Distribution: Debian, Arch, Kubuntu
Posts: 349

Rep: Reputation: 125Reputation: 125
Quote:
Originally Posted by djk44883 View Post
Why do you have it "&" ? it's not a service or daemon.

it just sets preferences for X and, poof it's done. There's only one X session (usually). Is there an advantage?

I kind of get the delay, but xdg-autostart doesn't happen until X is complete - after the user has logged in
Autostart Of Applications During Startup
I thought I needed the ampersand, but maybe not. I don't think it hurts anything, though. And I don't quite understand why the problem came up, but I think it's the same as what the OP wrote about, except that I've had Buster Xfce installed and running fine since April when it was still "Testing." Seemed to start happening after I added xfce4-power-manager. I'm going over my notes again and trying to maybe compare my setup to what I have in Xfce in Arch.
 
Old 08-10-2019, 09:05 PM   #6
ChuangTzu
Senior Member
 
Registered: May 2015
Location: Where ever needed
Distribution: Slackware/Salix while testing others
Posts: 1,649

Rep: Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791Reputation: 1791
If you have AMD then its probably the systemd bug that Debian inherited. It's a well known problem.
https://github.com/systemd/systemd/issues/11810
https://www.reddit.com/r/archlinux/c..._from_suspend/

PS: when testing Debian Buster I had the same problem you experienced with every DE except Plasma.

Last edited by ChuangTzu; 08-10-2019 at 09:07 PM.
 
Old 08-10-2019, 09:23 PM   #7
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Distribution: Debian, Arch, Kubuntu
Posts: 349

Rep: Reputation: 125Reputation: 125
Intel processor in my case.
 
Old 08-10-2019, 10:58 PM   #8
djk44883
Member
 
Registered: Aug 2008
Location: Ohio
Distribution: debian
Posts: 118

Rep: Reputation: 28
I have Intel, been running Buster sometime back in testing. mate-desktop, "disabled" screen-saver from auto-start. power-management setting for putting monitor to sleep is never, yet my monitor would sleep, or at least blank.

Since this is a media PC, the monitor is my TV, either the TV is powered on, set to PC or TV, or powered off. The PC doesn't need to control it. I went through settings dconf-editor and still would sleep, or just blank. Tried these settings
Quote:
Disable suspend and hibernation

For systems which should never attempt any type of suspension, these targets can be disabled at the systemd level with the following:

sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
without success. Finally discovered xset. May or may not be the actual issue but fixes my problems and I'm not aware of any problems it creates. They are user preferences. As for your ampersand, puts it in the background, it's likely finishes before it even makes it there. More or less benign (nevertheless, useless)
 
Old 08-10-2019, 11:28 PM   #9
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Distribution: Debian, Arch, Kubuntu
Posts: 349

Rep: Reputation: 125Reputation: 125
Quote:
Originally Posted by djk44883 View Post
As for your ampersand, puts it in the background, it's likely finishes before it even makes it there. More or less benign (nevertheless, useless)
Good to know, thanks. Guess I'll just leave it, then.

Might all this have been caused by some sort of conflict between light-locker and xfce4-power-manager? Grasping at straws here, but I think it started happening after I added the latter about a week ago. And I have xfce4-power-manager in Arch, but not light-locker. If I try to remove light-locker from Buster it wants to take out task-xfce-desktop as well, and I see a message about using apt autoremove to get rid of a ton of packages after that. So that's why I haven't uninstalled light-locker and instead removed it from autostart.

Anyway, xset looks like a nice work-around, if the OP wants to try that.
 
Old 08-11-2019, 07:11 AM   #10
djk44883
Member
 
Registered: Aug 2008
Location: Ohio
Distribution: debian
Posts: 118

Rep: Reputation: 28
Quote:
Originally Posted by m.a.l.'s pa View Post
Might all this have been caused by some sort of conflict between light-locker and xfce4-power-manager? Grasping at straws here,
Ya' know, now I've upgraded to Bullseye, actually any/all packages along the way, I've never looked back, kind of forgot.

What ever the problem may or may not be. But I do recall it being a PITA, not to disable something to keep the screen on full time.

As for conflicts with [xfce4|mate]-power-manager, I may be over simplifying things... and grasping straws - these are primarily UIs for the "settings". (linux systems has grown/evolved, at one time it was called pm-utils, ACPID, ACPI now it's controlled with systemd and/or dbus I suppose)


Don't use light-locker, but have lightdm as well. If any of this helps dig through what may be at issue.


Quote:
Anyway, xset looks like a nice work-around, if the OP wants to try that.
They may have more than a blank screen...
Quote:
I cannot wake the screen using key presses and mouse actions. The only thing that works is when I Ctrl+F<something>, then back to Ctrl+F7.
But I'm not really sure what those key functions are tied to. Is F<something> a special function key on like may laptops to enable key functions?
 
Old 08-11-2019, 09:40 AM   #11
m.a.l.'s pa
Member
 
Registered: Oct 2007
Location: albuquerque
Distribution: Debian, Arch, Kubuntu
Posts: 349

Rep: Reputation: 125Reputation: 125
Yeah, what the OP wrote sounds exactly like what was happening here. The monitor would go black and I couldn't do anything (that I could think of). Mouse wouldn't do anything, keys wouldn't do anything. Except I could still use Ctrl+Alt+F1 to get to a tty terminal, followed by Ctrl+Alt+F7 to get back into the Xfce session. The only other option I knew of was to do a hard reboot.
 
Old 08-11-2019, 10:05 AM   #12
djk44883
Member
 
Registered: Aug 2008
Location: Ohio
Distribution: debian
Posts: 118

Rep: Reputation: 28
Quote:
Originally Posted by m.a.l.'s pa View Post
Yeah, what the OP wrote sounds exactly like what was happening here. The monitor would go black and I couldn't do anything (that I could think of). Mouse wouldn't do anything, keys wouldn't do anything. Except I could still use Ctrl+Alt+F1 to get to a tty terminal, followed by Ctrl+Alt+F7 to get back into the Xfce session. The only other option I knew of was to do a hard reboot.

At this point, I'm not sure. Suddenly I vaguely recall swapping virtual terminals. But I though I was just finding a way to keep the screen "always on". My other systems have screen save set and suspend, they work as expected.
Disabling these is where I've encountered the issue, to what degree I can't recall exactly.
 
Old 11-27-2019, 07:22 AM   #13
Praveen_Rinku
LQ Newbie
 
Registered: Nov 2012
Posts: 6

Rep: Reputation: Disabled
screen is not resuming from blank state in Debian Buster

I have recently installed Buster on my PC. I have not installed any power management pkg or any screensaver.
The screen goes blank due to below xorg setting. Now if I press any keyboard button it doesn't lead to screen resume and I am left with rebooting only.
I am expecting that on my keyboard press , screen should resume. I am not sure what I am missing in my installation.
Though I can turn off xserver screen setting by "xset command" but that is the last thing I would like to do.

Below are brief logs where i have removed some parts.
Output of #xset q :
====================
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 64800 cycle: 600
DPMS (Energy Star):
Server does not have the DPMS Extension
===================
Xorg.0.log:
==================
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 18.979] Build Operating System: Linux 4.9.0-8-amd64 i686 Debian
[ 18.979] Current Operating System: Linux localhost 4.19.67-rt24 #1 PREEMPT RT Wed Nov 13 19:35:42 IST 2019 i686
--

[ 19.022] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 19.027] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 19.028] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(WW) modeset(0): Option "DPMS" is not used
[ 19.277] (II) Initializing extension Generic Event Extension
[ 19.277] (II) Initializing extension SHAPE
[ 19.277] (II) Initializing extension MIT-SHM
[ 19.277] (II) Initializing extension XInputExtension
[ 19.278] (II) Initializing extension XTEST
[ 19.278] (II) Initializing extension BIG-REQUESTS
[ 19.278] (II) Initializing extension SYNC
[ 19.278] (II) Initializing extension XKEYBOARD
[ 19.278] (II) Initializing extension XC-MISC
[ 19.278] (II) Initializing extension SECURITY
[ 19.278] (II) Initializing extension XFIXES
[ 19.279] (II) Initializing extension RENDER
[ 19.279] (II) Initializing extension RANDR
[ 19.279] (II) Initializing extension COMPOSITE
[ 19.279] (II) Initializing extension DAMAGE
[ 19.279] (II) Initializing extension MIT-SCREEN-SAVER
[ 19.280] (II) Initializing extension DOUBLE-BUFFER
[ 19.280] (II) Initializing extension RECORD
[ 19.280] (II) Initializing extension DPMS
=============================================
lspci :
VGA Controller Intel Corp rev09
============================================
 
Old 11-28-2019, 01:05 AM   #14
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 16,897
Blog Entries: 10

Rep: Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026Reputation: 5026
^ That cannot be caused by Xorg's screensaver.
Also that is never the whole XOrg.0.log.
And the lspci output seems to be lacking also.
Please start a new thread, explaining the problem in as much detail as possible, and add this information:
Code:
laptop-detect -v
lscpu
lspci -k
cat /var/log/Xorg.0.log
Please use CODE tags for cose, and make sure you show us the whole output.
 
  


Reply

Tags
debian, display, lightdm, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running script after screen wake - Debian 7 Shruikan Debian 2 07-30-2014 05:12 PM
Can I wake up a server in "standby" or "memory" mode using wake-on-lan? songweijia Linux - Server 2 03-03-2010 06:51 PM
wake on lan magic packet does not wake. albean Linux - Networking 1 06-30-2007 03:57 PM
konqueror won't work after after wake mandriva 2006 up from screen saver nila56 Linux - Software 3 06-08-2006 07:06 PM
Blank screen after "startx" after reboot after install cg from nvidia rozky Linux - Software 2 04-04-2005 08:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration