-   Debian (
-   -   Cups no longer working: printer useless (

realnerd 02-27-2007 03:48 PM

Cups no longer working: printer useless
Hello Debianers!

I need your help: I run Sarge with kernel 2.6.18-3-686 and my printer Epson Stylus color 600 can no longer use cups. This is the message I get when I try to use foomatic-gui to reconfigure my printer:

"(foomatic-gui:7111): GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
/usr/bin/foomatic-gui:264: GtkDeprecationWarning: gtk.TRUE is deprecated, use True instead
lpadmin: Unable to connect to server: Network is unreachable
Could not set up/change the queue "stylus_color_600"!
Reloading Common Unix Printing System: cupsd."

When I don't use cups (for example: cat file.txt > /dev/lp0) the printer is correctly working.

lpq and lprm don't work and seem to simply wait without providing any message.

The printer is linked to the computer using parallel port.

I'm a little bit lost, I don't even know how I can help you to help me. What is the information that you need?

Thanks in advance !!!

Quakeboy02 02-27-2007 03:58 PM

"lpadmin: Unable to connect to server: Network is unreachable"

Are you trying to use CUPS on an attached printer?

Did you make some network changes just before this happened? Did you update your kernel or anything relate to CUPS? Have you tried checking the CUPS configuration here? http://localhost:631/ That usually works for me when things mess up on my XP "printserver" due to my hacking around on things.

realnerd 02-28-2007 02:42 PM

Thanks for your reply.

I don't know what is an attached printer; mine is connected using parallel port.

I tried to connect to http://localhost:631/ but it fails.

I tried:

ping -c3 localhost
PING localhost.localdomain ( 56(84) bytes of data.

--- localhost.localdomain ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2001ms

As I have a message when I shutdown the computer indicating that a "named" cannot stop I somewhat googled and found that this is related to a programme "bind9".

I tried what I found on the Internet to localize the problem:

mabecane:/etc/init.d# /etc/init.d/bind9 stop
Stopping domain name service: namedrndc: connect failed: operation canceled

hostname gives "mabecane" which is the name I gave to my computer.

cat /etc/hosts gives:

### etherconf DEBCONF AREA. DO NOT EDIT THIS AREA OR INSERT TEXT BEFORE IT. localhost.localdomain localhost mabecane
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


If I cat /var/log/syslog | grep named

I get:

Feb 28 18:40:10 localhost named[5001]: starting BIND 9.2.4 -u bind
Feb 28 18:40:10 localhost named[5001]: using 1 CPU
Feb 28 18:40:10 localhost named[5001]: loading configuration from '/etc/bind/named.conf'
Feb 28 18:40:11 localhost named[5001]: ifiter_ioctl.c:236: REQUIRE(iter->pos < (unsigned int) iter->ifc.ifc_len) failed
Feb 28 18:40:11 localhost named[5001]: exiting (due to assertion failure)

I stop this, as I don't know if it is related to my problem.

I have one connection to Internet (via a usb modem Sagem 800) and no other network.
I do remember that some time ago I tried to get rid of a message concerning eth0 as I have nothing connected there...I may have broken something there!

NB: I do thank you for your reply: I had told my friends using Windoze that I was sure to get a reply at most one hour later, and you replied 10 minutes later!!

Thanks for your next suggestions.

Quakeboy02 02-28-2007 03:15 PM

I can't think of any reason that you should be running named; especially since you don't seem to really understand what it is. Also, if your browser won't bring up http://localhost:631/, then it seems that cupsd is no longer running on your system. Did you reconfigure your system or load a bunch of new software or remove some software without truly understanding what you were doing just before this happened?

Is the "cupsys" package still installed? Did you load "bind" for some reason?

All times are GMT -5. The time now is 09:31 PM.