-   Debian (
-   -   Cups misbehaving (

mjrich 02-22-2005 03:38 PM

Cups misbehaving
I have recently upgraded Cups (cupsys and cupsd, plus the foomatic* packages) and Firestarter to the current versions in Sarge; only to find that Cups is now behaving quite strangely.

A new printer can be installed, and a test page printed. However, from here on neither root nor any user can print to that printer (error: "client-error-not-possible"). Connections to the ip address of the printer are set to 'allow' in Firestarter, and no unexpected hits are seen in the logs.

One possible clue is that while the printers are all listed correctly by KDEPrint, on attempting to restart the Cups server the error "Error: Connection refused." Restarting Cups via /etc/init.d/cupsys restart works fine however.

Overal setup is: Sarge, 2.4.27-1-686 kernel, HP4200N printer (however same problem with other HP printers on the network).

Any thoughts ?



Dead Parrot 02-22-2005 04:37 PM

I've been able to solve some minor CUPS problems on my local printer by changing the LogLevel to debug in /etc/cups/cupsd.conf and then checking /var/log/cups/error_log . CUPS is a complex system and I don't understand much about it but the error messages in the log file pointed out where the problem was and helped to figure out what I needed to fix to get my printer working.

mjrich 02-22-2005 05:11 PM

Solved :)
Your suggestion of setting the debug level a bit higher worked - many thanks. KDEPrint was attempting to connect to Cups as user "", which unsurprisingly didn't get very far. Adding root to the users allowed to print seems to have solved it, though I've never come across this before. From the KDE Cups docs...

The server must initially be run as root, to support the default IPP of port 631. It changes users whenever an external program is run.


All times are GMT -5. The time now is 12:43 PM.