-   Debian (
-   -   cups broken in kde? Using Etch (

Mohtek 07-01-2006 09:23 PM

cups broken in kde? Using Etch
Hello all!
I hate posting on means that I am absolutely stuck :(

I have a fresh install, using latest Etch in KDE. The Printer is a Samsung ML 2010

When using the Control Center>periphials>printer, it freezes at the 'initializing manager'... stage, then errors out several minutes later. It says that it cannot connect to cups.
I have installed cupsys, cupsys-client, cupsys-driver-gutenprint, foomatic-filters, foomatic filters-ppds.
I'm in a round room trying to find the corner to sit in.

I have installed, purged, reinstalled... I have looked at the cool port and tried an install from there.
I do not know cups well enough to know what needs to be fixed.

I have learned much so far, but not enough to fix this.


IBall 07-02-2006 12:33 AM

Have you tried to install your printer using the web interface - http://localhost:631. It is quite self explanatory.

Is CUPS running - try "ps aux | grep cups"? If not, make sure that is is started.

I hope this helps

Mohtek 07-02-2006 06:51 AM

Yes, I have tried to install the printer....
Cups is running, and I have tried getting it to run from the web interface. The printer is said to work under Debian, and I have tried both the install program and manually installing it under the web interface.

I have two etch machines, and both of them have the same issue with the control panel>cups.

It says something to the effect that cups is not running or cannot be found. (ps aux| grep cups) and the web interface say otherwise.

I am perplexed.

Nishtya 07-09-2006 11:54 PM

Check in /etc/cups cups.conf file for a line:
Listen /var/run/cups/cups.sock and make sure it is commented out. Leave only localhost:631

Then do the same in /cups.d the ports.conf file.

I have had to go to through much trials with d-u's in sid lately to keep printing in KDE. I also had to copy the ppd file from an older install when configuring with the web interface

All times are GMT -5. The time now is 01:12 PM.