-   Debian (
-   -   CUPS atrocities /KDE-Aptitude cascading failure (

donnied 05-19-2012 01:44 PM

CUPS atrocities /KDE-Aptitude cascading failure
I should note that I run/ran Debian Squeeze / Wheezey AMD64 with a 32 bit Squeeze chroot.

Recently, I updated both main and chroot files using Squeeze repositories.

Something with CUPS or something else changed and the font became atrocious when printing PDFs and web pages. I tried reinstalling the CUPS drivers. That didn't help.

I removed all the CUPS files and reinstalled. The chroot seems fine now. I can print using 'lp' fine, print web pages and pdfs with a nice clear font.

I tried setting all the main system files to Squeeze (in sources.config). I downgraded and reinstalled - however, there was a circle of dependencies that could not be resolved -- even if the files in question had been removed. This is a bit beside the question as my main concern is being able to print decently outside of the chroot.

My printer is an HP 2600N.

As prompted by reportbug - I installed the Sid cups package.
The font is atrocious from web pages and pdfs.
lp fails with "/usr/lib/cups/filter/texttopdf failed" . Filing a bugreport.
The problems were present with Squeeze update -> Wheezey -> and now Sid.

I was reading elsewhere that this may possibly not be CUPS related.

Reinstalling cups-filters seems to help:

aptitude install cups-filters libcupsfilters1

All times are GMT -5. The time now is 02:25 PM.