LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Ctrl-Alt-Backspace Disabled by default - why?!? (https://www.linuxquestions.org/questions/debian-26/ctrl-alt-backspace-disabled-by-default-why-366727/)

brother.sand 09-24-2005 07:33 PM

Ctrl-Alt-Backspace Disabled by default - why?!?
 
OK,
What the heck? I have a debian 3.1 system running with xfree86 and the ctrl-alt-backspace hotkey is disabled. I've tried using the "DontZap" option in the ServerFlags section of the XF86Config-4 file but it has no effect. Also disabled are:

ctrl-alt-F1 (thru F6)
ctrl-alt-+
ctrl-alt-- (that's a minus there)

What's going on? I know that you can also disable this hotkey sequence with a "-T" flag to xinit but I don't see that anywhere. If sombody has already solved this problem I would love to hear about it.

Thanks,
D.

PS - When running gdm (prior to login) all of the above hotkey combos work.

RanDrake10 09-26-2005 06:42 AM

Do you have an entry in /etc/inittab
ca::ctrlaltdel:/sbin/shutdown -r now

SkyEye 09-26-2005 07:07 AM

Check your /etc/inittab
If it's commented (default in Sarge) like this
#ca::ctrlaltdel:/sbin/shutdown -r now
Ctrl-Alt-Del hotkey shoul be disabled.

If you get blank screens when you press Ctrl-Alt-F1 check for the lines saying to run "getty" or "agetty" or etc. on consoles 1-6.

brother.sand 09-26-2005 09:52 PM

Errr, ah, no. Not ctrl-alt-del. ctrl-alt-backspace. ctrl-alt-del on a console will reboot the system (has no effect during X sessions). I want ctrl-alt-backspace to kill the X session like it used to "back in the day". I also want ctrl-alt-F1 to go to the console screen. Right now it will only do that prior to login, from the gdm screen. Once the session starts the key sequences have no effect.

Actually, I mispoke before. ctrl-alt-backspace will not kill X from the gdm login either. ctrl-alt-F1 gets me to a console but ctrl-alt-backspace does nothing.

D.

zuralin 09-28-2005 02:32 PM

I am having a similar problem, ctrl+alt+f(x) doesn't work while logged in, but works fine while in GDM. However ctrl+alt+backspace works fine at all times. If you come across anything that fixes please post it, and I will do the same.


All times are GMT -5. The time now is 01:45 PM.