-   Debian (
-   -   Creating A New Device Node/Not A Valid Block Device (

indienick 07-12-2007 04:46 PM

Creating A New Device Node/Not A Valid Block Device
I didn't realize it until now, but when I installed Debian, it didn't recognize my 3.5" floppy drive.

I know this drive works, as it's recognized in the Windows XP part of my dual-boot situation.

This issue first became a problem when I tried to format a diskette, and check its contents before doing so. No matter which set of options I set with mount, mount still gave me an error. I quickly grepped an ls of /dev, and that's when it was confirmed: there was no /dev/fd0 node.

So, I created the node:

# mknod /dev/fd0 b 2 0
Tried mounting it again (as root and as a normal user), and still nothing.

Any ideas as to what the cause of all this could be? Before anyone suggests it, all the cables are in snugly.

Dutch Master 07-12-2007 05:16 PM

Did you update /etc/fstab as well? Otherwise the kernel won't know where to mount the new node ;)

indienick 07-12-2007 09:10 PM

Yup yup - it's updated.
Me making the /etc/fstab entry was what led me to discovering I didn't have a node for my floppy drive, in the first place!

nx5000 07-13-2007 05:01 AM

Is the module floppy and ide_floppy loaded?


mknod /dev/fd0 b 2 0
Now debian uses udev so this will vanish after reboot.

indienick 07-13-2007 02:07 PM

Those modules are loaded.
But the floppy drive is still not being recognized.

All times are GMT -5. The time now is 10:30 AM.