-   Debian (
-   -   creating a bootable knoppix 6 usb (

schaut 06-18-2009 06:30 PM

creating a bootable knoppix 6 usb
I have tried following the instructions at this link When I boot to the usb device grub starts loading then searches through the partitions on the device, then gives an error saying "could not mount disk to /mnt-system. Starting debugging Shell..." Has anyone had the same error or know what the problem is? Thanks in advance

linus72 06-18-2009 07:00 PM

It's alot easier than that bro,
I assume your usb is ext2 or ext3 with grub?

Please post your menu.lst (boot/grub/menu.lst) and what your computer is, etc.

and size of usb too

schaut 06-18-2009 07:15 PM

Here is my menu.lst
default 0
timeout 2
title knoppix
kernel /boot/isolinux/linux ramdisk_size=100000 init=/etc/init lang=us apm=power-off vga=791 initrd=minitr.gz nomce quiet BOOT_IMAGE=knoppix
initrd /boot/isolinux/minirt.gz

My computer is a dell latitude d600, my stick is 2 gigs using 1 gig as the linux partition ext2 and the second partition is a vfat. PS my menu.lst is the same as the one from the link I posted earlier.

linus72 06-18-2009 08:41 PM

OK, I used this how-to for installing tinycore to usb using grubster and it works great.
( )

best results I got were by dis-connecting hd, then using livecd to install grub to ext2/3
usb as hd0,0
it'll boot on some pc's that don't boot from usb, just using plop bootmanager cd/floppy
that's how I boot mine on emachines testbed(no usb boot)

right now, on single partition ext3 4gb usb
I have tinycore2.0, pupflux412, grml2009medium, and Gallibox puplet

here's my menu.lst from usb(grml excluded-long)


default 0
timeout 15

## Splash image!
splashimage /boot/grub/splashimages/grub_skull.xpm.gz

title TinyCore_2.0-USB
kernel /boot/bzImage quiet desktop=jwm restore=sda1/tce tce=sda1 waitusb=5
initrd /boot/tinycore.gz

title GalliBoxPup
kernel /boxpup/vmlinuz quiet pmedia=usbflash pfix=copy psubdir=boxpup
initrd /boxpup/initrd.gz

title PupFlux
kernel /pf/vmlinuz quiet pmedia=usbflash pfix=copy psubdir=pf
initrd /pf/initrd.gz

Note, there are no references to any root (hdx,x) anywhere.
works good too.:)
also, schaut, check your personal messages.

All times are GMT -5. The time now is 10:03 PM.