LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-10-2004, 05:21 PM   #1
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Arrow cdrecord setup


i have never burn a cd iso file under linux....i cannot get cdrecord to function...
it does not recognize my CDRW......here is my fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 /mnt/hda1 ntfs users,owner,ro,umask=000 0 0
/dev/hda5 /mnt/hda5 vfat users,owner,rw 0 2
/dev/hda6 /boot ext3 defaults 0 2
/dev/hda7 /opt reiserfs defaults 0 2
/dev/hda8 / reiserfs defaults 0 1
/dev/hda9 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

please advise
 
Old 08-10-2004, 05:52 PM   #2
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
did you try running cdrecord -scanbus (as root)?
your cd writer should show up something like this:
Code:
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
        0,0,0     0) 'HP      ' 'CD-Writer+ 9100 ' '1.0c' Removable CD-ROM
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
 
Old 08-10-2004, 06:04 PM   #3
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Original Poster
Rep: Reputation: 32
thank you for your reply...
yes this is the response

Code:
term6:~# cdrecord -scanbus
Cdrecord-Clone 2.01a34 (i686-pc-linux-gnu) Copyright (C) 1995-2004 J�rg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
      and thus may have bugs that are not present in the original version.
      Please send bug reports and support requests to <cdrtools@packages.debian.org>.
      The original author should not be bothered with problems of this version.

cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord:
cdrecord: For more information, install the cdrtools-doc
cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .
btw...i run 2.6.7 debian kernel
 
Old 08-10-2004, 06:13 PM   #4
zuralin
Member
 
Registered: Sep 2003
Distribution: Debian testing/unstable
Posts: 225

Rep: Reputation: 30
Have you tried reading /usr/share/doc/cdrecord/README.ATAPI.setup? I would start there (scroll down for info on the 2.6 kernels)
 
Old 08-10-2004, 08:13 PM   #5
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Original Poster
Rep: Reputation: 32
Quote:
Originally posted by zuralin
Have you tried reading /usr/share/doc/cdrecord/README.ATAPI.setup? I would start there (scroll down for info on the 2.6 kernels)
yes...thank you for the above....i have read it but still having trouble ....

i find the setup instructions confusing...

Code:
#ident @(#)cdrecord.dfl	1.4 02/07/07 Copyr 1998 J. Schilling
#
# This file is /etc/default/cdrecord
# It contains defaults that are used if no command line option
# or environment is present.
# 
# The default device, if not specified elswhere
#
CDR_DEVICE=cdrw
# 
# The default speed, if not specified elswhere
#
# Note that newer cdrecord versions do not default
# to speed=1. For MMC compliant drives, the default
# is to write at maximum speed, so it in general does
# not make sense to set up a default speed in /etc/default/cdrecord 
#
CDR_SPEED=12
cdrw=ATA:1,0,0     12       30m

# 
# The default FIFO size if, not specified elswhere
#
CDR_FIFOSIZE=4m

#
# The following definitions allow abstract device names.
# They are used if the device name does not contain the
# the characters ',', ':', '/' and '@'
#
# Unless you have a good reason, use speed == -1 and let
# cdrecord use it's intercal drive specific defaults.
#
# drive name	device	speed	fifosize driveropts
#
teac=		1,3,0	-1	-1	""
panasonic=	1,4,0	-1	-1	""
plextor=	1,4,0	-1	-1	""
sanyo=		1,4,0	-1	-1	burnfree
yamaha=		1,5,0	-1	-1	""
cdrom=		0,6,0	2	1m	""

Last edited by utanja; 08-10-2004 at 08:16 PM.
 
Old 08-11-2004, 08:22 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I didn't need to touch /etc/default/cdrecord at all to get gcombust working.

As far as I can remember, I just added "hdd=ide-scsi" to the kernel line in /boot/grub/menu.lst, "ide-scsi" and "sg" to /etc/modules, "pre-install ide-scsi modprobe ide-cd" to /etc/modprobe.d/cdrw (which I created) and then ran "update-modules" and rebooted.

This is largely the same procedure that is explained here:

http://www.debian.org/doc/manuals/re...en.html#s-cdrw

except that I had to apply it a bit for my Debian Sid system with Grub and 2.6.x kernel.
 
Old 08-12-2004, 04:37 AM   #7
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Original Poster
Rep: Reputation: 32
thanks for your comments DeadParrot

i will try your suggestions later tonite when i return from a flight....
 
Old 08-12-2004, 11:09 PM   #8
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Original Poster
Rep: Reputation: 32
i try your responses and seems to recognize the CDRW.....thank you so much....but now i must tend to hurricane preparing.....so i try after the storm to burn cds
 
Old 08-13-2004, 03:21 AM   #9
Sarinyo
LQ Newbie
 
Registered: Mar 2004
Posts: 16

Rep: Reputation: 0
Try it! :D

Hey, my advise is that if you're running KDE desktop (I don't know if it works with Gnome) you should try k3b. It's the Nero program for Linux. I am amazed, I thinks it's incredible! I try it and I've to configure nothing. Simply works pretty well. I've got a samsung CDRW and a Samsung CD on the same IDE and my CDRW works fine.

apt-get install k3b (I think)

Regards,

Marc.

Last edited by Sarinyo; 08-13-2004 at 07:26 AM.
 
Old 08-13-2004, 03:11 PM   #10
quentusrex
Member
 
Registered: Aug 2004
Location: Seattle, Washington
Posts: 101

Rep: Reputation: 15
Hey, thanks for posting the help. I just recently converted to Debian and couldn't get my 2 cd-rw drives to work. Just one thing though... On the boot up screen it says something about 'pre-install' and how it doesn't like it.

ignoring bad line starting with 'pre-install'

little help?
 
Old 08-14-2004, 10:22 PM   #11
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Original Poster
Rep: Reputation: 32
Re: Try it! :D

Quote:
Originally posted by Sarinyo
Hey, my advise is that if you're running KDE desktop (I don't know if it works with Gnome) you should try k3b. It's the Nero program for Linux. I am amazed, I thinks it's incredible! I try it and I've to configure nothing. Simply works pretty well. I've got a samsung CDRW and a Samsung CD on the same IDE and my CDRW works fine.

apt-get install k3b (I think)

Regards,

Marc.
thank you for your reply....but due to hurricane charley...been unable to power up until now...

i use gnome and not kde but thanks anyway....
 
Old 08-14-2004, 10:33 PM   #12
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,656

Rep: Reputation: 115Reputation: 115
Quote:
Originally posted by utanja


cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
If you still end up getting this error or for anyone finding this in a search then try using as root.
Code:
 chmod g+rw /dev/sg*
 chgrp cdrom /dev/sg*
 
Old 08-14-2004, 10:38 PM   #13
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,656

Rep: Reputation: 115Reputation: 115
Quote:
Originally posted by quentusrex
Hey, thanks for posting the help. I just recently converted to Debian and couldn't get my 2 cd-rw drives to work. Just one thing though... On the boot up screen it says something about 'pre-install' and how it doesn't like it.

ignoring bad line starting with 'pre-install'

little help?
That seems like you have a bad pre-install sg that some places suggest you use when using ide-scsi for burning. Try as root grep -i pre-install /etc/* to see where the setting is coming from. How have you setup the burning to try the ide-scsi? And could you post the output of dmesg | grep scsi and dmesg | grep hd and the contents of the file /etc/fstab.
 
Old 08-15-2004, 04:38 PM   #14
Ebel
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 63

Rep: Reputation: 15
k3b still works with Gnome, but in order to compile it I think you'd need to have KDE installed. It's a fantastic burning programme though.

I was having trouble with cdrecord also. I just downloaded and compiled to official version, and it worked grand. Damn RedHat messing with cdrecord!
 
Old 08-15-2004, 06:55 PM   #15
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Original Poster
Rep: Reputation: 32
Quote:
Originally posted by HappyTux
That seems like you have a bad pre-install sg that some places suggest you use when using ide-scsi for burning. Try as root grep -i pre-install /etc/* to see where the setting is coming from. How have you setup the burning to try the ide-scsi? And could you post the output of dmesg | grep scsi and dmesg | grep hd and the contents of the file /etc/fstab.
this is the outpuy on dmesg| scsi (no output) and dmesg|hd
Code:
term6:~# dmesg | grep scsi


term6:~# dmesg | grep hd
Kernel command line: root=/dev/hda5 ro
    ide0: BM-DMA at 0x4000-0x4007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:DMA, hdd:DMA
hda: ST3120023A, ATA DISK drive
hdc: CR-48XATE, ATAPI CD/DVD-ROM drive
hdd: LITEON DVD-ROM LTD163, ATAPI CD/DVD-ROM drive
hda: max request size: 128KiB
hda: 234441648 sectors (120034 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
VFS: Can't find ext3 filesystem on dev hda5.
VFS: Can't find ext2 filesystem on dev hda5.
ReiserFS: hda5: found reiserfs format "3.6" with standard journal
ReiserFS: hda5: using ordered data mode
ReiserFS: hda5: journal params: device hda5, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda5: checking transaction log (hda5)
ReiserFS: hda5: Using r5 hash to sort names
Adding 1009976k swap on /dev/hda11.  Priority:-1 extents:1
hdc: ATAPI 40X CD-ROM CD-R/RW CD-MRW drive, 2048kB Cache, UDMA(33)
hdd: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)
EXT3 FS on hda1, internal journal
ReiserFS: hda6: found reiserfs format "3.6" with standard journal
ReiserFS: hda6: using ordered data mode
ReiserFS: hda6: journal params: device hda6, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda6: checking transaction log (hda6)
ReiserFS: hda6: Using r5 hash to sort names
ReiserFS: hda7: found reiserfs format "3.6" with standard journal
ReiserFS: hda7: using ordered data mode
ReiserFS: hda7: journal params: device hda7, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda7: checking transaction log (hda7)
ReiserFS: hda7: Using r5 hash to sort names
ReiserFS: hda8: found reiserfs format "3.6" with standard journal
ReiserFS: hda8: using ordered data mode
ReiserFS: hda8: journal params: device hda8, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda8: checking transaction log (hda8)
ReiserFS: hda8: Using r5 hash to sort names
ReiserFS: hda9: found reiserfs format "3.6" with standard journal
ReiserFS: hda9: using ordered data mode
ReiserFS: hda9: journal params: device hda9, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda9: checking transaction log (hda9)
ReiserFS: hda9: Using r5 hash to sort names
ReiserFS: hda10: found reiserfs format "3.6" with standard journal
ReiserFS: hda10: using ordered data mode
ReiserFS: hda10: journal params: device hda10, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda10: checking transaction log (hda10)
ReiserFS: hda10: Using r5 hash to sort names
term6:~#
and here is my fstab
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1	/boot           ext3    defaults        0       2
/dev/hda5       /               reiserfs defaults        0       1
/dev/hda6       /opt            reiserfs defaults        0       2
/dev/hda7       /var            reiserfs defaults        0       2
/dev/hda8       /usr            reiserfs defaults        0       2
/dev/hda9       /home           reiserfs defaults        0       2
/dev/hda10      /tmp            reiserfs defaults        0       2
/dev/hda11      none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   iso9660 ro,user,noauto  0       0

i am using the 2.6.7 kernel but i can to the 2.4.6 kernel switch is better..

/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrecord CrEsPo Slackware 7 05-01-2005 01:16 PM
cdrecord help thick_guy_9 Slackware 4 02-18-2005 12:57 AM
cdrecord Pedroski Linux - Software 4 02-20-2004 12:15 PM
cdrecord help shanenin Linux - Software 1 11-23-2003 09:51 PM
cdrecord.. ramsees Linux - Software 2 08-07-2003 04:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration