LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   can't log in graphical environment (https://www.linuxquestions.org/questions/debian-26/cant-log-in-graphical-environment-90790/)

abd_bela 09-09-2003 03:04 AM

can't log in graphical environment
 
hi every body,
Finally I installed debian with redhat (and windows 98) in same machine,
so I can boot to any of the three system.
Now I have problem for loging to graphics with debian. with redhat No problem at all.
I have the graphical box interface, but when I put the username and passwd, It
restart with the same box interface. I can log with the text prompt, (Ctrl+F1, F6).

The more strange is if I log as a root with prompt text, and stop the X (level 3 ) , and
startx X, I log without problem. unfortunatly it refuse to startx as a normal user













hi everybody,
I finally installed redhat with debian in same machine.
My problem is I can log as text user , but not in a graphical part, the graphical box exists but when I put the username and password, the system tries to log but fails and
gives again the prompt box.
If I run level 2, and startx as root, it runs correctly
but as a normal user it doesn't run, it gives error:

couldn't load XKB
If there is an error in file why as root it runs it ??
my keyboard is french 105
this is my declaration
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"


than you for help
bela

nhs 09-09-2003 07:40 AM

If it refuses to load as anything other than root then it sounds like the permissions on /dev/mem or the keyboard device is to blame (I don't know which device file the keyboard is, probably /dev/kbd). Make sure all users have read and write permissions.

abd_bela 09-09-2003 11:42 AM

hi nhs,
thanks for reply
there is no /dev/kbd at all, instead in the redhat partition, the device
keyboard exists in /dev/input of redhat but not in /dev/input of the
debian partition (how create it ).
all the dev in /dev/input belong to root with crw----------- permission
other thing /dev/kmem and /dev/mem belong to news group in redhat
but belong to kmem group ( the groups exist) in debian :
the permission are : crw-r----- for all.
thank you very much

bela

nhs 09-12-2003 07:43 AM

Try "chmod a+rw /dev/input/*" and "chmod a+rw /dev/mem". This may solve your problem.


All times are GMT -5. The time now is 12:53 AM.