LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-08-2006, 08:39 PM   #1
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Rep: Reputation: 15
Cant find other hard drive files


I have a dual boot system.XP Pro on one drive and Debian on a seperate drive.I have used a couple of linux os's before (mandrake,Suse,Ubuntu) and in each linux os i could see the drive my xp pro was on.I have looked for ages trying to find my other drive in Debian so i can use some of the windows files that are used by both and they are nowhere to be seen.In devices which i thought it would be theres a couple of files: hda, hdb but they have a lock on them.

Also i tried putting a text file and a programme on cd from XP to open in debian but it read nothing.

Hope someone can please help me.
 
Old 01-08-2006, 09:01 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Quote:
In devices which i thought it would be theres a couple of files: hda, hdb but they have a lock on them.
Sounds like a simple permissions problem. Edit your /etc/fstab, and for the XP partitions, make sure 'user' option is there:
Code:
#example
/dev/hda1 /mnt/windows vfat noauto,user 0 0
Remount the drives, and the lock should be gone...
 
Old 01-08-2006, 09:32 PM   #3
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bulliver
Sounds like a simple permissions problem. Edit your /etc/fstab, and for the XP partitions, make sure 'user' option is there:
Code:
#example
/dev/hda1 /mnt/windows vfat noauto,user 0 0
Remount the drives, and the lock should be gone...
/etc/fstab is a readonly file it wont let me enter anything
 
Old 01-08-2006, 09:36 PM   #4
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
Yup. You will need to be root to edit it...
 
Old 01-08-2006, 09:39 PM   #5
LeftyAce
Member
 
Registered: Oct 2005
Distribution: Debian
Posts: 69

Rep: Reputation: 15
you must be root to edit /etc/fstab. Open a command line and type su and hit enter. It will prompt for the root password (which will not display at all as you type it). If su was successful, you can type whoami and be told "root". If you entered the password incorrectly, su will give an error (sorry if these instructions are unnecessary; it speeds things up to give them to you up front)
Once root, use a text editor such as nano to edit the fstab file.

EDIT: Sorry bulliver; took so long typing mine I didn't see you'd posted back already.

Last edited by LeftyAce; 01-08-2006 at 09:40 PM.
 
Old 01-08-2006, 09:44 PM   #6
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by LeftyAce
you must be root to edit /etc/fstab. Open a command line and type su and hit enter. It will prompt for the root password (which will not display at all as you type it). If su was successful, you can type whoami and be told "root". If you entered the password incorrectly, su will give an error (sorry if these instructions are unnecessary; it speeds things up to give them to you up front)
Once root, use a text editor such as nano to edit the fstab file.

EDIT: Sorry bulliver; took so long typing mine I didn't see you'd posted back already.
i did su to become root. i opened fstab in text editor it still wont let me type.
 
Old 01-08-2006, 09:46 PM   #7
LeftyAce
Member
 
Registered: Oct 2005
Distribution: Debian
Posts: 69

Rep: Reputation: 15
hmmmmm. what text editor are you using? (you must use one started on the command line where you became root)
 
Old 01-08-2006, 09:55 PM   #8
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
ok got it opened properly now cant save it.
 
Old 01-08-2006, 10:01 PM   #9
LeftyAce
Member
 
Registered: Oct 2005
Distribution: Debian
Posts: 69

Rep: Reputation: 15
"can't save it" do you get an error? what does it say? (I assume it's opened as a non-readonly file) Make sure it's not open in any other editors.... and if ur root, there should be no problem. (which editor are you using? if it's on the command line, that's ok but I don't know if a graphical editor launched by root will have root permissions.)
 
Old 01-08-2006, 10:05 PM   #10
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
using GEDIT

it says /fstab is read only do you want to replace it .I said yes but it said could not save it

by the way this what it said when i useed fdisk
Disk /dev/hda: 40.0 GB, 40060001280 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 4869 39110211 7 HPFS/NTFS

Disk /dev/hdb: 10.2 GB, 10245537792 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 1245 10000431

Last edited by rsuave; 01-08-2006 at 10:07 PM.
 
Old 01-08-2006, 10:14 PM   #11
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Also this was my fstab file before i typed anything

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb1 / ext3 defaults,errors=remount-ro 0 1
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
 
Old 01-08-2006, 10:14 PM   #12
LeftyAce
Member
 
Registered: Oct 2005
Distribution: Debian
Posts: 69

Rep: Reputation: 15
Aha. That's the problem. Don't use GEDIT. I'm pretty sure you have to use a command line text editor in order for su to give the editor root priveleges. So, in your console, become root and type
Code:
nano /etc/fstab
use the arrow keys to position cursor, and add the line suggested by bulliver. Then hit <ctrl>+X to exit. Hit <enter> when it asks u if u want to save the changes (I think it says something about the "modified buffer").
 
Old 01-08-2006, 10:27 PM   #13
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
ok i ve done that. A Windows directory appeared but got this message

Unable to mount the selected volume.:
mount: mount point /mnt/windows does not exist
 
Old 01-08-2006, 10:28 PM   #14
rsuave
Member
 
Registered: Nov 2004
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
thanks for your help guys. The reason i didnt put this in newbie is i thought id be better off putting it in its own os.
 
Old 01-08-2006, 10:34 PM   #15
LeftyAce
Member
 
Registered: Oct 2005
Distribution: Debian
Posts: 69

Rep: Reputation: 15
Not sure what you mean by "a windows directory appeared"
But, I do know what the mount error means. There's no directory called /mnt/windows, yet you're trying to mount the windows partition in a directory by that name. As root, create a /mnt/windows directory by typing
Code:
mkdir /mnt/windows
Incidentally (spelling???) this problem and the fix suggested by bulliver are not distro specific, so it would have worked fine in the newb section. On the other hand, no harm done putting it here; I for one don't usually wander into the newbie forums.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot find hard drive error Darthbudge Linux - Newbie 1 11-23-2005 11:26 PM
Cannot Find Hard Drive mathewjn Linux - Hardware 2 08-30-2005 04:14 PM
Can't find external hard drive Tianlangyan Linux - Newbie 6 11-11-2004 10:46 AM
Slackware can't find my hard drive! jeffChuck Slackware - Installation 5 07-12-2004 04:11 AM
Slack 9.1 can not find hard drive but 9.0 did neurotic Slackware 3 11-18-2003 01:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration