-   Debian (
-   -   Cannot mount more than 8 iso image files as loop device (

marsim 11-05-2004 10:46 AM

Cannot mount more than 8 iso image files as loop device
Hi all,

I've Debian 3.0 r2 and i cannot mount more than 8 iso files, how can I mount more loop devices ?

hitesh_linux 11-05-2004 10:51 AM

Be discriptive about this issue. from which path are you trying to mount iso file. post ur qurey with more details so other members can try to troubleshoot this issue.


marsim 11-05-2004 02:19 PM


i want to use my debian linux woody 3.0 r2 as a cd-rom jukebox having a number of cd-rom image files mounted as loop device using with:
mount -o loop -t iso9660 cdrom1.iso /mnt/iso1
mount -o loop -t iso9660 cdrom2.iso /mnt/iso2
mount -o loop -t iso9660 cdromn.iso /mnt/ison

but after mounting 9 devices when i try to mount the 10th i get the error msg:
mount: could not find any free loop device

I also modified without success lilo.conf "appending max_loop parameter

append="console=tty0 console=ttyS0,9600n8 max_loop=32"

and before i tried to modify a config file (don't remember at this moment wich one) without success.

I hope this message better explains the problem.

jschiwal 11-05-2004 08:00 PM


3.1. Adding the Loop Module Option

Current kernels allow you to set the number of loop devices supported without recompiling the kernel. One of these methods is to add an options line to /etc/modules.conf. This method will only work if your loop support has been configured as a loadable kernel module (which is how most major Linux distributions come preconfigured now).

Edit /etc/modules.conf and add the following line.

options loop max_loop=64

After making the above change, simply reboot. Or you can try to use rmmod and insmod to make the change on the fly - but this will not work if you currently have any loop devices mounted (you'll get an error saying loop: Device or resource busy).

marsim 11-09-2004 04:05 AM

once again i tried to put away any doubt...

the problem stills remain :-(

this is an extract from dmesg:

Only 8 devices!! I setted up the script as suggested in the how-to. (I tried also to modifying the lilo.conf appendig the parameter as suggested in the how-to)

Is it a debian Woody r2 and r3 bug ?
oppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Loading I2O Core - (c) Copyright 1999 Red Hat Software
I2O configuration manager v 0.04.
(C) Copyright 1999 Red Hat Software
loop: loaded (max 8 devices)
Compaq CISS Driver (v 2.4.5)
8139cp 10/100 PCI Ethernet driver v0.0.6 (Nov 19, 2001)
8139cp: pci dev 00:0b.0 (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
8139cp: Try the "8139too" driver instead.
8139too Fast Ethernet driver 0.9.24

All times are GMT -5. The time now is 08:05 PM.