LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-28-2004, 01:56 AM   #1
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Rep: Reputation: 30
Cannot go back with older libc6


Yesterday evening it seems that I screwed up my apt-get system... I have apt-get installed libc6, libdb1-compat, and python2.3 (downloaded as .deb. packages and installed manually) in a desperate attempt to install pyXMMS and pyKDE but it ended up as a whole mess.. Now I cannot apt-get install another package - I'm having this error:

Code:
root@tiger:~# apt-get install "somepackage"
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  libc6: Depends: libdb1-compat but it is not going to be installed
  libc6-dev: Depends: libc6 (= 2.2.5-11.5) but 2.3.2.ds1-11 is to be installed
  python2.3: Depends: python (>= 2.3) but 2.1.3-3.2 is to be installed
             Depends: libdb4.2 but it is not installable
             Depends: libncurses5 (>= 5.3.20030510-1) but 5.2.20020112a-7 is to be installed
             Depends: libreadline4 (>= 4.3-1) but 4.2a-5 is to be installed
             Depends: libssl0.9.7 but it is not installable
             Depends: zlib1g (>= 1:1.2.1) but 1:1.1.4-1.0woody0 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

The version of libc6 installed (over the new one):
Code:
root@tiger:~# apt-cache policy libc6
libc6:
  Installed: 2.3.2.ds1-11
  Candidate: 2.3.2.ds1-11
  Version Table:
 *** 2.3.2.ds1-11 0
        100 /var/lib/dpkg/status
     2.2.5-11.5 0
        500 http://http.us.debian.org stable/main Packages
        500 http://security.debian.org stable/updates/main Packages
I think that the only possible solution would be to remove libc6 and revert back to the original one, so i tried:

Code:
apt-get install libc6=2.2.5-11.5
But it didn't allow me, telling me the previous dependency problems:

Code:
root@tiger:~# apt-get install libc6=2.2.5-11.5
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
Sorry, but the following packages have unmet dependencies:
  libdb1-compat: Depends: libc6 (>= 2.2.5-13) but 2.2.5-11.5 is to be installed
  python2.3: Depends: python (>= 2.3) but 2.1.3-3.2 is to be installed
             Depends: libc6 (>= 2.3.2.ds1-4) but 2.2.5-11.5 is to be installed
             Depends: libdb4.2 but it is not installable
             Depends: libncurses5 (>= 5.3.20030510-1) but 5.2.20020112a-7 is to be installed
             Depends: libreadline4 (>= 4.3-1) but 4.2a-5 is to be installed
             Depends: libssl0.9.7 but it is not installable
             Depends: zlib1g (>= 1:1.2.1) but 1:1.1.4-1.0woody0 is to be installed
  python2.3-xmms: Depends: libc6 (>= 2.3.2.ds1-4) but 2.2.5-11.5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Is there a way to go around in problems like this (except of desperately wanting to crash the machine) ?

regards,
ganninu

Last edited by ganninu; 01-28-2004 at 05:07 AM.
 
Old 01-29-2004, 02:31 AM   #2
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
Question why did you do that?

First you need a good obstruction!

Never, ever do that again...

You have a fixed dependency now (libc6-dev: Depends: libc6 (= 2.2.5-11.5)), so you have to work that out first

the 2.2.5-11.5 is an old version for you.

Do what the tool says you should do....

Quote:
Try 'apt-get -f install' with no packages

and pray...

it might be good thing to uninstall the libdb1-compat package first with the dpkg tool (probably by force) and then run the 'apt-get -f install' command
 
Old 01-29-2004, 02:33 AM   #3
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
and another thing, generally, is not a good ideea to try to downgrade libc6
 
Old 01-29-2004, 03:04 AM   #4
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Original Poster
Rep: Reputation: 30
I uninstalled libc6 and now my entire system got freaked, i.e. I cannot use the command line!!! (things like ls, mv, cp, etc.. do not work anymore)

I learned this ---- NEVER TAMPER WITH THE LIBC6 PACKAGE!!!!!!!!!!!!!!!! ----

Now I backed up all the data from the Windows partition (had a dual boot box, and for the first time I found windose useful). Now I'm taking the opportunity to switch to FreeBSD (I still needed to install some day since it supports my Sis650 graphic chipset). Nontheless, I will equip my laptop with Debian....

Cheers guys.
ganninu

Last edited by ganninu; 01-29-2004 at 03:07 AM.
 
Old 01-29-2004, 08:38 AM   #5
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
I'm also rather certain that when you tried to uninstall libc6 that dpkg/apt made you type a sentence that says something to the effect of "I know this can totally screw up my system, but do it anyway." So, you sort of dug your own hole there

Why did you have libc6 from unstable on a stable system. Do NOT mix branches unless you know very well what you are doing (I know very well what I am doing and I would still never do it ). If you want newer stuff, then by all means, use unstable, but DON'T just start pulling random packages from the unstable branch and installing them on your stable distribution.
 
Old 01-29-2004, 10:14 AM   #6
ganninu
Member
 
Registered: Jul 2003
Distribution: RH 7.3/8.0/9.0, Debian Stable 3.0, FreeBSD 5.2, Solaris 8/9/10,HP-UX
Posts: 340

Original Poster
Rep: Reputation: 30
By the way, I downloaded the unstable ISO, but the CD didn't boot (I mean, i KNOW how to burn bootable CDs) - is that the "unstable" debian cannot be installed on a cold boot?
 
Old 01-29-2004, 11:11 AM   #7
Strike
Member
 
Registered: Jun 2001
Location: Houston, TX, USA
Distribution: Debian
Posts: 569

Rep: Reputation: 31
As far as I know, there are no official unstable branch installation CDs. The only official installation CDs are for stable. You can upgrade to unstable from stable relatively easily, though.
 
Old 01-30-2004, 02:29 AM   #8
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
Quote:
Originally posted by Strike
I'm also rather certain that when you tried to uninstall libc6 that dpkg/apt made you type a sentence that says something to the effect of "I know this can totally screw up my system, but do it anyway." So, you sort of dug your own hole there

Why did you have libc6 from unstable on a stable system. Do NOT mix branches unless you know very well what you are doing (I know very well what I am doing and I would still never do it ). If you want newer stuff, then by all means, use unstable, but DON'T just start pulling random packages from the unstable branch and installing them on your stable distribution.
better, yet, backport!
take the sources and make a package for the woody branch.

I know that sometimes it can be a drag, but most of the packages are on backports.org or apt-get.org
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I revert back to an older kernel? jspaceman Slackware 3 10-30-2004 05:07 PM
libc6 problem otaking.se Debian 0 09-24-2004 02:52 PM
how to revert back to older version of XFree86? pdmackenzie Linux - Software 3 06-18-2004 09:28 AM
libg++-libc6.2-2.so.3 xgamer Slackware 1 03-06-2004 02:48 PM
libstdc++-libc6.2-2.so.3 tommytomato Linux - General 1 12-12-2003 02:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration