-   Debian (
-   -   cannot execute binary on directory mounted by nfs (Debian wheezy) Permission denied. (

kaz2100 02-15-2012 11:59 PM

cannot execute binary on directory mounted by nfs (Debian wheezy) Permission denied.

There are 3 systems (all of them are Debian wheezy X86_64), connected by network. File sharing by nfs v3.

PenguinA: NFS client for /common/bin/
PenguinB: NFS client for /common/bin/

Whale: NFS server for /common/bin/, where many binaries are sitting.

This system used to work flawlessly.
After dist-upgrade today, PenguinA cannot execute binaries on /common/bin, error message is "Permission denied" if full path is specified.
"which" command cannot point any binaries under /common/bin/.

PenguinB has no trouble.

So far
Troubleshooting process follows;
Shell variables have correct values.
/etc/fstab has not been edited for a quite while.
Logs under /var/log do not show much.
Following look good form both PenguinA and PenguinB owner, group, permission.

"mount" on PenguinA shows "noexec". I need to find out where "noexec" comes from.

What is next?

Any suggestions will be appreciated!

sag47 02-16-2012 06:21 PM

What does the fstab entry look like for your NFS share (options, etc)?

From the mount man page...


The programs mount and umount maintain a list of currently mounted filesystems in the file /etc/mtab. If no arguments are given to mount, this list is printed.
Run the mount command. It's also possible that /etc/mtab is incorrectly configured. You can edit /etc/mtab just like /etc/fstab and remove a noexec option if it is specified.

Try remounting the NFS share with the exec option, what happens?


mount -o remount,exec /my/NFS/share
Alternatively you can delete the entry for the mount in /etc/mtab, unmount your filesystem, mount it again so that mtab is updated with new options.

kaz2100 02-16-2012 07:23 PM


Thanks, sag47

Yes, /etc/fstab has options "rw,user,noauto,vers=3", which has been sitting for a while.

"mount" command gives "noexec" again.
"mount -o remount,exec" fails, exit code is 32.

/common/ is "fsck"ed, so hopefully filesystem is not corrupted.


sag47 02-16-2012 07:26 PM

Did you check /etc/mtab? Did you try deleting the mtab entry, unmounting and then mounting the share again (3 steps)?

kaz2100 02-16-2012 08:12 PM


Yes, I checked /etc/mtab, which had noexec.

No, I have not tried your three steps.

I tried to umount, checked mtab to make sure no /common/, and mount, without success.
I put exec option on fstab, no success.

Then I tried your three steps, BINGO!

Thanks a lot.

All times are GMT -5. The time now is 08:48 AM.