LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-28-2009, 05:21 PM   #1
christian130
LQ Newbie
 
Registered: Aug 2009
Posts: 2

Rep: Reputation: 0
Unhappy cannot access to any of gnome systems utils except synaptic and the welcome screen ap


Hello.

After upgrading from etch to lenny, I can not access any of
items from system-> administration.
gives the following error:
"you are not allowed to access the system configuration"

version of debian Lenny

attempted solutions:

1 .- I AM ROOT: |

2 .- apt-get install - reinstall - fix-missing-utils gnome-system

3 .- apt-get install - reinstall - fix-missing dbus

4 .-.- apt-get build-dep - reinstall dbus

5 .- slightly modify the / etc / group and optionally: / etc /
passwd

I leave my / etc / group to see how it turned

root: x: 0: christian8
daemon: x: 1:
bin: x: 2:
sys: x: 3:
adm: x: 4: christian8
tty: x: 5:
disk: x: 6:
lp: x: 7:
mail: x: 8:
news: x: 9:
uucp: x: 10:
man: x: 12:
proxy: x: 13:
kmem: x: 15:
dialout: x: 20: christian8
fax: x: 21:
voice: x: 22:
cdrom: x: 24: christian8
floppy: x: 25: christian8
tape: x: 26:
sudo: x: 27:
audio: x: 29: gdm
dip: x: 30:
www-data: x: 33:
backup: x: 34:
operator: x: 37:
list: x: 38:
irc: x: 39:
src: x: 40:
gnats: x: 41:
shadow: x: 42:
utmp: x: 43:
video: x: 44: christian8
sasl: x: 45:
plugdev: x: 46: christian8
staff: x: 50:
games: x: 60:
users: x: 100:
nogroup: x: 65,534:
crontab: x: 101:
ssh: x: 102:
christian: x: 1000:
christian2: x: 1003:
bind: x: 103:
messagebus: x: 104:
gdm: x: 105: christian4
haldaemon: x: 106: christian8
powerdev: x: 107:
netdev: x: 108:
dhcp: x: 109: christian8
christian3: x: 1001:
christian5: x: 1004:
christian6: x: 1005:
libuuid: x: 110:
scanner: x: 111:
stb-admin: x: 112:
ssl-cert: x: 113:
lpadmin: x: 114:
christian8: x: 1002:
ntp: x: 115:

the user which i use with GDM and default is: christian8
There is also another error that whatever ALSA DEPENDS ON WORK
ONLY WITH THE ROOT USER!

postdata: i tried so hard looking for a solution in google but unfortunely could not found
i'm quite desperate about this problem because it takes another and another
i'll put my /proc/cpuinfo for more details
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel(R) Pentium(R) 4 CPU 2.26GHz
stepping : 5
cpu MHz : 2261.044
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up cid xtpr
bogomips : 4525.95

i'm using the kernel

2.6.18-6-686


i'also put my sudoers file /etc/sudoers:

# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
#
# Defaults env_reset
# Host alias specification
# User alias specification
# Cmnd alias specification
# User privilege specification
root ALL=(ALL) ALL

really really thanks in advance

Last edited by christian130; 08-28-2009 at 05:25 PM.
 
Old 08-30-2009, 06:40 AM   #2
j1alu
Member
 
Registered: Apr 2009
Distribution: debian gnu/linux
Posts: 798

Rep: Reputation: Disabled
you still got gksu installed?

if so, id try running the upgrade again and/or adding another user and check if the problem exists there too.

on a site note: is there any reason you use the 2.6.18-kernel? default is 2.6.26-2-686

Last edited by j1alu; 08-30-2009 at 06:42 AM.
 
Old 08-30-2009, 11:24 AM   #3
christian130
LQ Newbie
 
Registered: Aug 2009
Posts: 2

Original Poster
Rep: Reputation: 0
thanks to j1alu for reply my question!, ok i had the 26 kernel but i decided to change my sources.list to the official one post in debian.org and then the result was it upgrade to a previous version. I tried to reinstall gksu and got the same problem
the problem persists even if i'm running GDM as ROOT USER!, anyway the trouble related to alsa would fix if i'm really root i mean logging GDM with root and so on.

i put my sudoers file cuz in the previous version (etch), i changed the default one.

another, there is a daemon that is installed with the upgrade command, the daemon beggings with AVAHI, it gave me an error, so i deleted it in the rc2.d folder.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: More ways to gain access to systems you have physical access to LXer Syndicated Linux News 0 05-03-2009 12:20 PM
gnome-powermanager suspend error (quriks/pm-utils) vatten Linux - Software 0 09-06-2008 10:24 AM
icon-naming-utils not getting picked up during gnome-icon-theme... rendezvous123 Linux - Software 1 08-05-2007 12:42 AM
Access mysql from other systems dipu Linux - Networking 2 12-27-2003 01:04 PM
Gnome 2.4 with Synaptic FXRS Red Hat 0 10-19-2003 01:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration