LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-11-2011, 05:21 PM   #1
rewesh
LQ Newbie
 
Registered: Oct 2011
Posts: 12

Rep: Reputation: Disabled
Red face can not run aptitude nor apt-get to install any package


just did aptitude-upgrade and ended up with a message no matter what i do" E: I wasn't able to locate file for the mysql-server-5.0 package. This might mean you need to manually fix this package.
Writing extended state information... Done
E: I wasn't able to locate file for the mysql-server-5.0 package. This might mean you need to manually fix this package.
E: Internal error: couldn't generate list of packages to download"

I have tried some comand ( not in hte right order )
aptitude clean, install -f
dpkg --configure -a, clear-avilable


I do not want to update mysql from etch to lenny and i marked it as hols in apptitude, however still the same message. how can i fix this. thanks
 
Old 10-11-2011, 06:38 PM   #2
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,398
Blog Entries: 7

Rep: Reputation: 167Reputation: 167
post up your sources.list

Code:
cat /etc/apt/sources.list
 
Old 10-11-2011, 07:34 PM   #3
rewesh
LQ Newbie
 
Registered: Oct 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
#############################################################
################### OFFICIAL DEBIAN REPOS ###################
#############################################################

###### Debian Main Repos
deb http://ftp.us.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.us.debian.org/debian/ lenny main contrib non-free

###### Debian Update Repos
deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://ftp.us.debian.org/debian/ lenny-proposed-updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ lenny-proposed-updates main contrib non-free


##############################################################
##################### UNOFFICIAL REPOS ######################
##############################################################

###### 3rd Party Binary Repos

#### Bimoid - http://bimoid.com/
## Run this command: wget -O - http://www.bimoid.com/debian/apt.key | apt-key add -
#deb http://www.bimoid.com/debian/ stable non-free

#### Debian Multimedia - http://www.debian-multimedia.org/
## Run this command: apt-get update && apt-get install debian-multimedia-keyring && apt-get update
#deb http://www.debian-multimedia.org oldstable main

#### Dotdeb - http://www.dotdeb.org
## Run this command: wget -q -O - http://www.dotdeb.org/dotdeb.gpg | apt-key add -
#deb http://packages.dotdeb.org oldstable all

#### Enlightenment - http://enlightenment.org
## Run this command: wget -q http://packages.enlightenment.org/repo.key -O- | apt-key add -
#deb http://packages.enlightenment.org/debian lenny main extras

#### Esmska - http://code.google.com/p/esmska/
## Run this command: wget -q -O - http://repo.palatinus.cz/repo.key | apt-key add -
#deb http://repo.palatinus.cz/stable /

#### Google Linux Software Repositories - http://www.google.com
## Run this command: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -
#deb http://dl.google.com/linux/deb/ stable non-free main

#### Google Linux Software Repositories (Testing) - http://www.google.com
## Run this command: wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add -
#deb http://dl.google.com/linux/deb/ testing non-free

#### Lenny and a Half - http://wiki.debian.org/LennyAndAHalf
#deb ftp://ftp.debian.org/debian lenny-proposed-updates main

#### Opera .deb Repository - http://deb.opera.com/
## Run this command: wget -O - http://deb.opera.com/archive.key | apt-key add -
#deb http://deb.opera.com/opera/ lenny non-free

#### Opera .deb Repository (Beta Releases) - http://deb.opera.com/
## Run this command: wget -O - http://deb.opera.com/archive.key | apt-key add -
#deb http://deb.opera.com/opera-beta/ lenny non-free

#### Unofficial Maintainer - http://unofficial.debian-maintainers.org/
## Run this command: wget -q -O - http://unofficial.debian-maintainers...rchive-key.asc | apt-key add -
#deb http://unofficial.debian-maintainers.org/ lenny main contrib non-free restricted

#### VirtualBox - http://www.virtualbox.org
## Run this command: wget -q http://download.virtualbox.org/virtu...racle_vbox.asc -O- | apt-key add -
#deb http://download.virtualbox.org/virtualbox/debian lenny contrib

#### Webmin - http://webmin.com/
## Run this command: wget -q http://www.webmin.com/jcameron-key.asc -O- | apt-key add -
deb http://download.webmin.com/download/repository sarge contrib


####### 3rd Party Source Repos

#### Dotdeb (Source) - http://www.dotdeb.org
## Run this command: wget -q -O - http://www.dotdeb.org/dotdeb.gpg | apt-key add -
#deb-src http://packages.dotdeb.org oldstable all

#### Unofficial Maintainer (Source) - http://unofficial.debian-maintainers.org/
## Run this command: wget -q -O - http://unofficial.debian-maintainers...rchive-key.asc | apt-key add -
#deb-src http://unofficial.debian-maintainers.org/ lenny main contrib non-free
 
Old 10-11-2011, 09:12 PM   #4
62chevy
Member
 
Registered: Mar 2002
Location: West (By God) Virginia
Distribution: Debian Squeeze - Sid
Posts: 281

Rep: Reputation: 45
Your /etc/apt/sources.list looks fine to me at least the main ones for Debian.

If ' aptitude update && aptitude full-upgrade ' doesn't do it then you may need to pin mysql to the version in Etch.

/etc/apt/preferences

Code:
Package: xserver-*
Pin: version 2:1.10.4-1
Pin-Priority: 700

Package: xserver-xorg-video-sisusb
Pin: version 1:0.9.4-2+b1
Pin-Priority: 700
Something like this.
 
1 members found this post helpful.
Old 10-13-2011, 01:34 PM   #5
rewesh
LQ Newbie
 
Registered: Oct 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
I did try these,however still the same error.

Package: mysql*
Pin: version 5.0.32-7et
Pin-Priority: 700

And

Package: mysql-server-5.0
Pin: version 5.0.32-7et
Pin-Priority: 700
 
Old 10-13-2011, 02:19 PM   #6
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
Add the repos for Etch back, comment out lenny for now.
aptitude update && aptitude dist-upgrade
pin mysql or use dpkg to hold
echo mysql hold|dpkg --set-selections
add lenny repos back comment etch
aptitude update
aptitude safe-upgrade
aptitude full-upgrade
 
1 members found this post helpful.
Old 10-13-2011, 04:24 PM   #7
rewesh
LQ Newbie
 
Registered: Oct 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
I am receiving this error

1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up mysql-server-5.0 (5.0.32-7etch12) ...
Stopping MySQL database server: mysqld failed!
invoke-rc.d: initscript mysql, action "stop" failed.
/etc/init.d/mysql: ERROR: Using expire_logs_days without log_bin crashes the server. See README.Debian.gz failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.0 (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
mysql-server-5.0
E: Sub-process /usr/bin/dpkg returned an error code (1)
Some errors occurred while unpacking. I'm going to configure the
packages that were installed. This may result in duplicate errors
or errors caused by missing dependencies. This is OK, only the errors
above this message are important. Please fix them and run [I]nstall again
Press enter to continue.
 
Old 10-20-2011, 05:06 PM   #8
rewesh
LQ Newbie
 
Registered: Oct 2011
Posts: 12

Original Poster
Rep: Reputation: Disabled
I solved this by, Stopping mysql manually and commenting the line expire_logs_days
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt/aptitude package management "auto" flag cjmueller Debian 2 10-16-2011 10:52 PM
Error when install package aptitude! rosy84 Linux - Software 7 04-28-2011 07:20 AM
(new install)) How does one install Synaptic package manager... Aptitude cannot find Pooped Debian 9 08-23-2010 12:31 AM
[Aptitude] Is it possible to check which package automatically install packageA? Akhran Debian 2 03-13-2006 12:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration