LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Can I install mod_evasive in apache2 when installed from repo? (https://www.linuxquestions.org/questions/debian-26/can-i-install-mod_evasive-in-apache2-when-installed-from-repo-436883/)

OneBinary 04-19-2006 05:51 PM

Can I install mod_evasive in apache2 when installed from repo?
 
Hi All,

I would like to install mod_evasive into my apache2 installation. The instructions say I need to use apxs to install mod_evasive, but the problem is I installed apache2 via apt-get and I am unable to find a apxs binary.

If I recall apxs can only be enabled during the ./configure when compiling/installing from source.

Any ideas how I can install mod_evasive into apache2 on my Debian system?

nx5000 04-20-2006 04:37 AM

apxs should be in apache-dev:
http://packages.debian.org/cgi-bin/s...table&arch=all

OneBinary 04-20-2006 08:21 AM

Yeah I saw that, but is there an apache2-dev? I don't want a bunch of apache1.3 crap floating around on my system. Also since I did not compile from source, would using apxs to build another module screw up my existing install (installed from repo)?

nx5000 04-20-2006 10:11 AM

From this: http://megaz.arbuz.com/2004/08/02/apache-performance/
it doesn't seem that you need to recompile apache, also why its called "modules"..

apache2-threaded-dev seems to be for apache2 threaded(normal). For preforked apache2, apache2-prefork-dev


All times are GMT -5. The time now is 07:22 AM.