LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-01-2003, 08:08 AM   #1
rahaydenuk
LQ Newbie
 
Registered: Nov 2003
Posts: 18

Rep: Reputation: 0
Can't start X-Windows on laptop with GeForce 4


Hi,

I'm pretty new to Linux (especially Debian). I've successfully got Debian dual-booting with Windows XP, but I can't get X-Windows to start. I get the "no screen" error when I try and run startx. I've tried multiple times to configure X to the best of my abilities using xf86config, all with no success.

I am on a laptop with an NVIDIA GeForce 4 440 Go 64Mb video card and a standard laptop LCD display (max res. 1024x768). I have a wireless USB Microsoft IntelliMouse Explorer and a standard laptop keyboard.

Here's my XF86Config-4 file so that hopefully someone can tell me what I'm doing wrong:


#######################################

### BEGIN DEBCONF SECTION
# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.
#
# To change things within the debconf section, run the command:
# dpkg-reconfigure xserver-xfree86
# as root. Also see "How do I add custom sections to a dexconf-generated
# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "pex5"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xie"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "uk"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nv"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

### END DEBCONF SECTION

#######################################


Thanks,

Richard Hayden.
 
Old 11-01-2003, 10:07 AM   #2
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
I have had problems getting laptops to display unde XFree86 at anything but their native resolution. You say your laptop's resolution is 1024x768, but you don't have a 1024x768 resolution defined in your XF86Config-4 file.

Also, you have a generic monitor defined instead of a generic LCD monitor (assuming you pulled this off of a XFree86 config tool database instead of coming up with the settings yourself).

Looking through the /var/log/XFree86.0.log file, instead of just the reported final error, can sometimes be instructive.

Good luck.
 
Old 11-01-2003, 02:17 PM   #3
Windy
LQ Newbie
 
Registered: Nov 2003
Location: Germany
Distribution: Debian Woody
Posts: 3

Rep: Reputation: 0
I had a similar problem, but not at a labtop.
There was only one little question in the xserver setup that causes the problem.
When i was asked if i want to use frame buffering, i entered the default answer 'yes', but that was wrong to my system.
Maybe your system don't needs/supports frame buffering too.
You can do the setup of the xserver again and answer with 'no' or you can edit the XF86Config-4 file (just delete the line 'Option "UseFBDev" "true"'):

...
Section "Device"
Identifier "Generic Video Card"
Driver "nv"
EndSection
...
 
Old 11-01-2003, 05:37 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,596

Rep: Reputation: 98
If you are using Xfree 4.1 you may want to upgrade it does not support Geforce4 cards or get the driver from Nvidia then compile, install and use that.
 
Old 11-02-2003, 01:31 AM   #5
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 48
Theirs a few things wrong with the file

remove the lines:
Code:
Load "GLcore"
Load "dri"
.
.
Section "DRI"
Mode 0666
EndSection
Change the 'Section "Device"' part too:
Code:
Section "Device"
	Identifier	"Video Card"
	Driver		"nvidia"
	Option		"NoLogo" "true"
	Option		"RenderAccel" "true"
EndSection
Then Finally change the Device line under section screen too 'Device "Video Card"'.

If you want that max res add "1024x768" to the modes lines.

Now you can get the driver for you GeForce4 from debian depending on you setup (i.e. unstable/stable) you'll need to do diffrent things, check the packages site http://www.uk.debian.org/distrib/pac...earch_packages and search nvidia, you'll probably have to compile one ( Its best ) let us know if you need help with that

Last edited by leonscape; 11-02-2003 at 01:36 AM.
 
Old 11-02-2003, 01:54 AM   #6
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 47
before the change to nvidia will work you need to install the driver form nvidia.com, it is a .run file you run at command prompt

you need to do this, nvidia2go devices will nto work without the driver (except when using framebuffer rather than nv)
 
Old 11-02-2003, 06:04 AM   #7
Kiada
Member
 
Registered: Apr 2003
Distribution: Mandrake 10.1
Posts: 39

Rep: Reputation: 15
hmmm sorry to jump in, but ive got the same kinda setup and im trying to install nvidias drivers i just downloaded (the .run file) but it tells me xserver is on and it wont install unless its off...

I'm a complete noob lol, i was wondering how to get the install working? how do i shut down X server? any help appreciated...

**Edit: damn, didnt realise this was the Debian Distro forum, i just used the search. Well.. im using Mandrake 9.1, soz about that...

Last edited by Kiada; 11-02-2003 at 06:06 AM.
 
Old 11-02-2003, 06:29 AM   #8
rahaydenuk
LQ Newbie
 
Registered: Nov 2003
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by exodist
before the change to nvidia will work you need to install the driver form nvidia.com, it is a .run file you run at command prompt

you need to do this, nvidia2go devices will nto work without the driver (except when using framebuffer rather than nv)
Hi,

I've already downloaded this .run file and have attempted to run it at the prompt. It couldn't find a pre-compiled kernel interface so it wanted to compile one. Next it couldn't find the kernel headers (as they weren't installed), so I installed the kernel-source package for my kernel version (and put in a symlink /usr/src/linux pointing to it). I then had errors about 'modversions.h' couldn't be found, but after reading various posts on the net I managed to create it using the command 'make oldconfig' followed by 'make dep' on the makefile in /usr/src/linux. I honestly don't know what this actually did or whether it did it correctly, but it did create the missing 'modversions.h'. I now get an error saying my C compiler is not the same version used to originally compile the kernel (or something like that). It tells me I can set IGNORE_CC_MISMATCH to bypass this check but I don't know whether this would be a good idea. Anyone know where I go next?

Thanks,

Richard Hayden.
 
Old 11-02-2003, 11:00 AM   #9
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 47
Kiada:
hold control+alt+f1, if that takes you to a place you can't type hold alt+f2 and you should get login prompt (if you need to go back to X press control+alt+f7
after you login the text console type this, at least 2, maybe all 3 will fail, that is not a problem:
killall -9 gdm
killall -9 xdm
killall -9 kdm
next type:
killall -9 X
that will close x, and previous commands will keep it from respawning
now use the run file from the terminal and it should work

also do not forget tot make the change from nv to nvidia in the config file


rahaydenuk:
the problem is that the version of your running kernel, and the version of the kernel source are different, you d-loaded and installed the wrong one. you can go ahead and use the ignore_cc_mismatch, hope it works, but if it does not it isn't the end of the world.
you can try it liek this:
IGNORE_CC_MISMATCH=1
./whatever.run
if that does nto work you will need to extract source and do it manually (not hard)
./whatever.run --extract-only
cd [directory made by previous command]/usr/src/nv/
type these until one works:
IGNORE_CC_MISMATCH=1 make
make IGNORE_CC_MISMATCH=1
make IGNORE_CC_MISMATCH=1 install
if none of those work we will need to do it differently, but lets hope this does.
next type
cd ../../../
make
make install

that should install it, if you casn follow these directions though you can probably even recompile your own kernel (easyer than it sounds)
that would be safer for your hardware.
now after driver is installed just mod the config file with nvidia instead of nv
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X server doesn't start - Mandrake 10.0 GeForce FX 5200 WXGA varadha Linux - General 0 07-03-2004 07:01 PM
Mandrake 10 - Geforce 5200 - X Refuses to Start houston1981 Mandriva 3 06-09-2004 06:03 PM
Probl. Screen res in widescreen laptop with nvidia Geforce FX 5200 amaya Linux - Software 1 04-13-2004 05:02 PM
Installing Fedora on Laptop > GeForce FX 5200 Go Jefklak Red Hat 5 12-27-2003 04:49 AM
I can't get my box to start after installing Geforce 4 MX 420 tarballedtux Linux - Hardware 24 07-11-2002 11:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration