LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-19-2004, 04:52 PM   #1
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Rep: Reputation: 77
Can't start X on Debian


Ok, so I installed Debian (testing) this weekend and everything went well. Tried installing the nVidia drivers and got some error about no precompiled kernel so had to back out of the nVidia installer.

Now when I rebooted and tried to startx, I get some nVidia error saying that it can't startx.

I know this is such a general question and should list specifically what the error says but thought off the top of someones head, they know what should be done.
 
Old 10-20-2004, 04:58 AM   #2
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Did you compile the nvidia driver then? If there's no kernel on the ftp site it'll try to build some itself. Did that happen or did you escape the setup?
 
Old 10-21-2004, 08:11 AM   #3
MikeZila
Member
 
Registered: Jul 2004
Location: Parts Unknown
Distribution: Arch
Posts: 377

Rep: Reputation: 30
Post

Don't worry if it says there isn't a compiled kernel interface. It doesn't mean anything is wrong, it just means that you either have to download one or compile one yourself. In any case, you don't have to do anything directly, it will either download and use one from nvidia's ftp site, or compile one all on its own.

Just let the installer complete.
 
Old 10-21-2004, 09:35 AM   #4
Oxyacetylene
Member
 
Registered: Apr 2004
Location: Greensboro, NC, USA
Distribution: Debian
Posts: 134

Rep: Reputation: 15
I had to get the nvidia drivers installed for my newly installed system last night. I found this site and used the tutorial to install the drivers the "debian way" and it worked great. Maybe this will help you?

http://home.comcast.net/~andrex/Debi...dia/index.html
 
Old 10-21-2004, 12:46 PM   #5
MikeZila
Member
 
Registered: Jul 2004
Location: Parts Unknown
Distribution: Arch
Posts: 377

Rep: Reputation: 30
Wait....theres a "Debian" way?

Is the nVidia installer something a Debian user shouldn't use?
 
Old 10-21-2004, 01:10 PM   #6
Oxyacetylene
Member
 
Registered: Apr 2004
Location: Greensboro, NC, USA
Distribution: Debian
Posts: 134

Rep: Reputation: 15
You can install the drivers either way. Using the nvidia installer might get you newer drivers and it might be easier to update later, but I had trouble getting it to work for me that way, so I used the tutorial I posted the link to and used the Debian tools to install the driver.
 
Old 10-21-2004, 01:35 PM   #7
Kethinov
Member
 
Registered: Oct 2003
Location: ESU, Student Teaching 5th Grade
Distribution: Ubuntu
Posts: 118

Rep: Reputation: 15
Here's how I installed my nvidia card in Debian. There may be easier ways to do this, but none of the guides I found on the net worked.

Note: Being root when doing this makes things easier.

Note: Change your apt sources to unstable or testing. Take your favorite text editor over to /etc/apt/sources.list. Change "stable" to "testing" or "unstable".

Note: Make sure you have gcc installed.

Code:
apt-get install gcc
Note: Make sure you have libc6-dev installed.

Code:
apt-get install libc6-dev
Note: Make sure you have make-kpkg installed.

Code:
apt-get install kernel-package
Note: Make sure you have modconf installed.

Code:
apt-get install modconf
---

Firstly, you need a kernel source to match your kernel.

Question: I don't understand why the kernel has anything to do with installing some video drivers...
Answer: Because the kernel is where the DRI interface is which is necessary for 3D with any type of speed. If all you want is 2D you can use the "nv" module that comes with XFree. In which case you shouldn't be reading this tutorial...

Run this to see what kernel you have:

Code:
uname -a
Then install the source code for your kernel. You can find the kernel source by searching for it:

Code:
apt-cache search kernel-source
Then simply apt-get install the source that matches your kernel and decompress it if apt doesn't do it for you.

After that, you need to get the nvidia kernel:

Code:
apt-get install nvidia-kernel-source nvidia-kernel-common
That will give you a source tarball in /usr/src called nvidia-kernel-source.tar.gz.

Now you need to decompress it:

Code:
cd /usr/src
tar -zxf nvidia-kernel-source.tar.gz
Next, for confirmation, please run:

Code:
ls /usr/src
You should get output that looks something like this:
kernel-source-2.x.x.tar.bz2 modules nvidia-kernel-source.tar.gz

Note: Adjust the following commands to match your kernel source.

Now that that's out of the way, you can copy your kernel config and make a custom nvidia installer for your system.

Code:
cd /boot
cp config-2.x.x-1-386 /usr/src/kernel-source-2.x.x
cd /usr/src/kernel-source-2.x.x
mv config-2.x.x-1-386 .config
make oldconfig
make-kpkg modules_image
After all that you should now see something like nvidia-kernel-2.x.x_1.0.5336-6+10.00.Custom_i386.deb in /usr/src. If so, run:

Code:
dpkg -i nvidia-kernel-2.x.x_1.0.5336-6+10.00.Custom_i386.deb
Note: Adjust that command to match your file.

Next you need to run modconf and make sure nvidia is on the list.

Code:
modconf
There should be an entry on that list somewhere regarding nvidia. (It should be at the bottom.) If all you see is a lot of kernel/blah/blah and nothing with the word nvidia in it, then exit out of modconf and run:

Code:
ls /lib/modules
You should see some output that looks something like this:
2.x.x 2.x.x-1-386 modprobe.conf modprobe.conf.old

Note: If you have multiple kernels, ignore them. If you ran into the modconf not seeing nvidia problem, you should see two directories referencing your current kernel as the output above does.

Now check to see if there is a nvidia subdirectory in both of those directories.

Code:
ls /lib/modules/2.x.x-1
ls /lib/modules/2.x.x
If this happened to you, it installed the nvidia kernel module in the wrong tree. In my case, it should have went in /lib/modules/2.x.x-1. It needs to be copied over. Do so, then update your modules and run modconf again:

Code:
cp -r /lib/modules/2.6.4/nvidia/ /lib/modules/2.x.x-1-386/
update-modules
modconf
Nvidia should be on your modconf list this time. Highlight it and hit enter. You should be able to install the module now. If all goes well, there should be a + sign next to it in modconf.

Now you're probably going to want nvidia-glx:

Code:
apt-get install nvidia-glx
Now you're going to want to edit your XF86Config in /etc/X11 with your favorite text editor. In the Device section, change Driver "nv" to Driver "nvidia". Also comment out the lines Load "GLcore" and Load "dri". You'll also want to add Option "RenderAccel" "true" to the Device section along with turning NvAGP on.

Here is a sample finished Module section:

Code:
Section "Module"
        #Load   "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        #Load   "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "vbe"
EndSection
And here is a sample finished Device section:

Code:
Section "Device"
        Identifier      "NVIDIA Corporation NV25 [GeForce4 Ti 4200]"
        Driver          "nvidia"
        Option "RenderAccel" "true"
        Option "NvAGP" "1"
        #Option "NoLogo" "true"
EndSection
Finally, since you've been doing this all as root, you may need to make sure that the other users of the computer can use the card:

Code:
chmod 777 /dev/nvid
Now your card should work. If you were running any X sessions while doing this, restart them. Otherwise, just start X. You should see a nvidia splash screen. The best way to test to see if your card really is working is to try running an OpenGL application. OpenGL screensavers are a good choice. I like Euphoria, personally.

I hope this tutorial was helpful!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get xmame to start Debian jbasement Debian 1 04-16-2005 11:37 PM
Can start the X Windows in Debian explorer1979 Debian 6 08-27-2004 01:35 AM
debian start up scripts? pgte3 Debian 7 08-25-2004 07:42 PM
X won't start on Matrox Millneium II, Debian dstrozzi Linux - Newbie 6 06-16-2003 12:46 PM
Debian / X won't start kwong Linux - General 4 03-03-2003 01:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration