Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 06-15-2005, 01:30 PM   #1
LQ Newbie
Registered: Jun 2005
Location: canada
Distribution: debian
Posts: 4

Rep: Reputation: 0
can't start kde in sarge.

This is my first post here as I am somewhat new to the world of linux. My first attempt at linux was debian woody on pearpc. I was able to install and configure x server to run kde. Unfortunatelly it ran very slow and was somewhat limited to what I could do but I did enjoy it.
I finally got an old computer running and have installed sarge. Installed X server and got gnome running. I have installed kde but haven't been able to start kde. When I type startkde I recieve this:

xsetroot: unable to open display
xset: unable to open display
xsetroot: unable to open display
startkde: starting up...
startkde: running kpersonalizer...
kwin: cannot connect to x server
kpersonalizer: cannot connect to x server

Gnome runs I believe as default when I startx. I haven't decided which display I like best but would like to explore both. How could I go about this? Is there a way to set up x to give me this option?Any help would be greatly appreciated,thanks in advance.
Old 06-15-2005, 02:39 PM   #2
Dead Parrot
Senior Member
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
If you insist on starting X from the command line, you need to create a .xinitrc file into your home directory. It's the file that "startx" command will check to see which DE (gnome or kde) it should start. You can make the contents of .xinitrc to look like this:

#exec gnome-session
exec startkde

This will tell "startx" to start kde. If you want to start gnome instead, just move the # character to the beginning of the other line.

However, you might want to install a GUI display manager like gdm or kdm that lets you to choose from a menu which DE (gnome or kde) you want to start. If you have trouble starting the display manager automatically, you can install the "rcconf" package that lets you enable/disable the services started at boot time.
Old 06-15-2005, 08:00 PM   #3
LQ Newbie
Registered: Jun 2005
Location: canada
Distribution: debian
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks Dead Parrot installed gdm and I am off to the races. Thanks again for your help I do appreciate it. 1109 posts eh, wow I have a lot of learning to do.Thanks again and I am sure we'll talk again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Sarge 3.1 LXF70 XWindows fails to start - Missing symbols cgtueno Debian 1 09-05-2005 09:07 AM
X-Windows fails to start & other Debian sarge install issues tommilo Linux - Newbie 30 03-02-2005 09:49 AM
Start DHCPd and configure iptables on boot (Debian Sarge) Qis Linux - Networking 6 03-02-2005 05:34 AM
Debian sarge - unable to start X VertX Linux - Newbie 3 02-03-2005 10:56 AM
XMMS Crashes program start, Linux Sarge System rjcmi Debian 7 10-08-2004 03:51 PM > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:55 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration