LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-04-2005, 06:14 PM   #1
howarddevore
Member
 
Registered: Apr 2005
Distribution: not sure yet
Posts: 115

Rep: Reputation: 15
can't sign in as root


oh shoot...

I've just spent ages getting x to work - and it does!

however now I've rebooted, the all new *graphical* login doesn't recognize my passwords

I've some ideas about this:
When i first got X and gnome working i noticed that on the web when i type the key for the 'at' symbol I got a double speech mark instead of the a in a circle. So i reckon i entered the wrong information for my keyboard type. Reckon i could be correct here?

Anyway, luckily for me, my usr password had the double speechmark as its non alphanumeric symbol, so by substituting the 'at' key for the speechmark symbol, i was able to login as usr.

However, that leaves my root password. There are two symbols that i guess i need to find substitues for...?

Other than that, does anyone have any ideas about this or anything.
I'm a bit green to say the least with linux, and am resisting a big melting scream

//
howard
 
Old 07-04-2005, 06:15 PM   #2
howarddevore
Member
 
Registered: Apr 2005
Distribution: not sure yet
Posts: 115

Original Poster
Rep: Reputation: 15
to add to that, weirdly using the su command seems to enable me to use my root password...is this normal?

//howard
 
Old 07-05-2005, 04:11 AM   #3
nvm
LQ Newbie
 
Registered: Jun 2005
Location: Glasgow, Scotland
Distribution: Debian
Posts: 12

Rep: Reputation: 0
By default most graphical login managers don't allow logins from route. Which login manager are you using?
If you can find an options tab on the login manager, after putting in your password (which it'll prompt you for to change the settings) there might be a 'allow root to login' option.
 
Old 07-05-2005, 04:44 AM   #4
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Debian doesn't allow root-login, I don't think it's a setting in login-manager but somewhere else.
Anyway, don't log in to GUI as root!
Install a small program 'sux' (apt-get install sux) and use that in terminal instead of 'su'.
You can then start applications as root if you need to.
Quote:
So i reckon i entered the wrong information for my keyboard type. Reckon i could be correct here?
Correct!
1. Check /etc/X11/XF86-Config-4
In Section "InputDevice" you have something like:
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
change that 'se' to whatever it should be for you.

2. If you use KDE, then check ControlPanel->Region & accessibility and System Administration -> loginmanager. (Or something like it, I'm translating from Swedish here).
 
Old 07-18-2005, 03:14 AM   #5
bp12345
Member
 
Registered: Jun 2005
Distribution: Debian testing, Kubuntu 5.04
Posts: 104

Rep: Reputation: 15
If you go to login options you can change that and you can login as root. This is in gdm, I don't know about kdm or xdm.
 
Old 07-18-2005, 05:41 AM   #6
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
I know it's not encouraged to login as root, but if you want to add root to KDM, open a console, su to root, open a text editor, gedit, kate or something, and go to /etc/kde3/kdm and the file you need to alter is kdmrc. Nearly halfway down the file you'll find the following.
# Allow root logins?
# Default is true
AllowRootLogin=false

Change false to true, save the change, and when you next login you'll find root added to the KDM menu. Nigel. aka farpoint.
 
Old 07-18-2005, 02:16 PM   #7
pradeepyamujala
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Debian-Sarge, WinXP, 2003 Server, Longhorn
Posts: 5

Rep: Reputation: 0
Thumbs up If u still have the same problem then read this

This is the same problem that lots of debian users do get. And here is the solution....

For security reasons Debian do not allow u login as root (Then how to enter please do not ask me in u r in X). but it is just a option. login as normal user. then go to "LOGIN SCREE SETUP" there under SECURITY" tab check first option "Allow ROOT TO LOGIN" and close the app. now logout and enter the root password

Bye
All the best. Enjoy Debian- The Ultimate
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sign on invisible in gaim - NOT invi after sign on saravkrish Linux - Software 7 09-12-2005 11:55 PM
can't sign on as root samuelmp Ubuntu 3 09-04-2005 10:36 AM
Why must I sign on as root before using KPPP dialup? jawq Linux - Newbie 4 06-11-2005 11:37 AM
how do i sign into root with one command? provkitir Linux - Newbie 12 10-28-2004 08:08 PM
sign in hythemr Red Hat 1 08-31-2003 08:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration