LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-31-2003, 01:34 PM   #1
tunny
LQ Newbie
 
Registered: Aug 2003
Distribution: debian
Posts: 5

Rep: Reputation: 0
Red face can't see files on fat32


I've managed to set up my system as a newbie pretty good but now I'am stuck.I can see my common directory(on a separate HD visible to all OS on system)as root but not logged on as user.Please can anybody point me in the right direction.If you need to see my edited fstab or mtab then reply

Last edited by tunny; 09-03-2003 at 06:20 PM.
 
Old 08-31-2003, 02:03 PM   #2
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Posting your /etc/fstab would help greatly.

You may need to add the user option, this allows normal users to mount and un-mount the partition.
 
Old 08-31-2003, 02:46 PM   #3
tunny
LQ Newbie
 
Registered: Aug 2003
Distribution: debian
Posts: 5

Original Poster
Rep: Reputation: 0
thanks for the help.
/etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hde1 / ext3 defaults,errors=remount-ro 0 1
/dev/hdc1 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
# partitions found by Knoppix
#/dev/hde1 /mnt/hde1 auto noauto,users,exec 0 0
#/dev/hde2 /mnt/hde2 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppix 0 0
/dev/hdc2 /mnt/hdc2 auto noauto,users,showexec,umask=022,uid=andrew,gid=andrew 0 0
/dev/scd0 /cdrom auto ro,noauto,user,exec 0 0
/dev/scd1 /cdrecorder auto ro,noauto,user,exec 0 0


/dev/hde1 / ext3 rw,errors=remount-ro 0 0
/dev/root.old /initrd ext2 rw 0 0
none /proc proc rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/cdrom /cdrom iso9660 ro,noexec,nosuid,nodev,user=andrew 0 0
/dev/scd1 /cdrecorder iso9660 ro,nosuid,nodev,user=andrew 0 0
/dev/hdc2 /common vfat rw,nosuid,nodev,user=andrew 0 0

Last edited by tunny; 08-31-2003 at 02:56 PM.
 
Old 08-31-2003, 03:10 PM   #4
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
check the permissions for /common. It could be that non-root users are not allowed to enter it. If so, change the permissions (you have to be root to do this).
 
Old 08-31-2003, 03:18 PM   #5
pe2338
Member
 
Registered: Dec 2002
Location: Bucharest,RO
Distribution: debian etch, sarge and sid
Posts: 407

Rep: Reputation: 30
Wink check out this thread

Had the same problem solved like this:

http://www.linuxquestions.org/questi...threadid=85773
 
Old 08-31-2003, 03:52 PM   #6
tunny
LQ Newbie
 
Registered: Aug 2003
Distribution: debian
Posts: 5

Original Poster
Rep: Reputation: 0
I've tried to change the permissions for common using chown as root,get operation not permitted going to look for another way to change permission.
read previous thread helped me to mount common but don't understand some of the last bits will reread and repost.
thanks for all your help time for bed

Last edited by tunny; 08-31-2003 at 03:56 PM.
 
Old 08-31-2003, 03:59 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
the command is chmod. As root, you'd do
chmod a+x /common
but more to the point, were the permission messed up?
 
Old 08-31-2003, 05:28 PM   #8
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
Using chmod on a mounted vfat filesystem will not work.
To set permissions for a non-Linux filesystem, use the umask option.
user=andrew is an incorrect syntax.

If you want to allow all normal users to mount, un-mount and access a vfat partition.
Code:
/dev/hdc2 /common vfat rw,nosuid,nodev,user,umask=000 0 0
To set file ownership to one user (andrew) with write permission.
Code:
/dev/hdc2 /common vfat rw,nosuid,nodev,user,uid=andrew,gid=andrew,umask=022 0 0
 
Old 08-31-2003, 05:50 PM   #9
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
I once had a mount point /blah which for some reason only root was allowed to enter. When I mounted a filesystem on /blah, regardless what it said in fstab, a normal user could not see what's there. I thought that something similar might be happening.
 
Old 09-03-2003, 05:59 PM   #10
tunny
LQ Newbie
 
Registered: Aug 2003
Distribution: debian
Posts: 5

Original Poster
Rep: Reputation: 0
quick recap checked permissions every thing seemed OK till I had a flash of inspiration and went back and checked the groups I'am in,using KUser.What an idiot I had forgotten to tick any boxes.everything now visible,apologies for wasting everyones time.
great forum...creep....creep.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Copying large files to FAT32 sketch7 Linux - General 11 10-22-2007 10:13 AM
Accessing FAT32 files rknetsch Linux - Newbie 3 06-16-2005 11:40 AM
FAT32 - Files Invisibles upset Slackware 14 06-25-2004 05:11 PM
Can't see files in a FAT32 Folder +joni Mandriva 4 05-10-2004 11:48 AM
Certain FAT32 files become empty shoota Linux - General 2 11-07-2003 07:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration