LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-12-2004, 08:43 PM   #1
webvandals
Member
 
Registered: Aug 2003
Posts: 105

Rep: Reputation: 15
Unhappy Can't install KDE headers in Ubuntu


I need KDE headers so I can configure/compile Quanta. But here's what happens:
Quote:
The following packages have unmet dependencies:
kdelibs4-dev: Depends: libarts1-dev (> 1.2.1) but it is not going to be installed
E: Broken packages
root@LinuxBox:/home/sean/src/kdewebdev #
What should I do?
 
Old 11-13-2004, 01:29 AM   #2
Ironi
LQ Newbie
 
Registered: May 2003
Location: Lansing, MI
Distribution: Debian
Posts: 27

Rep: Reputation: 15
apt-get build-dep quanta should fetch everything you need.
 
Old 11-13-2004, 09:49 AM   #3
webvandals
Member
 
Registered: Aug 2003
Posts: 105

Original Poster
Rep: Reputation: 15
Nope no dice

Quote:
root@LinuxBox:/tank/home_sean # apt-get build-dep quanta
Reading Package Lists... Done
Building Dependency Tree... Done
E: Build-dependencies for quanta could not be satisfied.
root@LinuxBox:/tank/home_sean #
 
Old 11-13-2004, 02:59 PM   #4
Ironi
LQ Newbie
 
Registered: May 2003
Location: Lansing, MI
Distribution: Debian
Posts: 27

Rep: Reputation: 15
Hrm... Do you have the universe source uncommented in /etc/apt/sources.list ? Ubuntu doesn't provide KDE packages by default.

Last edited by Ironi; 11-13-2004 at 03:05 PM.
 
Old 11-13-2004, 06:20 PM   #5
webvandals
Member
 
Registered: Aug 2003
Posts: 105

Original Poster
Rep: Reputation: 15
I should have mentioned before; I have universe enabled.

But I think I may be getting closer. In my first post you can see that the source of the trouble is the package: "libarts1-dev"

If I try to apt-get install that package, I get this love note:
Quote:
The following packages have unmet dependencies:
libartsc0-dev: Depends: libartsc0 (= 1.2.3-1) but 1.3.1-1 is to be installed
E: Broken packages
root@LinuxBox:/tank/home_sean #
...and finally, if I try install the package that apt complains about in that message ("libartsc0"). I just get this:
Quote:
libartsc0 is already the newest version.
And so I reach a dead end.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install kde headers mdhowe Linux - Software 2 06-16-2005 11:48 PM
Kalamaris install...No KDE headers? exluddite Linux - Software 2 02-12-2005 05:08 PM
checking for KDE... configure: error:, no KDE headers installed mythief Mandriva 4 10-23-2004 09:20 AM
checking for KDE... configure: error:, no KDE headers installed mythief Linux - Software 2 10-23-2004 06:20 AM
KDE headers tincat2 Linux - Software 14 06-23-2002 02:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration