LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 10-19-2004, 04:51 PM   #1
binboy35
LQ Newbie
 
Registered: Sep 2004
Location: Canada
Distribution: Debian Sarge (kernel 2.4), Slackware 10.0
Posts: 20

Rep: Reputation: 0
browser is not working


My browser, Mozilla-Firefox, only works while I'm logged in as root. When logged in as user, it wont come up at all and I get the following script in x-term....

===========================================
autoselected local: en-US
Xlib: connection to " :0.0" refused by server
Xlib: XDM authorization key matches an existing client

(firefox-bin1697): Gtk-WARNING **: cannot open display:
=============================================

Any help is appreciated. Thanks.
 
Old 10-19-2004, 10:29 PM   #2
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
Are you logging in as root and then su'ing to user? What directory did you install firefox in?

Try the command
xhost +
Then try to start firefox
 
Old 10-20-2004, 11:28 AM   #3
binboy35
LQ Newbie
 
Registered: Sep 2004
Location: Canada
Distribution: Debian Sarge (kernel 2.4), Slackware 10.0
Posts: 20

Original Poster
Rep: Reputation: 0
It worked. After I typed xhost +, I got the following script,

access control disabled, client can connect from any host.

then I started my browser no problem.

I consider the matter now resolved. Thank you for your help and the link (linuxbasics).

 
Old 10-20-2004, 11:21 PM   #4
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
Great you got it going Just to let you know, if you want a better way to do it

xhost +localhost

That way it doesn't give other hosts access to the local X server.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox browser not working hspk Red Hat 9 02-19-2007 05:36 PM
MPlayer Browser Plug-In Not Working BarfBag SUSE / openSUSE 4 10-24-2005 04:13 PM
Konqueror Audio Browser Not Working (k wmeler Linux - Software 3 05-31-2004 02:51 AM
Browser not working Drogo Linux - Software 14 02-02-2003 02:00 AM
RD 8.0 Hardware Browser Not Working? Mikest Linux - Hardware 3 12-06-2002 06:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration