LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (https://www.linuxquestions.org/questions/debian-26/)
-   -   Booting to initramfs, gave up waiting, /dev/disk/by-uuid/xxxx does not exist (https://www.linuxquestions.org/questions/debian-26/booting-to-initramfs-gave-up-waiting-dev-disk-by-uuid-xxxx-does-not-exist-4175585901/)

readmore 07-30-2016 07:20 PM

Booting to initramfs, gave up waiting, /dev/disk/by-uuid/xxxx does not exist
 
This is resolved now. Found a solution on askubuntu, but I dont need anymore online accounts. So documenting here on LQ.

Problem: Computer started booting to initramfs and gave messages: ... gave up waiting ... /dev/disk/by-uuid/xxxx does not exist

How I broke it: This happened after running "update-initramfs -u" and rebooting. (Was troubleshooting a different problem). Just prior to running update-initramfs, I had run "depmod `uname -r` /lib/modules/3.16.0-4-amd64/kernel/drivers/net/ethernet/realtek/r8169.ko.

Then system came back up to initramfs, with the ash (?) shell. There were also some errors about various modules. Missing I think. Some webpages/forums said just type exit at ash shell and system will come up. That didnt work in this case.

Cause? I'm guessing the dependency list was built incomplete into the kernel because I specifically named a file(?), and/or I didn't do grub stuff at the time. man depmod: "-a, --all Probe all modules. This option is enabled by default if no file names are given in the command-line." The solution below I had first tried w/out the depmod command but it failed. Then running it without specifying any file (i.e. relying on the default of -a); then the problem cleared.

Anyway, the resolution for me was; Based on: http://askubuntu.com/a/516471

(Change /dev/sda1 to wherever your install is.)

- Booted off debian install-cd, chose rescue mode, dropped to busybox shell, and:

# mount /dev/sda1 /mnt
# mount --bind /dev /mnt/dev
# mount --bind /proc /mnt/proc
# mount --bind /sys /mnt/sys
# chroot /mnt
# depmod `uname -r`
# update-initramfs -u
# update-grub
reboot

HTH someone.

kiyop 07-30-2016 11:27 PM

Quote:

Originally Posted by readmore (Post 5583511)
How I broke it: This happened after running "update-initramfs -u" and rebooting. (Was troubleshooting a different problem). Just prior to running update-initramfs, I had run "depmod `uname -r` /lib/modules/3.16.0-4-amd64/kernel/drivers/net/ethernet/realtek/r8169.ko.

Why did you do such a stupid thing? :D
Is there any web page which suggested it?
Code:

man depmod
shows:
Quote:

If filenames are given on the command line, only those modules are examined (which is rarely useful unless all modules are listed).

readmore 07-31-2016 08:23 AM

what!? rtfm? pffft...dive in gunz blazin man.

Like I said...was troubleshooting a diff problem. lol, anyways, I got into it I got out of it.

sgosnell 08-01-2016 01:38 PM

Hanging boot when the device does not exist usually means a borked fstab file. Correcting that usually fixes the problem without having to do anything else. But Ubuntu forums can give strange advice, which sometimes even works.


All times are GMT -5. The time now is 03:27 PM.