LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-11-2004, 05:54 PM   #1
helios22
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Boot to text (instead of GUI)


Hello-

I'm wondering how I can switch to boot to text login instead of the graphical login. How would I go about doing this?

There are no problems booting, I would just like to boot into text mode instead of graphical mode everytime.

Thank you
 
Old 04-11-2004, 06:02 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Edit your /etc/inittab file - change the default to (I think) 3 - or whatever the number is for Debian.

Next time you boot up, it will be in text mode. You'll then have to enter startx to start X.
 
Old 04-11-2004, 06:43 PM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Depends on your desktop manager - is it GDM (for Gnome), KDM (for KDE), or plain XDM. Check /etc/rc2.d/ if there is something like S99gdm, S99kdm, or S99xdm. You need to disable this file (which is actually a link to similar file in /etc/init.d/) somehow.

You can rename it something like offS99xdm or you can make it non-executable or you can simply remove it.

One way is to write in command line (as root) 'update-rc.d -f xdm remove' (supposing it's xdm you want to disable). See 'man update-rc.d' for further info. To make Debian boot again straight to gui you can do (as root) 'update-rc.d xdm defaults'.
 
Old 04-11-2004, 08:31 PM   #4
theabyyss
Member
 
Registered: Aug 2001
Location: CT
Distribution: Debian Sarge (2.6.9-albooksleep) on a PPC
Posts: 64

Rep: Reputation: 15
if you edit inittab i'm pretty sure it's actually runlevel 2 for console. or you could change your bootloader to pass the parameter "2" to the kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
change the option to boot from gui to text boyd98 AIX 3 01-12-2005 11:16 AM
GUI vs text editors R00ts Programming 9 07-20-2004 06:01 AM
changing boot option from gui to text buffed317 Fedora 1 07-06-2004 06:21 PM
GUI gone.. just text login mgbgt Linux - Newbie 4 06-16-2003 01:05 AM
Newbie, making linux boot to text instead of GUI Irongut Linux - Software 4 05-14-2003 07:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration