LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 07-13-2007, 08:35 AM   #16
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,618

Rep: Reputation: 104Reputation: 104

Looks like you are trying to start it as root this is disabled in Debian try as your normal user.
 
Old 07-13-2007, 10:40 PM   #17
Mario1776
LQ Newbie
 
Registered: Jun 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Booting to the command line, logging in as a user other than "root", and entering "startkde" produced the same results as it did when I was logged in as root.

Running "xinit /usr/bin/startkde" at the command line worked, KDE started.

I have found out how to do everything that I wanted to with regards to booting to text. I have plenty of questions about other topics, but I think this thread is done. Thanks for all the help.

P.S. Logging in as root is indeed disabled at Debian's GUI Login Manager BUT when booting to the command line I have been able to log in as "root" then enter "startx" to run Gnome or enter "xinit /usr/bin/startkde" to run KDE.
 
Old 07-15-2007, 12:50 PM   #18
smellypenguin
LQ Newbie
 
Registered: Jun 2007
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by Mario1776
P.S. Logging in as root is indeed disabled at Debian's GUI Login Manager BUT when booting to the command line I have been able to log in as "root" then enter "startx" to run Gnome or enter "xinit /usr/bin/startkde" to run KDE.
if u want to login as root then add the following line to gdm.conf
(but, generally not recommended for security reason.)

/etc/gdm/gdm.conf

[security]
AllowRoot=true

so far, no one mentioned about editing this file:
/etc/X11/default-display-manager
(though I'm not sure that DEC system has the same file as x86 has)

#/usr/bin/gdm

commenting out this line is the easiest way to disable graphical login.

if u do so, then create a file named ~/.xinitrc which contains the following line:
exec gnome-session

or
exec startkde

and issue the command: startx
to start Gnome or KDE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a file that Linux writes upon boot that is the EXACT text as the boot screen lostboy Linux - General 21 01-08-2008 02:10 PM
grub issues: dual boot Debian i386 & Debian amd64 ErrorBound Debian 1 03-09-2007 07:41 PM
how boot in text-mode on Debian? xcore_on Linux - Newbie 8 04-01-2006 02:15 PM
switching graphical boot up to text boot up? chunlee Linux - Newbie 4 12-03-2004 03:55 AM
How to turn text anti-aliasing globally off in Debian? sylph Linux - Newbie 2 05-24-2004 05:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration