-   Debian (
-   -   Boot problem with Debian (grub) and hardware RAID 1 (

kampmannpeine 11-06-2010 06:11 AM

Boot problem with Debian (grub) and hardware RAID 1
Well I had a boot problem with a two-disk hardware RAID 1 server (Fujitsu Primergy TX 100 S1).

Though install went well and also the installation of Grub there was no rebooting after install ... and the reboot into "rescue" did not bring the wanted results.

I also installed other versions of Linux (Suse 11.3 and the last Ubuntu) all with the same effect

I also tried the new grub2 from Debian ... no success

After installation and retracting the CD one would expect a boot process from hardware, however BIOS told me "no operating system found"

I tried also to go to the rescue system of Debian: same effect

Anybody knows??

tia Jörg

fordeck 11-06-2010 08:31 AM

Are you using software RAID or hardware RAID? If your using software RAID then you need to make sure that /boot is not in your mirrored array, because the software needs to be readable in order to build the RAID 1 mirror. This is kind of like the which came first the chicken or the egg.



kampmannpeine 11-07-2010 06:40 AM

Thanks, this Fujitsu server has hardware raid1. When the Bios (and later the LSI after <ctrl>-M) comes up LSI says for each drive "READY" ... alternatively "ONLIN" is possible but not used.

So the question is clear, how does DEBIAN recognize the hardware raid 1?

kind regards

All times are GMT -5. The time now is 06:40 PM.